Project

General

Profile

Actions

Bug #202

closed

"Invalid character" error when downloading UV-5R

Added by David Bowman over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
06/07/2012
Due date:
% Done:

100%

Estimated time:
Chirp Version:
daily
Model affected:
Baofeng UV-5R
Platform:
Windows

Description

During d/l from radio the error " Value contains invalid character X" in CHIRP daily-20120607. No debug file found in chirp folder.


Files

debug.log (4.38 KB) debug.log David Bowman, 06/07/2012 04:58 PM

Related issues

Blocked by Bug #207: Ref bug 202ClosedDan Smith06/08/2012

Actions
Actions #1

Updated by Dan Smith over 10 years ago

  • Subject changed from Baofeng UV-5R to "Invalid character" error when downloading UV-5R
  • Assignee set to Dan Smith
  • Priority changed from Immediate to Normal
Actions #2

Updated by Dan Smith over 10 years ago

Please attach your debug log and then review:

http://chirp.danplanet.com/projects/chirp/wiki/How_to_report_issues

Actions #3

Updated by Jim Moss over 10 years ago

Dan Smith wrote:

Please attach your debug log and then review:

http://chirp.danplanet.com/projects/chirp/wiki/How_to_report_issues

Another user with same issue on 20120607 daily build re: Baofeng UV-5R "Invalid character" on download.

Here is a dump of my debug log:
CHIRP daily-20120607 on WinVista/7 (Python 2.7.2)
Registered Alinco_DR03T = DR03Radio
Registered Alinco_DR06T = DR06Radio
Registered Alinco_DR135T = DR135Radio
Registered Alinco_DR235T = DR235Radio
Registered Alinco_DR435T = DR435Radio
Registered Alinco_DJ596 = DJ596Radio
Registered Jetstream_JT220M = JT220MRadio
Registered Kenwood_TH-D7 = THD7Radio
Registered Kenwood_TH-D7G = THD7GRadio
Registered Kenwood_TM-D700 = TMD700Radio
Registered Kenwood_TM-V7 = TMV7Radio
Registered Kenwood_TM-G707 = TMG707Radio
Registered Kenwood_TH-F6 = THF6ARadio
Registered Kenwood_TH-F7 = THF7ERadio
Registered Kenwood_TM-D710 = TMD710Radio
Registered Kenwood_TH-D72 = THD72Radio
Registered Kenwood_TM-V71 = TMV71Radio
Registered Kenwood_TH-K2 = THK2Radio
Registered Kenwood_TM-271 = TM271Radio
Registered Icom_7200 = Icom7200Radio
Registered Icom_7000 = Icom7000Radio
Registered Icom_746 = Icom746Radio
Registered Yaesu_FT-2800M = FT2800Radio
Registered Yaesu_FT-60 = FT60Radio
Registered Yaesu_FT-7800 = FT7800Radio
Registered Yaesu_FT-8800 = FT8800Radio
Registered Yaesu_FT-8900 = FT8900Radio
Registered Yaesu_FT-817 = FT817Radio
Registered Yaesu_FT-817ND = FT817NDRadio
Registered Yaesu_FT-817ND_US = FT817NDUSRadio
Registered Yaesu_FT-857_897 = FT857Radio
Registered Yaesu_FT-857_897_US = FT857USRadio
Registered Generic_CSV = CSVRadio
Registered ARRL_Travel_Plus = TpeRadio
Registered Generic_XML = XMLRadio
Registered Icom_IC-2100H = IC2100Radio
Registered Icom_IC-2200H = IC2200Radio
Registered Icom_IC-2720H = IC2720Radio
Registered Icom_IC-2820H = IC2820Radio
Registered Icom_IC-91_92AD = IC9xRadio
Registered Icom_IC-91_92AD_ICF_File = IC9xICFRadio
Registered Icom_IC-Q7A = ICQ7Radio
Registered Icom_IC-T70 = ICT70Radio
Registered Icom_IC-W32A = ICW32ARadio
Registered Icom_IC-V82_U82 = ICx8xRadio
Registered Icom_ID-31A = ID31Radio
Registered Icom_ID-800H_v2 = ID800v2Radio
Registered Icom_ID-880H = ID880Radio
Registered Kenwood_HMK = HMKRadio
Registered Baofeng_UV-5R = BaofengUV5R
Registered Yaesu_VX-3 = VX3Radio
Registered Yaesu_VX-5 = VX5Radio
Registered Yaesu_VX-6 = VX6Radio
Registered Yaesu_VX-7 = VX7Radio
Registered Yaesu_VX-8_R = VX8Radio
Registered Yaesu_VX-8_DR = VX8DRadio
Registered Vertex_Standard_VXA-700 = VXA700Radio
Registered Wouxun_KG-UVD1P = KGUVD1PRadio
Registered Wouxun_KG-UV6D = KGUV6DRadio
Registered Wouxun_KG-UV6X = KGUV6XRadio
Registered Puxing_PX-777 = Puxing777Radio
Registered Puxing_PX-2R = Puxing2RRadio
Registered Baofeng_UV-3R = UV3RRadio
Registered TYT_TH-UV3R = TYTUV3RRadio
Skipping existing stock config
Skipping existing stock config
Skipping existing stock config
Skipping existing stock config
Skipping existing stock config
Skipping existing stock config
Skipping existing stock config
Skipping existing stock config
User selected Baofeng UV-5R on port COM1
Clone thread started
Ident:
000: aa 42 46 42 32 33 31 dd .BFB231.

Appending element to top
Appending element to top
Appending element to squelch
Appending element to step
Appending element to save
Appending element to vox
Appending element to abr
Appending element to tdr
Appending element to beep
Appending element to timeout
Appending element to voice
Appending element to screv
Appending element to mdfa
Appending element to mdfb
Appending element to bcl
Appending element to autolk
Appending element to wtled
Appending element to rxled
Appending element to txled
Appending element to ani.code
Appending element to ani.code
Appending element to ani.code
Appending element to ani.code
Appending element to ani.code
-- Exception: --
Traceback (most recent call last):
File "chirpui\clone.pyo", line 223, in run
File "chirp\uv5r.pyo", line 267, in sync_in
File "chirp\uv5r.pyo", line 258, in process_mmap
File "chirp\uv5r.pyo", line 526, in get_settings
File "chirp\settings.pyo", line 124, in init
File "chirp\settings.pyo", line 139, in set_value

InvalidValueError: Value contains invalid character `ÿ'

Clone failed: Value contains invalid character ÿ'
Clone thread ended
--- Exception Dialog: Value contains invalid character
ÿ' ---
Traceback (most recent call last):
File "chirpw", line 68, in

AttributeError: 'NoneType' object has no attribute 'split'

C:\Chirp\6-7-12\library.zip\chirpui\mainapp.py:442: PangoWarning: Invalid UTF-8 string passed to pango_layout_set_text()

Jim Moss

Actions #4

Updated by Dan Smith over 10 years ago

  • Status changed from New to Resolved
  • Target version set to 0.3.0

Fixed in r1664.

Since I can't reproduce this, I'll leave this in "resolved" state. Please test tomorrow's daily build and report back here.

Thanks!

Actions #5

Updated by Jim Moss over 10 years ago

Dan Smith wrote:

Fixed in r1664.

Since I can't reproduce this, I'll leave this in "resolved" state. Please test tomorrow's daily build and report back here.

Thanks!

Will test tomorrow's build and report back on this Issue tag.

73's
Jim, N9YKG

Actions #6

Updated by David Bowman over 10 years ago

Actions #7

Updated by Jim Moss over 10 years ago

Jim Moss wrote:

Dan Smith wrote:

Fixed in r1664.

Since I can't reproduce this, I'll leave this in "resolved" state. Please test tomorrow's daily build and report back here.

Thanks!

Will test tomorrow's build and report back on this Issue tag.

73's
Jim, N9YKG

Tested build 20120608 and Baofeng UV-5R reads and writes correctly.

73's
Jim Moss N9YKG

Actions #8

Updated by Tom Hayward over 10 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF