Project

General

Profile

Actions

Bug #283

closed

VX-7: insert-row scribbles on the power column

Added by David Griffith over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
-
Start date:
08/28/2012
Due date:
% Done:

0%

Estimated time:
Chirp Version:
daily
Model affected:
VX-7
Platform:
All

Description

Suppose you have an image from a Yaesu VX-7 and want to insert some blank entries, you right-click and select "insert-row" above or below. This works, but every entry after the new blank spot will have its power column changed to L1.


Files

scribble.img (15.8 KB) scribble.img David Griffith, 09/07/2012 09:54 PM
bakersfield.img (15.8 KB) bakersfield.img sample image file David Griffith, 09/10/2012 07:51 PM

Related issues

Related to Bug #214: VX-7R: Insert rowClosedDan Smith06/11/2012

Actions
Actions #1

Updated by David Griffith over 10 years ago

Bug is also triggered when pasting 1.25m frequencies. This time ALL power levels are set to L1. A dialog box pops up and flashes for each entry pasted this message "Invalid value for this field" then on the next line "list.index(x): x not in list".

Actions #2

Updated by David Griffith over 10 years ago

Load a blank image and write some stuff to it with the power levels at "hi". Upload this to the radio. All channels uploaded will have the power setting set to L1. Also, start with a blank image and write some stuff to it. Save it, then exit Chirp. Sometimes upon reloading, all the power levels will be set to L1.

This is a very infuriating bug.

Actions #3

Updated by Filippi Marco over 10 years ago

  • Status changed from New to In Progress
  • Assignee set to Filippi Marco
  • Platform changed from Linux to All

I can reproduce it, that's good.

Please create 4 memories with the 4 different power levels, clone to chirp, save the image and send it here.
If you can please add also 2 mem on 1.25m with the two allowed power level.
I then need to know what power level is shown by the radio for each memory.

I already pointed out the wrong line of code but unluckily my vx7 cable is gone dead and I can't test myself :(

Actions #4

Updated by David Griffith over 10 years ago

Here is the requested image.

Actions #5

Updated by Filippi Marco over 10 years ago

Sorry but ... do the memory 1 shows on the radio HI or L1? And the 5 is L2 or L1?

Actions #6

Updated by David Griffith over 10 years ago

From 1 to 6 the power levels are as follows: Hi, L3, L2, L1, L2, L1. The last two (5 and 6) are 1.25m frequencies.

Actions #7

Updated by Filippi Marco over 10 years ago

  • Status changed from In Progress to Closed

Tnx David
I sent the patch the developper list and it will be included in next days daily build

Actions #8

Updated by David Griffith over 10 years ago

I tried this and the bug remains.

Actions #9

Updated by David Griffith over 10 years ago

Here's a sample image file to play with

Actions #10

Updated by Filippi Marco over 10 years ago

  • Status changed from Closed to Feedback

I'm unable to reproduce it after the patch, so I'm waiting some more details from David.

Actions #11

Updated by David Griffith over 10 years ago

False alarm. Somehow my local repository didn't update itself correctly. I see no trace of the bug.

Actions #12

Updated by Filippi Marco over 10 years ago

  • Status changed from Feedback to Closed
Actions

Also available in: Atom PDF