New Model #2999

Kenwood TK-760G commercial radio support

Added by Pavel Milanes almost 7 years ago. Updated over 6 years ago.

Status:Closed Start date:11/13/2015
Priority:Normal Due date:
Assignee:Pavel Milanes % Done:

100%

Category:-
Target version:-
Chirp Version:daily Equipment Loan Offered:Yes

Description

I own a Kenwood TK-760G commercial radio (don't be confused with TK-760, not G model)

I have started the development of the driver, I was stalled by a checksum on every packet of data, but solved that I'm working on it as a hobby project; I will have in matter of hours a script for effectively dump the radio memory.

I don't have a due date for it, and will work on weekends on the mapping of the memory and everything else. Junior python coder, so be easy on my.

Cheers.

tk760g.py - Beta version of the driver, little bank support yet. (46.6 kB) Pavel Milanes, 12/25/2015 11:13 pm

Kenwood_TK-760G.img - Kenwood TK-760G radio image (32 kB) Pavel Milanes, 12/25/2015 11:13 pm

tk760g.py - Release candidate driver, Basic Settings, full bank support but will fail the tests in chirp due to different paradigm. (49.6 kB) Pavel Milanes, 12/27/2015 05:43 pm


Related issues

related to Bug #3119: run_tests script, bank testing don't work with commercial... Closed 01/02/2016
related to Bug #3211: Kenwood TK-260G bug Closed 01/24/2016
related to Bug #3213: Kenwood TK-270G Closed 01/24/2016

Associated revisions

Revision 2619:c64c57a71642
Added by Pavel Milanes (CO7WT) over 6 years ago

[TK-760G] New Model, support the VHF part of the Kenwood 60G family, fix #2999

This patch is the support to the VHF part of the Kenwood 60G family,
and must be appplied after the patch for the issue #3119

Revision 2633:fcf2cdc476e6
Added by Pavel Milanes (CO7WT) over 6 years ago

[PATCH][TK-760G] Fix author declaration, fixes #2999

Revision 2647:488f105f54e6
Added by Pavel Milanes (CO7WT) over 6 years ago

[PATCH][TK-760G] Improved program mode + UHF mobile models, fixes #2999

Improved procedure to enter in program mode, it will try 10 times before
fail, added also a lot of debug info.

Added support for the mobile UHF modes:

TK-860G/862G/868G with many variants.

73

Revision 2660:30fd4d736864
Added by Pavel Milanes (CO7WT) over 6 years ago

[PATCH][TK-760G] Fix the driver in windows and CH with no TX, fixes #2999

The driver was not working on windows, I take a while to learn by the
hard way that the timing on windows is different from linux & mac.

Now it works, fixed also the offset = off when you set a channel.

I have extended the edges of the bands when they are very close to
the ham bands, that's the way we use this radios in Cuba, for example:

The radios with the default sub-band segment 148-174 Mhz can be pulled
down to 144 Mhz in the lower edge with no problem, this mod works also
in UHF.

History

Updated by Pavel Milanes almost 7 years ago

  • File tk760g_v0.1.py added

Some work and advance in this weekend project...

Attached is the pre-alpha code of the driver, it can read & shows the channels, plus a write back to the radio, the settings are in mapping process yet, and no provision to modify the memories (it's but not functional now, so disabled).

It has no provision to map the radio banks by now, so all mems will show as just a single list.

BONUS: I borrowed a hand held TK-272G and get a dump of it's mem, it's quite the same, even disabling the ident code I can read it in chirp, just the settings seems wrong, aka: it may be easy to make a driver to this hand held based on this driver.

WARNING: The driver has not been run against chirp test bed, so some bugs may reside on it.

73, CO7WT, Pavel.

Updated by Pavel Milanes almost 7 years ago

News about this,

I have mapped almost all the MEM parts of this radio, just a few bytes in the channel definition that resist any logic. I can't find what this bytes are for !?

I have done a handful of test but appears that this kind of radio will resist until the end about this strange byte meaning. I have done some test with the most common values and the radio works as expected (from my point of view) but when you read it with the original soft and re-write it, the values changes with no apparent change in radio's work... strange.

I have done the modify memory def (remains to solve the strange bytes issue) and I'm working on the setting parts, first the show and then the modify part.

I have work to do ahead with the sub-version radio identification, even on every single radio model (let's say TK-760G) there are variations in frequency range and/or option, to name a few:

  • TK-760G K (High VHF band 148-174)
  • TK-760G K2 (Low VHF band 136-162)
  • TK-760G N (New version High VHF band)
  • TK-760G E (NE) (Europe version?)
  • TK-760HG * (high power versions for each sub-model)

And all of them have a little variations in the identification codes, how to manage this on chirps remains TBD yet.

I hope to have a 90% working version as late as early January.

BONUS: Confirmed, this radio is part of what Kenwood named as "The 60-G series", so TK-26xG, TK-27xG, TK-36xG, T-76xG y TK-86xG; so chances are high for this entire family to be supported, the code will still focused on the TK-760G K2 until I have at hands each other member of the family to test it's support.

Updated by Pavel Milanes almost 7 years ago

  • % Done changed from 30 to 80
  • Equipment Loan Offered changed from No to Yes

Happy Holidays.

I have solved now the problems mentioned in the last post, the driver has now full capabilities in the memory manipulation.

It assume the bank structure in the radio and preserve it when you make a change to one channel assigned to a bank, and even deleting a channel in a bank works, or deleting all channels in a bank erase the pertinent bank.

This kenwood memmap is tricky but not impossible to hack.

Just new channels are assigned to bank #1 by now. There is no provision to modify the channel - bank assignation yet.

I set 80% completion and will have 2 milestones to get 100% completion and patch summit for inclusion:

  • Settings support, at the beginning not all settings, but the most "ham" ones will be on it.
  • Full bank support.

Each one with a 10% weight.

Enjoy the holiday season festivities, HNY!

Updated by Tom Hayward almost 7 years ago

This is great! Thanks for your efforts!

Updated by Pavel Milanes almost 7 years ago

  • Status changed from New to In Progress
  • Priority changed from Low to Normal

Thanks to you for bring Chirps to the masses and make it GPL for us to improve it.

I forgot to mention that the driver now knows how to handle the different variants of EACH radio it will support (see comment #2 about variants)

Also a Xmas gift: This driver will handle the entire Kenwood 60G family easily, I have tested TK-272G/270G/260G and all works 100% and have the SAME memmap, just remains the settings that one or the other model don't support.

This is only the VHF part of the family, the UHF part can be adapted with no hassle as I see, but I will need some radios to test (No UHF versions here around)

Cheers.

Updated by Pavel Milanes almost 7 years ago

Settings support is completed, as I mentioned in a recent post for now just the more ham friendly ones are on it.

I have to understand the bank model principles in chirp yet, and then apply that to this driver to add full bank support.

For the impatients and courious, attached is the beta driver and TK-760G image to play.

This driver is only for the VHF part of the family, and is capable of manage this radios and his variations:

  • Portables VHF TK-260/270/272/278
  • Mobiles VHF TK-760/762/768

The UHF part of the family is easily adaptable, but need radios in hand to test it.

As a beta codes, may include bugs, it's not for production, just testing.

73, HNY.

Updated by Pavel Milanes almost 7 years ago

  • File deleted (tk760g_v0.1.py)

Updated by Pavel Milanes almost 7 years ago

  • File tk760g.py added
  • % Done changed from 90 to 100

Last milestone done, but a problem arose:

The default chirp paradigm about banks is not compatible with this kenwood radios bank's paradigm.

If you want to take a peek on it see [[http://intrepid.danplanet.com/pipermail/chirp_devel/2015-December/003658.html]] and add your 5 cents to this, here or in the devel mailist.

Until I have a definitive solution to this, the patch will not be pushed to the daily build.

The RC driver code is attached to test, all working ok, but it will make the run_tests script fail, you have been warned.

Cheers CO7WT.

Updated by Pavel Milanes almost 7 years ago

In the last post I mentioned a problem with bank management, that is addressed in issue #3119 and it's linked now to this issue.

A patch is on the queue to resolve issue #3119
A patch is on the queue to resolve this issue (#2999)

Updated by Pavel Milanes over 6 years ago

  • Status changed from In Progress to Resolved

Support for this radio family is on chirp since 2016/January/10.

Issue resolved, I will leave a time to report bugs and then will close this issue.

73 Pavel, CO7WT

Updated by Pavel Milanes over 6 years ago

  • Status changed from Resolved to Closed

Close to this issue, it support the radio or which it's build, there are some issues about different firmware but we will address that on other issues.

Also available in: Atom PDF