Bug #3737

TH-9800 Won't communicate with most recent build

Added by William Kisse about 4 years ago. Updated 5 months ago.

Status:Closed Start date:06/11/2016
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:All
Model affected:TYT TH-9800

Description

Build I downloaded - chirp-daily-20160604-installer - works perfectly with my TH-9800

Build chirp-daily-20160611-installer will not communicate with TH-9800.

Associated revisions

Revision 2719:b656da94c361
Added by Nathan Crapo about 4 years ago

Make radio model identification for TH-7800 and TH-9800 more specific so they don't interfere with each other, or completely different radios. The TH-7800 was ahead of the TH-9800 in the list of Radios to identify against, so Chirp would use it for TH-7800 and TH-9800 radios. This patch makes both TH-7800 and TH-9800 drivers check their model more carefully so order of Radios Classes doesn't matter. It's more robust that way.

TH-7800 seems to use "TH9800" for a model string too. Check for a "TH9800" or "TH7800" string in the th7800.py driver in case TYT doesn't consistently set the model or in case owners change their model name.

Fixes #3737.

History

Updated by Nathan Crapo about 4 years ago

I'm guessing the model detection code isn't working right in the TH-7800 and TH-9800 drivers. I will see if I can fix that.

William, can you provide your debug log? If my theory is correct, I think you can temporarily work around the issue by ensuring TH-9800 is selected before you try to do an upload or download to/from your radio. I'm guessing CHIRP has selected TH-7800 instead. Once I fix the model match code you won't have to do that anymore.

Updated by Nathan Crapo about 4 years ago

Ignore my last suggestion to force the model - it doesn't work. I just submitted a patch to fix the issue. I was able to reproduce the issue locally without either radio by:
1) Run chirp
2) Load TH-9800 from tests/images/TYT_TH-9800.img
3) Select Radio->"Upload to Radio"

The model incorrectly shows as TH-7800. TYT TH-7800 files identify as TYT TH-7800. This is because the code in both drivers is not specific enough.

Unfortunately, TYT chose to use "TH9800" as a model name for both radios: TH-7800 and TH-9800. Maybe other TH-7800 owners have something different? I used the band-limit registers to determine what model it really was. I also added a check for TH9800 or TH7800 in the TH-7800 model check in case TYT fixes this at some time or users update it in their own radios with the OEM software. Hopefully that will be more robust.

Updated by William Kisse about 4 years ago

My most sincere thanks for your prompt attention and time to resolution.

Bravo!

73,

Bill
W3MSH

Updated by Bernhard Hailer 5 months ago

  • Status changed from New to Closed
  • Priority changed from High to Normal
  • Target version set to chirp-daily
  • Chirp Version changed from 0.4.0 to daily
  • Model affected changed from (All models) to TYT TH-9800
  • Platform changed from Windows to All

No more input by submitter, looks like this has been fixed for good.

Also available in: Atom PDF