Bug #4563

TYT TH-9800+ (PLUS version) - Failed to communicate with the radio: Radio sent a short block.

Added by Justin Richeson over 3 years ago. Updated 3 months ago.

Status:Feedback Start date:02/26/2017
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:Windows
Model affected:TYT TH-9800

Description

BUILD daily-20170222, Windows 10 - Trying to read from radio errors: "Failed to communicate with the radio: Radio sent a short block."
Using USB -> FTDI -> USB Female Header -> usb cable -> radio.
FTDI -> USB:
GND -> Black (cable ground, not shield)
TX -> White
RX -> Green

Red & USB Shield ground are N/C.

Starts read but almost immediately errors. This setup is working with the included TYT software (2.0.8).

debug.log included. Noted bug 3737, but didn't see any attached log...not sure if this is related. It doesn't seem like this since it looks like the log shows it loading the 9800 materials not the 7800.

debug.log (18.6 kB) Justin Richeson, 02/26/2017 02:06 pm

debug.log (28.3 kB) DJ kourampies, 05/21/2020 01:22 am


Related issues

related to Bug #2983: TH 9800 can't communicate Rejected 11/07/2015

History

Updated by Bernhard Hailer 4 months ago

  • Status changed from New to Feedback

Unfortunately, the debug log doesn't tell much.
Have you been able to resolve this on your own since you submitted this?
Have you tried with a recent version since you submitted this?
If you haven't, and if you're still having this issue, provide another debug log, perhaps it logs more now. Thanks!

Updated by Shawn Graham 4 months ago

Same issue with a Mac. Can't seem to get the TYT cable to connect. Baofeng cables still work with other radios and chirp.

Updated by Justin Richeson 4 months ago

Yes, I was able to resolve this quite a long time ago...sorry...I thought this had been closed. I cannot remember the resolution at this time.

Updated by Bernhard Hailer 4 months ago

  • Status changed from Feedback to Closed
  • Target version set to chirp-daily

Resolved by submitter.
@Shawn Graham: you might want to open a new ticket, but please provide a debug log as described in the Wiki: "How To Report Issues". Thanks!

Updated by DJ kourampies 3 months ago

This happened to me too with my diy cable that works perfectly on the TH-7800. on the TH-9800 Plus with the diy cable I got the same error (while factory software worked).
With the factory cable both the TH-9800 Plus and TH-7800 work perfectly with chirp.

Both the diy and factory cable are CH340 based.

Updated by Bernhard Hailer 3 months ago

Ok, each of you, please attach debug logs you recorded while trying to connect with the radio.
My chief suspect would be insufficient electrical contact or a driver issue with the USB to Serial chip you're using.

Since the original issue has been resolved by the submitter, we would like to close this ticket asap.

Updated by DJ kourampies 3 months ago

Here it's the debug log from trying to read with the DIY cable on the TH-9800 Plus.
Other than the short block already mentioned, it produced a different error the second time. "Failed to communicate with the radio: Radio NAKed block"

Updated by DJ kourampies 3 months ago

Factory software works normally with the DIY cable, confirmed again.

Updated by Bernhard Hailer 3 months ago

  • Status changed from Closed to Feedback

Reopened. Found another ticket which might point to something substantial. #2983 describes a similar issue which was resolved by using newer computer hardware. Perhaps there's a timing issue in the serial code. Do you have the means to test this on a different computer?

Also available in: Atom PDF

prevent spam