Bug #3835

Yaesu VX-2R and VX-5R: download works, but ERROR partway thru upload.

Added by Michael Thompson almost 6 years ago. Updated almost 2 years ago.

Status:Closed Start date:07/16/2016
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Chirp Version:daily Platform:MacOS
Model affected:Yaesu VX-2, VX-5

Description

I have used CHIRP successfully on a Leixen radio, but am having trouble with my Yaesu handhelds.

I am able to download images from both the VX-2R and the VX-5R with no issues. The upload also appears to work for a while: the radios switch from wait to receive mode and the progress bar in the CHIRP dialog box shows progress until it is between 1/4 and 1/3 done. Then an ERROR appears on the radio and shortly thereafter the progress bar starts. On disconnecting the radios, I find that the memories previously programmed are now lost.

I have tried this multiple times, using different USB ports.

I tried a factory-reset on VX-2R, downloaded the image successfully, then, without making changes, immediately tried to upload the image. Same issue: about 1/3 of the way thru an ERROR appears on the radio.

Debug log is attached.

I'm using
- CHIRP daily-20160703
- MAC OS X 10.11.5
- Valley Enterprises cable RPC-Y1-U-FBM
- System report on USB
FT232R USB UART:

Product ID:    0x6001
Vendor ID: 0x0403 (Future Technology Devices International Limited)
Version: 6.00
Serial Number: AH03HC4T
Manufacturer: FTDI
Location ID: 0x14200000

Any help would be much appreciated. I seem so close, but yet so far.

debug.log (236 kB) Michael Thompson, 07/16/2016 06:09 am


Related issues

related to Bug #2019: I can download but can't upload to any of my FT-60's Closed 10/31/2014

History

Updated by Tom Hayward almost 6 years ago

  • Status changed from New to Feedback

I have seen this problem when the cable does not have a good connection. Try applying some lateral pressure to the connector while uploading to make sure it's making contact.

Updated by Michael Thompson almost 6 years ago

Thanks Tom. Unfortunately, no luck. I did try it 3 times on the VX-5R, pressing in different directions each time. Same result each time.

In any case, I doubt the physical connection is the issue. The symptoms seem to differ from those of a faulty connection: (1) the download from the radio never fails (2) the upload always starts off well, runs for for a fairly long time (haven't timed it, but probably 15 seconds or more), then always fails at exactly the same point on the progress bar. Also, I have exactly the same problem with two different radios (VX-2R and VX-5R).

Thanks, but I'm guessing the clues lie in the debug.log.

Updated by Jonathan Handler almost 6 years ago

This differs from my FT-60 situation in that I get nothing on upload. I download fine, just like the guys who reported this in 2014, but when I put my radio in RX and go to upload I get no progress and an instantaneous radio error. I am using a real DB-9 serial,cable to radio so I have no drivers or other related issues. I use Chirp for many radios and all work but this.

Updated by Michael Thompson almost 6 years ago

EL CAPITAN THE CULPRIT?

I now think this is likely an issue related to El Capitan and the various things I see posted about how OS X 10.11 handles drivers. I have been successful in getting the same Valley Enterprises cable... which is the first one recommended on the website's Mac OS tips page.... to work with a slightly older Macbook Air running Yosemite, but not with the original setup using El Capitan. With the same cable and Chirp build, things now seem to work on both the VX2r and the VX5R. >> So the open issue now is: How to get things running on El Capitan, i.e. OS X 10.11. <<

Updated by Tom Hayward almost 6 years ago

FWIW, I've never had any trouble on El Capitan. Sorry, I don't have a specific procedure for "never having any trouble".

Updated by Bernhard Hailer almost 2 years ago

  • Description updated (diff)
  • Chirp Version changed from 0.4.0 to daily
  • Model affected changed from (All models) to Yaesu VX-2, VX-5

Updated by Bernhard Hailer almost 2 years ago

  • Status changed from Feedback to Closed

Closed to lack of traffic on this ticket.
Please investigate USB drivers for the cables in use (see MacOS Tips).

Also available in: Atom PDF