Bug #4545

ICOM ID-51A Plus 2

Added by Justin Curti over 5 years ago. Updated about 2 years ago.

Status:Feedback Start date:02/20/2017
Priority:Normal Due date:
Assignee:- % Done:


Target version:chirp-daily
Chirp Version:daily Platform:All
Model affected:Icom ID-51A Plus 2


Using a MacBook Pro, when trying to clone a Icom ID-51A Plus 2, a error message pops up: "Failed to communicate with the radio: I can't talk to this model". I have tried cloning in clone mode as well as in normal mode. I do not know if I am doing something incorrectly, or if there is a communication issue between CHIRP and this Icom model. Likewise, I did not see any other post on this particular model having issues.

debug.log (30.5 kB) Peter Kringle, 08/28/2020 12:41 pm

Related issues

duplicated by New Model #7763: Icom ID-51E Plus2 Closed 04/04/2020


Updated by Scott Pettigrew over 5 years ago

I am also receiving this error on a daily build, installed on Linux Mint.

Updated by Gerry Carpinetti over 5 years ago

I have a ICOM ID-51A Plus 2 and receiving the same errors as mentioned above post on Windows 10

Updated by Mark MacConnell almost 5 years ago

Gerry Carpinetti wrote:

I have a ICOM ID-51A Plus 2 and receiving the same errors as mentioned above post on Windows 10

Anyone able to fix this problem. I just downloaded the most current version on Windows 10 and having this same problem.

Updated by Creede Lambard over 4 years ago

Not to turn this into a "me too" fest, but I'm having the same issue with this radio on both Windows 10 and Mac OS.

Updated by Bernhard Hailer over 2 years ago

  • Status changed from New to Feedback
  • Target version set to chirp-daily
  • Chirp Version changed from 0.4.0 to daily
  • Model affected changed from ID-51A Plus 2 to Icom ID-51A Plus 2
  • Platform changed from MacOS to All

Have you tried with a recent version since you submitted this?
If you haven't, and if you're still having this issue, please refer to the Wiki "How To Report Issues" and provide a debug log. Thanks!

Updated by Peter Kringle about 2 years ago

I just confirmed the same problem with MacOS 10.15.6 running CHIRP daily-20200827 I am attaching the debug log when i try both ID-51 and ID-51Plus options.

As a side note I also have an older ICOM 51 Plus which works perfectly, but the newer Plus2 does not.

Updated by Bernhard Hailer about 2 years ago

Thank you, the log is helpful. This radio has a new version number in its firmware:

[2020-08-28 12:39:39,639] chirp.drivers.icf - INFO: This model: 000: 33 90 00 03 00 00 00 00   3.......
[2020-08-28 12:39:39,639] chirp.drivers.icf - INFO: Supp model: 000: 33 90 00 02 00 00 00 00   3.......

A developer needs to look into it and see what it takes to talk with this version.

Also available in: Atom PDF