Feature #4547

Allow to change Icom IC-7100 CI-V address

Added by Dave Svab over 4 years ago. Updated 6 months ago.

Status:In Progress Start date:02/20/2017
Priority:Normal Due date:
Assignee:Kosta A. % Done:

50%

Category:-
Target version:chirp-daily
Chirp Version:daily Model affected:Icom live mode radios

Description

Refer #4329. I'm having exactly the same issue. Reads about 1 row a second, and all rows come back blank, with 'Error' in the Name column. Looks like a read timeout?

Settings:
  • daily_20170217
  • COM7 - USB to serial converter cable
  • Make - Icom
  • Model - IC 7100

Interestingly, the 'Auto Detect' did indeed identify the rig as a IC 7100, so I doubt the cable is the problem as was the case with #4329. Also, the same cable is being used with Icom's Remote Control software on this PC with that rig, and that software works perfectly, remotely controlling all the functions of the IC 7100. Wouldn't work if the cable was suspect.

Let me know if there is any other diagnostic data I should provide to allow you to diagnose/debug.

Thanks for the good work you guys are doing :)

PS: I am able to program my Baofeng 5 HT with no problems (using it's own different cable of course)

Associated revisions

Revision 3506:b3f648cc2d3c
Added by Kosta A. 5 months ago

Modified icomciv probe_model to use directory based driver search pattern. #4547

Revision 3590:3272e13f714e
Added by Kosta A. 5 months ago

Modified icomciv probe_model to use directory based driver search pattern. #4547

(cherry picked from commit 13f685de20e0905d301163aa18a0f91b9b1c41e0)

History

Updated by Dave Svab over 4 years ago

Ok, found the problem. Seems Chirp expects to communicate with its radio using CI-V address 88h. This is the default in the IC-7100 when shipped.

I had to change mine to be compatible with some other software, so mine was set to 70h.

Switching back to 88h solved the problem. Suggestion: make that a configurable parameter in the 'Read From Radio' dialog.

Let's close this issue.

Updated by Carlo Femia over 4 years ago

I have the same problem. Reads about 1 row a second, and all rows come back blank, with 'Error' in the Name column
Settings:
daily_20170309
COM15 - USB Cat cable (it work correctly with other software and other rtx)
Make - Icom
Model - IC 7100 (CI-V 88h or 70h)

Thanks

Updated by Bernhard Hailer over 1 year ago

  • Status changed from New to Feedback
  • Target version set to chirp-daily
  • Platform changed from Windows to All

A debug log might be helpful, please refer to the Wiki "How To Report Issues".

Updated by Bernhard Hailer about 1 year ago

  • Tracker changed from Bug to Feature
  • Subject changed from Icom IC-7100 read errors, no channels downloaded to Allow to change Icom IC-7100 CI-V address

This ticket was converted to a feature request, asking for a changeable CI-V address.

Updated by Kosta A. 6 months ago

  • Status changed from Feedback to In Progress
  • Assignee set to Kosta A.
  • % Done changed from 0 to 50
  • Model affected changed from ICOM IC-7100 to Icom live mode radios

Also available in: Atom PDF