Bug #4981

Numerous errors trying to send stuff to my radio

Added by James Statham almost 3 years ago. Updated about 1 month ago.

Status:Closed Start date:07/05/2017
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:Windows
Model affected:Retevis H777

Description

My radio is a Retevis H777 model. I tried to transfer a new image file and i get four errors.
The first issue is that on COM3 when i try to send it over it clones however the bar doesn't move at all i left it for an hour with no change. I cancelled the process seeing it wasn't going anywhere and tried again the the error was could not open port COM3: [Error 5] Access is denied. I then tried the other port listed i.e. COM9 which said Radio refused to enter programming mode (this was previously what happened on COM8 however when i uninstalled CHIRP and reinstalled it it switched to COM9 for some reason.)
I tried going through the various ports however all except COM4 said could not open port COM2: [Error 2] The system cannot find the file specified. Obviously not all of them said COM2 it was the number of the port respectively.
COM4 said could not open port COM4: [Error 121] The semaphore timeout period has expired.
They were the only four errors i got however if i restarted it would let me bring up the same non moving clone bar on COM3 before me cancelling it and the process repeating.
I've tried restarting, uninstalling everything and nothing has worked.

ProlificDrivers2.jpg (157.8 kB) Jim Unroe, 07/07/2017 07:37 pm

History

Updated by Jim Unroe almost 3 years ago

  • Status changed from New to Feedback

With Windows, you should not have to guess which com port to use. You should access Device Manager to see exactly which com port has been assigned to your programming cable.

Also, if your programming cable is one of many that has a counterfeit Prolific chip in it, the device driver automatically installed by Windows is incompatible, You will have to download, install and select the older Prolific v3.2.0.0 device driver as shown here.

Jim

Updated by James Statham almost 3 years ago

Hi Jim,
I've tried doing that and I've figured out it's COM7 I'm meant to be using however the problem persists as when i select COM7 the radio refuses to enter programming mode

Updated by Jim Unroe almost 3 years ago

While in Device Manager, see which driver is installed for the programming cable. If it is a Prolific device driver and it is not v3.2.0.0, then you will have to download, install and select the v3.2.0.0 driver per the instructions here.

As you can see in the attached screen capture, I have multiple Prolific device drivers installed for testing purposes. But for every day use I have the v3.2.0.0 device driver selected because it is compatible with the counterfeit chip that is in most Prolific chip based programmings cables. It latest Prolific driver automatically installed by Windows is intentionally incompatible with counterfeit Prolific chips.

Jim

Updated by Bernhard Hailer about 1 month ago

  • Status changed from Feedback to Closed
  • Priority changed from Urgent to Normal
  • Target version set to chirp-daily

No more feedback by submitter.

Also available in: Atom PDF