Feature #5081

Chirp launches but menu bar is all-grey on OS X

Added by Michael Robinson almost 3 years ago. Updated 2 months ago.

Status:Closed Start date:08/20/2017
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Model affected:(All models)

Description

When I lauch chirp-daily-20170714, the app appears to launch but no window appears. The menu bar appears greyed out, but clicking on menu items does display menu items. Clicking File -> Open results in no response from the app. If window focus is changed to another app, the Chirp menu bar does not re-appear when I click on the Chirp icon in the dock.

Chirp was previously installed and working on this computer, but has not been used in several months, likely since the OS X upgrade.

Running OS X 10.12.6

KK7DS Python runtime deleted and fresh install today.

History

Updated by Michael Robinson almost 3 years ago

Discovered the problem. For some reason the program window always opens by default on the secondary display that I often have turned off. This also explains the greyed out menu bar. Programs with windows only open on other displays show grey but usable menu bars on the displays that don't have active windows. So the problem is fixed.

Perhaps Chirp can be updated to start by default on the #1 display to avoid this issue in the future?

Updated by Bernhard Hailer 4 months ago

  • Tracker changed from Bug to Feature
  • Target version set to chirp-daily

Retargeted as "Feature Request", based on first comment to this ticket.

Updated by Bernhard Hailer 2 months ago

  • Status changed from New to Closed

This is probably more a problem with the desktop handler (MacOS). I don't think anything in Chirp can fix this.

Also available in: Atom PDF