Bug #631

Anytone AT-5888UV Fails to Download

Added by Ralph Jenkins over 9 years ago. Updated over 9 years ago.

Status:Closed Start date:02/27/2013
Priority:Normal Due date:
Assignee:Dan Smith % Done:

0%

Category:-
Target version:0.4.0
Chirp Version:0.3.0 Platform:Windows
Model affected:AT-5888UV

Description

CHIRP starts reading this radio gets to clone67 then stops and I get this.
"ERROR" An error has occurred-string index out of range.

debug.log (4.2 kB) Ralph Jenkins, 02/27/2013 01:30 pm

anytone.py (12.1 kB) Dan Smith, 02/27/2013 06:58 pm

debug.log (10.1 kB) Ralph Jenkins, 02/27/2013 08:40 pm

anytone.py (12.1 kB) Dan Smith, 02/27/2013 09:14 pm

debug.log (83.9 kB) Ralph Jenkins, 02/28/2013 05:25 am

debug.log - Debug Log (83.9 kB) Seth Stone, 02/28/2013 12:53 pm

anytone.py (12.1 kB) Dan Smith, 02/28/2013 05:34 pm


Related issues

related to Bug #6401: Slow Read Error on AnyTone AT-5888UV Feedback 01/23/2019
duplicated by Bug #633: Anytone AT-5888UV Rejected 02/27/2013

Associated revisions

Revision 1924:49de55116a55
Added by Dan Smith over 9 years ago

[anytone] Fix failure to download on Windows

Windows is really slow at parsing the bitwise structure for some reason,
which introduced such a significant delay in the download procedure
when parsing the flags for the optimized download step that the radio
quietly timed out. This splits the memory format up into just the bit needed
to do that step, which seems to improve performance enough to escape the
problem. However, some bitwise improvements are probably warranted.

Fixes #631

History

Updated by Dan Smith over 9 years ago

  • Subject changed from Anytone AT-5888UV to Anytone AT-5888UV Fails to Download

I need the debug log attached to this bug please.

Thanks!

Updated by Ralph Jenkins over 9 years ago

Ralph Jenkins wrote:
Dan there was no debug log just an error window.

CHIRP starts reading this radio gets to clone67 then stops and I get this.
"ERROR" An error has occurred-string index out of range.

Updated by Dan Smith over 9 years ago

There is always a debug log generated, even just for opening chirp itself. Please see the FAQ or How_to_report_issues for details.

Updated by Dan Smith over 9 years ago

  • Status changed from New to Feedback

Your debug log shows one of a few things:

Either:

1. Your radio is using a different and incompatible firmware version from mine. Can you tell from the OEM software what firmware version yours is? When and where did you purchase your radio from?
2. Your driver or cable is bad and is corrupting the communication with the radio
3. You chose the wrong serial port

Updated by Ralph Jenkins over 9 years ago

Firmware version 1.0.0 (2012-2013)
Ordered 11-28-2012 received 02-07-2013
www.ImportCommunications.com (Ed Griffin)
Cable works fine with OEM
The program is reading from the radio but it stops at clone67

Updated by Dan Smith over 9 years ago

The debug log you provided shows that the failure occurs during radio identification, which is early in the process, before any blocks have been downloaded. Perhaps in this specific case, the radio was still sitting at the last failed clone step when you captured this log?

Could you try power cycling the radio, starting fresh, and capturing a new debug log to attach here?

Thanks!

Updated by Ralph Jenkins over 9 years ago

Here is a fresh one.

Updated by Dan Smith over 9 years ago

I'm attaching a test module that can be loaded into your installation to generate some additional debug information for me. Please save it off as anytone.py and then do the following:

1. Close CHIRP
2. Power cycle your radio
3. Start CHIRP
4. Go to File->Load Module and choose the anytone.py file
5. Attempt to download your radio
6. Close CHIRP and attach your debug.log file here

Thanks!

Updated by Ralph Jenkins over 9 years ago

4. Go To File -there is no "Load Module"

There is-Go To File -"New" "Open" "Open stock config" "Quit"

Updated by Ralph Jenkins over 9 years ago

I figured it out.
Here you go.

Updated by Dan Smith over 9 years ago

Thanks, I'm attaching another one to gather more information based on what I saw. It's definitely puzzling though. Hopefully this will give me some ideas on things to try to actually make some progress.

Updated by Ralph Jenkins over 9 years ago

OK here it is.

Updated by Seth Stone over 9 years ago

I also have the same issue. Attached is my debug file.

Updated by Dan Smith over 9 years ago

  • Assignee set to Dan Smith
  • Target version set to 0.4.0

This is interesting, Seth's is actually the same issue. Fails in exactly the same place.

Are either of you guys able to test with your hardware but on a linux or OSX machine? I'll try to find time to cobble together a windows box to try this on soon, but I have to think that it's something quirky like a platform issue.

Thanks!

Updated by Dan Smith over 9 years ago

  • Status changed from Feedback to In Progress

Okay, I can reproduce it on Windows! Much easier to debug :)

Updated by Dan Smith over 9 years ago

Try this module. It disables the optimization, so the download will take a while, but should make it work for you guys. Please test and let me know.

Updated by Seth Stone over 9 years ago

With that module, I was able to get it to work. Next is the test to see if I can get the data from my Wouxun KG-UV6 to the Anytone 588.

Updated by Dan Smith over 9 years ago

Excellent, thanks. Would still appreciate verification of the real fix once I figure it out :)

For any usage issues, please ask on the mailing list.

Updated by Dan Smith over 9 years ago

  • Status changed from In Progress to Resolved

The fix is actually not so clear, because this was a timing issue. However, I think I've got it so that it won't be a problem for now. Future performance changes are really necessary to make this better.

Please let me know how tomorrow's build works. Thanks!

Fixed in r1924

Updated by Ralph Jenkins over 9 years ago

Sorry for such a late report been busy.

This module worked it completed the channel downloads.
As you said it downloaded rather slow but you know now that your on the right track.
Good Job !!

I will work with it a little more in the morning.

Updated by Ralph Jenkins over 9 years ago

Well it's almost morning !!

I find that I have to keep reloading the module in order for this to keep working.

I took and uploaded my Kenwood D710 channels to the Anytone appears to be fine no errors yet!

Updated by Dan Smith over 9 years ago

Yes, that's correct, you'll have to re-load the module each time you start chirp. Tomorrow's build will have my workaround in it, so if that works well, then you won't have to load the module anymore.

Glad to hear that it's working for you, thanks for the info!

Updated by Ralph Jenkins over 9 years ago

Sorry but just where is Tomorrow's build or is it done yet?

Updated by Ralph Jenkins over 9 years ago

Forget it I found it.
Downloaded it and it works like a charm.
Thank You !

Updated by Dan Smith over 9 years ago

  • Status changed from Resolved to Closed

Cool, thanks for your help and patience!

Also available in: Atom PDF