Bug #6431

BTech UV-50x3 programming

Added by David Elkins over 1 year ago. Updated 4 months ago.

Status:Closed Start date:02/08/2019
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:Windows
Model affected:BTech UV-50x3

Description

After setting the frequency, Tone mode DTCS, DTCS code 131, DTCS rx code 131, DTCS pol NN, duplex +, offset 5.000000 and mode FM. The DTCS rx code reverts to 23.
When I program my UV5R it works fine.


Related issues

related to Bug #8047: BTech - UV-50X3 (May Be Related to Issue#6431) Feedback 07/06/2020
duplicated by Bug #6437: UV-50x3 programming Closed 02/11/2019

History

Updated by David Elkins over 1 year ago

I suspect that I am the assignor and not the assignee?

Updated by Bernhard Hailer 9 months ago

  • Subject changed from UV-50x3 programming to BTech UV-50x3 programming
  • Status changed from New to Feedback
  • Assignee deleted (David Elkins)
  • Priority changed from High to Normal
  • Target version changed from 0.4.1 to chirp-daily
  • Model affected changed from UV-50x3 to BTech UV-50x3

Correct :-)
Please let us know whether the problem still exists in the daily builds.

Updated by Bernhard Hailer 5 months ago

  • Status changed from Feedback to Closed

No more feedback by submitter.
Please let us know in case this ticket should be reopened.

Updated by Jim Unroe 4 months ago

CHIRP is working as intended and sending the correct settings to the radio (I dug out my BTECH UV-50X3 to double check). You are just don have a complete understanding how CHIRP is configured for the various selective call scenarios.

When Tone Mode is set to DTCS, the value in the DTCS Code field is used for both the TX DTCS code and the RX DTCS code. The default value (023) in the DTCS Rx Code field is unused and ignored by CHIRP.

Tone Mode = DTCS
DTCS Code = (value used for both TX DTCS code and RX DTCS code)
DTCS Rx Code = unused

The only time you will use the DTCS Code field and DTCS Rx Code field at the same time is when they are asymmetrical (not the same). In that case you would be using the Cross Mode field to set it up.

Tone Mode = Cross
Cross Mode = DTCS->DTCS
DTCS Code = (value used for TX code and not the same as RX code)
DTCS Rx Code = (value used for RX code and not the same as TX code)

So when Tone Mode is set to Cross and Cross Mode is set to DTCS->DTCS and both the DTCS Code field and the DTCS Rx Code field are set to the same DTCS code value, CHIRP notices and changes Tone Mode to DTCS and changes the unused and ignored DTCS Rx Code field to the default value (023) which would be the preferred equivalent.

In addition, you must have disabled Hide Unused Fields (enabled is the default). With Hide Unused Fields enabled, the DTCS Rx Code field would have been " " {blank} to indicate that this field is not used when Tone Mode is set to DTCS. I would recommend that you re-enable Hide Unused Fields so that the unused and ignored fields will be once again hidden. Then you will know that "blank" fields don't require a value.

For more information, you can review these guides.
Understanding CHIRP's columns
CHIRP Programming Reference

Jim KC9HI

Also available in: Atom PDF

prevent spam