New Model #6985

QYT KT-8R

Added by Ed Hempstead 11 months ago. Updated 6 months ago.

Status:Closed Start date:08/15/2019
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Equipment Loan Offered:Yes

Description

Didn't see anyhting about this new radio. Quad band from QYT. Any chance of update for this radio. No way of programming it. I can loan the radio, but not sure how to ship, will it be safe and secure? Who covers the shipping? About how long will it take? I'm in AZ so if somebody lives close enough, I could take it to them.


Related issues

duplicates New Model #6843: QYT KT-8R Feedback 06/02/2019

History

Updated by Bernhard Hailer 6 months ago

  • Subject changed from KT-8R to QYT KT-8R
  • Status changed from New to Closed
  • Priority changed from High to Normal
  • Target version set to chirp-daily

Duplicate of #6843. If you're still willing to loan out your radio, please leave a comment there, and we'll set the corresponding flag. First, please rad Wiki: Rules For Loaning A Radio. Thanks!

Also available in: Atom PDF