Bug #7727

Cannot get repeater book query to work

Added by Anthony Cerami 2 months ago. Updated 12 days ago.

Status:Closed Start date:03/23/2020
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:All
Model affected:(All models)

Description

Cannot get repeater book query to work. I have the latest version. I installed the software on two computers Win 7 and Win 10. It seems to search and comes back with no information.


Related issues

related to Bug #7731: CHIRP is damaged and can't be opened. You should move it ... Feedback 03/24/2020
duplicated by Bug #7729: Import from data source / Repeater book Closed 03/23/2020

History

Updated by Anders Knudsen 2 months ago

Seems the back-end query, which runs on this site is not working.

i.e. If I query Chicago, the query string is: http://chirp.danplanet.com/query/rb/1.0/app_direct?loc=Chicago&band=%&dist=50

This returns an error if you use a web browser, however the tempfile CVS contains the correct data, but with errors returned by the backend PHP code at the top of the file.

The chirpw cannot parse the CVS with this extra text. If I remove the extra text, I can manually import the data.

Since the query code runs on this site, nothing users of chirpw can do until that's fixed.

Temp CVS returned:

<br />
<b>Warning</b>:  Use of undefined constant ymdHi - assumed 'ymdHi' (this will throw an Error in a future version of PHP) in <b>/home/nwham123/public_html/repeaters/downloads/CHIRP/app_direct.php</b> on line <b>7</b><br />
<br />
<b>Warning</b>:  Cannot modify header information - headers already sent by (output started at /home/nwham123/public_html/repeaters/downloads/CHIRP/app_direct.php:7) in <b>/home/nwham123/public_html/repeaters/downloads/CHIRP/app_direct.php</b> on line <b>8</b><br />
<br />
<b>Warning</b>:  Cannot modify header information - headers already sent by (output started at /home/nwham123/public_html/repeaters/downloads/CHIRP/app_direct.php:7) in <b>/home/nwham123/public_html/repeaters/downloads/CHIRP/app_direct.php</b> on line <b>9</b><br />
<br />
<b>Warning</b>:  count(): Parameter must be an array or an object that implements Countable in <b>/home/nwham123/public_html/repeaters/downloads/CHIRP/app_direct.php</b> on line <b>59</b><br />
Location,Name,Frequency,Duplex,Offset,Tone,rToneFreq,cToneFreq,DtcsCode,DtcsPolarity,Mode,TStep,Comment^M
<br />
<b>Warning</b>:  Use of undefined constant KILOMETERS - assumed 'KILOMETERS' (this will throw an Error in a future version of PHP) in <b>/home/nwham123/public_html/repeaters/downloads/CHIRP/app_direct.php</b> on line <b>279</b><br />
1,W9AP,224.60000,-,1.60000,Tone,110.9,88.5,023,NN,FM,5,"Glenview",^M
2,N9ZD,443.27500,+,5.00000,Tone,114.8,88.5,023,NN,FM,5,"Oak Forest",^M
3,WM9W,224.52000,-,1.60000,Tone,110.9,110.9,023,NN,FM,5,"Chicago",^M
4,KA9QJG,224.74000,-,1.60000,Tone,131.8,131.8,023,NN,FM,5,"Hammond",^M
5,N9TO,223.86000,-,1.60000,Tone,110.9,88.5,023,NN,FM,5,"Westmont",^M
...
etc.

Updated by Anders Knudsen 2 months ago

Anders Knudsen wrote:

Seems the back-end query, which runs on this site is not working.

i.e. If I query Chicago, the query string is: http://chirp.danplanet.com/query/rb/1.0/app_direct?loc=Chicago&band=%&dist=50

This returns an error if you use a web browser, however the tempfile CVS contains the correct data, but with errors returned by the backend PHP code at the top of the file.

The chirpw cannot parse the CVS with this extra text. If I remove the extra text, I can manually import the data.

Since the query code runs on this site, nothing users of chirpw can do until that's fixed.

Temp CVS returned:
[...]

CSV above. Not CVS (doh)

Updated by Garrett Dow 2 months ago

The PHP version on Repeaterbook.com was recently upgraded and some of the functions were broken. The cause of this error was discovered and has since been fixed. Normal operation has been restored.

Garrett, KD6KPC
Repeaterbook.com Owner

Updated by J B 2 months ago

I see the last update was saying functionality had been restored, I just wanted to report I am still experiencing this issue. The repeaterbook query returns no info on the latest version and downgrading to an earlier version has the same effect. Thanks!

Updated by Bernhard Hailer 13 days ago

  • Status changed from New to Feedback
  • Target version set to chirp-daily
  • Platform changed from Windows to All

So does this problem still persist?
Also, is it a Chirp or a RepeaterBook issue?
Thanks.

Updated by J B 13 days ago

Bernhard Hailer wrote:

So does this problem still persist?
Also, is it a Chirp or a RepeaterBook issue?
Thanks.

The issue is fixed. I believe the issue was with RepeaterBook, the issue resolved a few days later using the same version of CHIRP.

Updated by Bernhard Hailer 12 days ago

  • Status changed from Feedback to Closed

Thanks for the feedback!

Also available in: Atom PDF