Bug #7761

BTECH GMRS50X1 Settings

Added by Frank Torres about 1 month ago. Updated about 1 month ago.

Status:Closed Start date:04/04/2020
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:All
Model affected:BTech GMRS-50X1

Description

Hello Support Team,

I use CHIRP to program various Baofeng/BTECH radios and it works great with the UV-25x2 and the F8HP. However, I’m having problems with the settings options of the GMRS-50X1. I’m using the latest version of CHIRP (I think) and the settings options is all blank (see attached picture). The worst part is when I upload an updated channel list to the radio, the radio settings are overwritten with default values and I loose them all.

CHIRP Version: 20200227
Radio: BTECH GMRS-50X1

Please let me know if this is a known problem with these radios and/or what can it be done to fix it.

Thank you for your support!
Frank Torres

BTECH_GMRS-50X1_Settings.jpg (78.4 kB) Frank Torres, 04/04/2020 09:26 am

BTECH_GMRS-50X1_20200404.img - Image File (16.2 kB) Frank Torres, 04/04/2020 12:48 pm

debug.log - Log File (33.7 kB) Frank Torres, 04/04/2020 12:48 pm

BTECH_GMRS-50X1_20200404(dtmf_settings_fixed).img (16.2 kB) Jim Unroe, 04/04/2020 02:10 pm

History

Updated by Jim Unroe about 1 month ago

  • Status changed from New to Feedback
  • Platform changed from Windows to All

Hi Frank,

There is one or more settings that are out-of-range. The CHIRP debug.log file will show you which ones they are so you can fix it. Or if you want you can attach a freshly downloaded CHIRP Radio Images (*.img) file to this issue and I will correct the errant setting and attach a fixed copy.

Jim KC9HI

Updated by Frank Torres about 1 month ago

Hello,

I'm attaching both, image file and log file. I can see this from the log, but I can't understand what stetting is wrong or out-of-range.

[2020-04-04 15:39:27,502] chirp.ui.memedit - INFO: Cross Mode supported: True
[2020-04-04 15:39:27,502] chirp.ui.memedit - INFO: Comment supported: False
[2020-04-04 15:39:27,588] chirp.ui.common - ERROR: Exception running RadioJob: list index out of range
[2020-04-04 15:39:27,591] chirp.ui.reporting - DEBUG: Reporting exception
[2020-04-04 15:39:27,589] chirp.ui.common - ERROR: -- Exception: --
[2020-04-04 15:39:27,591] chirp.ui.common - ERROR: Traceback (most recent call last):
File "chirp\ui\common.pyo", line 116, in _execute
File "chirp\drivers\btech.pyo", line 2141, in get_settings
IndexError: list index out of range

[2020-04-04 15:39:27,592] chirp.ui.common - ERROR: ----------------
[2020-04-04 15:39:27,592] chirp.ui.common - ERROR: Job Args: ()
[2020-04-04 15:39:27,592] chirp.ui.common - ERROR: Job KWArgs: {}
[2020-04-04 15:39:27,592] chirp.ui.common - ERROR: Job Called from:

File "chirpw", line 153, in <module>
File "chirp\ui\mainapp.pyo", line 1635, in mh
File "chirp\ui\mainapp.pyo", line 386, in do_open
File "chirp\ui\editorset.pyo", line 148, in init
File "chirp\ui\settingsedit.pyo", line 71, in init

Thanks,
Frank

Updated by Jim Unroe about 1 month ago

Hi Frank,

There were 6 bytes that were out of range. I set them all to the "factory" defaults.

Upload it to your radio and then download from your radio back to CHIRP to see if you still have the Settings visible. If they remain, all is good. If not, your radio may have some faulty memory bytes.

Jim KC9HI

Updated by Frank Torres about 1 month ago

Hello Jim,

The new image solved the problem. I uploaded the new image to the radio, then downloaded a "new" image from the radio and the setting window was visible preserving the manual changes I did on the radio.

Thank you very much for your assistance.

Frank Torres

Updated by Bernhard Hailer about 1 month ago

  • Status changed from Feedback to Closed
  • Target version set to chirp-daily
  • Model affected changed from BTECH GMRS50X1 to BTech GMRS-50X1

Thanks for your feedback!

Also available in: Atom PDF