Project

General

Profile

Actions

New Model #7791

closed

Radioddity GA-510 (BF-H6?)

Added by Alan Schwartz over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
Start date:
04/12/2020
Due date:
% Done:

100%

Estimated time:
Equipment Loan Offered:
No

Description

Please add GA-510 to list when possible. Same as BF-H6? What can I do to support this process, short of shipping you my radio? Radioddity offers a separate programming software for this radio (attached).


Files

Radioddity GA-510 CPS.exe (1.98 MB) Radioddity GA-510 CPS.exe Alan Schwartz, 04/12/2020 05:24 PM
GA-510 programming S_W.JPG (145 KB) GA-510 programming S_W.JPG GA-510 mfr software - what is in radio Alan Schwartz, 04/30/2020 11:44 AM
upload from GA-510.JPG (95.8 KB) upload from GA-510.JPG Upload from radio to Chirp result Alan Schwartz, 04/30/2020 11:44 AM
chirp writes to GA-510 OK.JPG (99.2 KB) chirp writes to GA-510 OK.JPG Added a channel, writes to radio OK, channel is present. Alan Schwartz, 04/30/2020 11:44 AM
basic.JPG (32.9 KB) basic.JPG initial setting access - basic Alan Schwartz, 04/30/2020 01:32 PM
advanced.JPG (47.1 KB) advanced.JPG move to advanced menu Alan Schwartz, 04/30/2020 01:32 PM
DTMF.JPG (61 KB) DTMF.JPG move to DTMF menu Alan Schwartz, 04/30/2020 01:32 PM
back to basic.JPG (34.1 KB) back to basic.JPG return to basic menu Alan Schwartz, 04/30/2020 01:32 PM
Actions #1

Updated by Dan Smith over 2 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Applied in changeset commit:f77b68f24710.

Actions #2

Updated by Bernhard Hailer over 2 years ago

  • Target version set to chirp-daily

Added to list of Supported Radios.

Actions #3

Updated by Dan Smith over 2 years ago

Alan, can you test this driver and report back if it works for you? During development one person running a non-english version of windows was experiencing some disappearing settings in the settings tab when switching back and forth between tabs. It would be super helpful if you could play around with that and see if you notice anything similar.

Thanks!

Actions #4

Updated by Alan Schwartz over 2 years ago

Tried new version. Upload from radio looks OK, wrote changes to radio OK. No obvious anomalies in read nor write. Screen shots of original settings, upload result and modified file that was written to radio attached.
Now I have to learn how to use the external DB to add local repeaters. Many thanks for the quick addition of my radio model. 73, Al

Actions #5

Updated by Dan Smith over 2 years ago

Hey Alan, thanks for that report. Specifically what I'm looking for is in the Settings tab on the left. Can you open that, switch around between Basic, Advanced and DMTF and see if any of the values disappear? Like, click on Settings, check the squelch value on the basic tab, click to advanced, click to DTMF, go back to basic, check that squelch still shows a value, etc.

Thanks a bunch!

Actions #6

Updated by Alan Schwartz over 2 years ago

Hi Dan, Clicked through Settings menus. Don't notice any settings disappearing. Will these screen shots help? Do you need Team Viewer access to my PC & HT? Best, Al

Actions #7

Updated by Dan Smith over 2 years ago

Hi Alan,

No that's fine, thanks for checking. I can't reproduce the problem here either, so I was just looking for someone else to try. The original report of a problem during testing was on an Asian-language version of windows, and I was suspecting the problem was related to fonts on that system. Since I can't do further debug on such a system, I think I'll just have to wait and see if anyone else pops up and reports the issue.

Thanks a lot for your help!

Actions

Also available in: Atom PDF