Bug #7867

Chirp crash when moving rows

Added by Roger Cullumber 24 days ago. Updated 23 days ago.

Status:Closed Start date:05/09/2020
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:Windows
Model affected:Yaesu VX-8R

Description

When trying to insert or delete rows in Chirp with the attached Yaesu image file the program gets stuck moving the first row. The Shift window pops up and says "Moving 3 to 2" with a Close button. Hitting the Close button blanks the Memories window and It then locks up the program and requires a hard close and restart.

Error is;
[2020-05-09 11:57:38,312] chirp.drivers.vx8 - ERROR: Failed to parse settings: Traceback (most recent call last):
File "chirp\drivers\vx8.pyo", line 1322, in get_settings
File "chirp\drivers\vx8.pyo", line 1313, in _get_settings
File "chirp\drivers\vx8.pyo", line 986, in _get_aprs_rx_settings
IndexError: tuple index out of range

Traceback (most recent call last):
File "chirp\ui\settingsedit.pyo", line 219, in _build_ui
Exception: Invalid Radio Settings
[2020-05-09 11:58:10,907] chirp.ui.editorset - DEBUG: <MemoryEditor object at 0x35c06c0 (chirp+ui+common+Editor at 0x4312290)> changed
[2020-05-09 11:58:44,355] chirp.ui.shiftdialog - DEBUG: Found a hole: 109
[2020-05-09 11:58:44,355] chirp.ui.shiftdialog - INFO: Moving 3 to 2
Exception in thread Thread-4:
Traceback (most recent call last):
File "threading.pyo", line 810, in bootstrap_inner
File "threading.pyo", line 763, in run
File "chirp\ui\shiftdialog.pyo", line 138, in threadfn
File "chirp\ui\shiftdialog.pyo", line 119, in _delete_hole
File "chirp\ui\shiftdialog.pyo", line 72, in _shift_memories
File "chirp\drivers\vx8.pyo", line 688, in set_memory
File "chirp\drivers\vx8.pyo", line 682, in _debank
File "chirp\drivers\vx8.pyo", line 484, in remove_memory_from_mapping
File "chirp\drivers\vx8.pyo", line 418, in update_vfo
File "chirp\bitwise.pyo", line 208, in __getitem

IndexError: list index out of range

[2020-05-09 12:00:36,042] chirp.ui.editorset - DEBUG: <MemoryEditor object at 0x35c06c0 (chirp+ui+common+Editor at 0x4312290)> changed

debug.log - Debug file (33.9 kB) Roger Cullumber, 05/09/2020 12:03 pm

Yaesu_VX-8R_20200509.img - Yaesu File (63.9 kB) Roger Cullumber, 05/09/2020 12:03 pm

History

Updated by Tony Fuller 23 days ago

Hi Roger,

Thanks for attaching your img file -- I was able to reproduce this and it may be a secondary symptom of something else -- There is an invalid setting somewhere in your radio that the Chirp driver vx8.py doesn't like. You can see for your self by going to the Settings tab and all you get is a blank window.

I'll add a few debug breakpoints to see if I can track down the invalid setting.

Updated by Tony Fuller 23 days ago

Actually those errors in _get_aprs_rx_settings() and other functions may be unrelated.

Can you perform this test:

Open a stock config and try to Insert a new line above or below. I think the feature is just broken and it's not your IMG file (but your IMG file does break the vx8.py driver)

Tony

Updated by Roger Cullumber 23 days ago

Tony,
Just like taking your car to the mechanic to demonstrate the malfunction and the car runs fine, I can't reproduce this problem in Chirp now. After I filed the bug, I exported to csv, modified it, and re-imported to have the new row where I wanted it. Perhaps that fixed the issue. At least the debug.log shows some proof of an issue. Thanks for your time looking into this. Feel free to set it as resolved for now. If it pops up again I'll reopen the issue.

Updated by Bernhard Hailer 23 days ago

  • Status changed from New to Closed
  • Target version set to chirp-daily
  • Model affected changed from (All models) to Yaesu VX-8R

Thanks for the feedback. And yes, if it happens again, let us know.

Also available in: Atom PDF