Bug #7883

Anytone HT TERMN8R can't insert channels that requere 12.5kHz step

Added by Cody Schafer about 2 years ago. Updated over 1 year ago.

Status:Closed Start date:05/16/2020
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Chirp Version:daily Platform:All
Model affected:Anytone TERMN8R

Description

  • the device does include a `tune_step` field in it's channel memory block, but
  • `get_features()` sets `has_tuning_step = False` and the `tune_step` field is never modified.
  • Code trying to set channels examines `has_nostep_tuning` when deciding to emit an error

```
if self.valid_tuning_steps and not self.has_nostep_tuning:
try:
step = required_step(mem.freq)
if step not in self.valid_tuning_steps:
msg = ValidationError("Frequency requires %.2fkHz step" %
required_step(mem.freq))
msgs.append(msg)
except errors.InvalidDataError, e:
msgs.append(str(e))

```

  • setting `has_nostep_tuning` works, but note that `valid_tuning_steps` is set to `[5.0, 10.0, 15.0, 20.0, 25.0, 30.0, 50.0, 100.0]` (aka `COMMON_TUNING_STEPS`), which doesn't match the settable tuning steps on the radio, which are: `[2.5, 5.0, 6.25, 10.0, 12.5, 20, 25, 30, 50]`

Related issues

duplicates Bug #6561: Fix anytone_ht valid tuning steps Closed 03/03/2019

History

Updated by Bernhard Hailer over 1 year ago

  • Description updated (diff)
  • Model affected changed from anytone_ht to Anytone TERMN8R

Corrected formatting.

Updated by Jim Unroe over 1 year ago

Basically a dupe of #6561 which has been resolved.

Jim KC9HI

Updated by Bernhard Hailer over 1 year ago

  • Status changed from New to Closed

Duplicates #6561, which has been resolved. Please follow and post there. Thanks!

Also available in: Atom PDF