Bug #7923

python3 support

Added by Anton Bolshakov about 1 month ago. Updated 30 days ago.

Status:Rejected Start date:05/27/2020
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-py3
Chirp Version:daily Platform:Linux
Model affected:(All models)

Description

Hi, I'm trying to install python3 branch using the latest commit from http://d-rats.com/hg/hgwebdir.cgi/chirp.hg/shortlog/68534f20c141
and facing the following errors:

python3.7 setup.py install --skip-build --root=/var/tmp/portage/net-wireless/chirp-20200213/image/_python3.7
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/wouxun: invalid syntax (wouxun.py, line 277)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/vxa700: invalid syntax (vxa700.py, line 180)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/vx6: invalid syntax (vx6.py, line 874)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/vgc: invalid syntax (vgc.py, line 1413)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/uv6r: invalid syntax (baofeng_common.py, line 167)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/uv5x3: invalid syntax (baofeng_common.py, line 167)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/ts850: 'dict' object has no attribute 'iteritems'
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/ts590: invalid syntax (ts590.py, line 1647)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/ts480: invalid syntax (ts480.py, line 1141)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/ts2000: Missing parentheses in call to 'print'. Did you mean print("Bug: unsupported duplex `%s'" % mem.duplex)? (ts2000.py, line 220)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/tk760g: invalid syntax (tk760g.py, line 910)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/tk760: 'float' object cannot be interpreted as an integer
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/tk270: 'float' object cannot be interpreted as an integer
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/thuv1f: invalid syntax (thuv1f.py, line 217)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/thd72: invalid syntax (thd72.py, line 584)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/th_uv8000: invalid syntax (th_uv8000.py, line 1489)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/th_uv3r25: invalid syntax (wouxun.py, line 277)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/th_uv3r: invalid syntax (wouxun.py, line 277)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/th9800: invalid syntax (th9800.py, line 601)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/th9000: invalid syntax (th9000.py, line 355)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/th7800: invalid syntax (th7800.py, line 539)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/tdxone_tdq8a: invalid syntax (tdxone_tdq8a.py, line 304)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/rh5r_v2: Missing parentheses in call to 'print'. Did you mean print(MEM_FORMAT)? (rh5r_v2.py, line 170)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/rfinder: invalid syntax (rfinder.py, line 243)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/retevis_rt26: invalid syntax (retevis_rt26.py, line 900)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/retevis_rt23: invalid syntax (retevis_rt23.py, line 849)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/retevis_rt22: invalid syntax (retevis_rt22.py, line 608)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/retevis_rt21: invalid syntax (retevis_rt21.py, line 564)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/retevis_rt1: invalid syntax (retevis_rt1.py, line 729)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/radtel_t18: invalid syntax (radtel_t18.py, line 481)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/radioddity_r2: invalid syntax (radioddity_r2.py, line 614)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/puxing_px888k: can only concatenate list (not "range") to list
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/puxing: invalid syntax (puxing.py, line 50)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/mursv1: invalid syntax (baofeng_common.py, line 167)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/lt725uv: invalid syntax (lt725uv.py, line 1396)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/leixen: invalid syntax (leixen.py, line 264)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/kyd_IP620: invalid syntax (kyd_IP620.py, line 184)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/kyd: invalid syntax (kyd.py, line 503)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/kguv9dplus: invalid syntax (kguv9dplus.py, line 880)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/kguv8e: invalid syntax (kguv8e.py, line 340)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/kguv8dplus: invalid syntax (kguv8dplus.py, line 421)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/kguv8d: invalid syntax (kguv8d.py, line 379)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/gmrsuv1: invalid syntax (baofeng_common.py, line 167)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/ftm350: invalid syntax (ftm350.py, line 281)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/ftm3200d: invalid syntax (ft1d.py, line 1893)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/ft90: invalid syntax (ft90.py, line 335)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/ft8100: Missing parentheses in call to 'print'. Did you mean print(self.VARIANT, number, tx_freq, mem.freq)? (ft8100.py, line 178)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/ft7100: invalid syntax (ft7100.py, line 571)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/ft70: invalid syntax (ft70.py, line 1165)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/ft60: invalid syntax (ft60.py, line 406)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/ft50: invalid syntax (ft50.py, line 589)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/ft450d: invalid syntax (ft450d.py, line 502)
Failed to import /var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/chirp/drivers/ft2d: invalid syntax (ft1d.py, line 1893)make: Entering directory '/var/tmp/portage/net-wireless/chirp-20200213/work/chirp-hg-68534f20c141/locale'

Please convert the effected files into python3


Related issues

duplicates Feature #495: PYTHON In Progress 02/03/2013

History

Updated by Alex Page about 1 month ago

I submitted a bunch of patches that should clear these up. I was able to launch the UI and download+upload to a radio. Keep an eye on the revision log and try again with your setup if you see the patches come through.

Updated by Anton Bolshakov about 1 month ago

sorry I'm new to this tracking system and find it is not very intuitive. Can you help me find your commit, so I can try it?

Updated by Alex Page about 1 month ago

I'm new here as well. You can follow the commits at https://chirp.danplanet.com/projects/chirp/repository/, or clone the source from http://d-rats.com/hg/chirp.hg. I have created a fork on Github if you want to test it until my patches go through: https://github.com/atpage/chirp.

Updated by Dan Smith 30 days ago

  • Status changed from New to Rejected

I'm closing this as a duplicate of the python3 issue we've been tracking all those fixes under just for cleanliness and correlation.

Updated by Alex Page 30 days ago

Is that #495? I'll send future patches that way instead.

Also available in: Atom PDF