Bug #8485

UV-9R Series Radios Do Not Like Computer Programming

Added by Mark Dunkle 3 months ago. Updated 14 days ago.

Status:Closed Start date:11/26/2020
Priority:High Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Chirp Version:daily Platform:All
Model affected:Baofeng UV-9R Series

Description

I sell programming cables for a living, and I have run into a problem that I just have not been able to solve. The UV-82WP, UV-9R, and UV-9RPlus that I own and use to test my cables in theory all use the same firmware and programming cable. In reality, the UV-9R series radios do not work with most of the cables that do work with the UV-82 and varients. This is a problem with both Chirp and the WP970i software. I have tried various USB to serail adapters with Prolific and FTDI chipsets from different cable manufacturers that I buy from, and the results are the same. I have used a USB packet capture tool that confirms that data is being successfully passed in all cases and it is not a serial communications problem. I have also confirmed that the data being exchanged differs between successful and failed programming attempts.

I am opening this bug report on danplanet.com to socialize the problem, and perhaps someone has figured out the root cause and to ask the Chirp team if we can have a developer investigate and maybe come up with a workaround in Chirp. I can provide radios, cables, and more details. I can be reached by email

debug.log (716.9 kB) Mark Dunkle, 11/26/2020 03:44 pm

History

Updated by Bernhard Hailer about 1 month ago

  • Status changed from New to Feedback
  • Model affected changed from UV-9R Series to Baofeng UV-9R Series
  • Platform changed from Windows to All
Hi Mark, let's circle back on this one and collect a few facts.
  • Your debug log contains multiple attempts exchanging data with a UV-82WP and a UV-9R. The latter sometimes appears to work, sometimes not, did I get that right? (Hint: collect one file per attempt and each time rename the log file to something easy to relate, like "UV-9R Radio does not respond.log". That's easier to review.)
  • The "WP970i" software is Baofeng's product? Since both softwares have similar problems, I'd suspect some issue on the hardware side.
  • When you are using your USB capture device, do you always (especially in the cases where Chirp reports "Radio does not respond" or "Not the amount of data we want") see traffic on both serial TX and RX?
  • Can you 100% exclude contact problems such as a jack not fitting perfectly into the radio's socket?
  • Are there cables which consistently work and others which consistently don't?
  • Did you try different computers, excluding possible issues with USB-to-serial drivers?

Thanks.

Updated by Bernhard Hailer 24 days ago

  • Status changed from Feedback to Closed

After a conversation with Mark it turned out that the socket in the UV-9D is constructed in a way which doesn't allow plugs to properly be seated. Like for some other Chinese radios, the connector must be modified before it makes proper contact. Thanks Mark for the feedback!

Updated by Bernhard Hailer 15 days ago

Mark provided the following insight for folks who bought a cable elsewhere and now are having problems getting the radio connected:

The connector for Motorola radio and the Baofeng BF-82WP is what I would call a defacto standard; however, the Baofeng pinout is unique to their radios. For some inexplicable reason, the UV-9R and UV-9RPlus shape of the connector on the radio interferes with the defacto standard cable connector pins touching the radio's connector contacts. The solution is to trim the wedging flange, opposite the screw, by 1 or 2 mm. This "mod" does not appear to adversely affect the BF-82WP.

Based on personal experience, I'd always suggest to buy cables from reputed vendors such as BlueMax49ers in the first place. You will much less likely run into problems, but if there is any, you will also get good customer support.

Updated by Jim Unroe 15 days ago

Bernhard Hailer wrote:

Based on personal experience, I'd always suggest to buy cables from reputed vendors such as BlueMax49ers in the first place. You will much less likely run into problems, but if there is any, you will also get good customer support.

Except in this case. If you will recall from the original post, Mark is BlueMax49ers.

To solve this issue, I purchased a UV-9R radio and Mark sent me a pair of his BlueMax49ers programming cables. Out-of-the-box, neither the BlueMax49ers or the "official" Baofeng labeled programming cable would work to program the UV-9R. My same type programming cable from Retevis for their RT6, which has a different shell on the connector, worked fine.

After closer inspection, I could see that the way the radio and BlueMax49ers and Baofeng programming cables mated up to the radio, the pins of the programming cable were not properly lined up with the contacts of the radio. Studying which direction the pins were off and by how much, I modified the connector of one BlueMax49ers programming cable with a file until the pins lined up properly. Once this was done, the programming cable worked reliably every time.

In the mean time, I have ordered a Baofeng labeled programming cable which has the same shell as the Retevis programming cable to see if it has the WCH CH340 chip or the Prolific PL2303HXA type chip.

Jim KC9HI

Updated by Bernhard Hailer 14 days ago

Hmm. Did you contact Mark? I'm certain he would have helped you to resolve the issue. His customer support is very good.

Also available in: Atom PDF