New Model #8591

Quansheng TG-UV2 Plus

Added by Nas Ziak almost 2 years ago. Updated 7 months ago.

Status:Closed Start date:12/25/2020
Priority:Normal Due date:
Assignee:Ran Katz % Done:

100%

Category:-
Target version:chirp-daily
Chirp Version:daily Equipment Loan Offered:No

Description

I purchased this ham radio , i saw that other people have this handheld to , but cant find support , is there a chance that will be supported by Chirp?

Sorry for my bad English.

Quansheng_TG-UV2 .img (8.2 kB) Ran Katz, 02/08/2022 10:53 pm

chirpw_x5eR0A7o9Q.png (4.6 kB) Hao Xu, 02/14/2022 10:18 pm

debug.log (31.5 kB) Hao Xu, 03/11/2022 10:02 pm

tg_uv2p_fix_8591_v1.py (23 kB) Ran Katz, 03/15/2022 09:32 pm

tg_uv2p_fix_8591_v2.py (23.2 kB) Ran Katz, 03/15/2022 10:26 pm


Related issues

related to New Model #177: Quansheng TG-UV2 Blocked 05/20/2012

Associated revisions

Revision 3655:8236e479d0fd
Added by Ran Katz 10 months ago

Driver for TG-UV2+ (and probably TG-UV2)
See Issues #8591 and #177
Tested on TG-UV2+ , however teh code base (a 'C' utility) was developed a decade ago for the TG-UV2,
and I could not find any differences.

---------------
user: Ran Katz <>
branch 'default'
added chirp/drivers/tg_uv2p.py
added tests/images/Quansheng_TG-UV2+.img

Revision 3656:3a8175e15d9c
Added by Ran Katz 10 months ago

Added set_settings for the tg-uv2+ driver,

Related to #8591

user: Ran Katz <>
branch 'default'
changed chirp/drivers/tg_uv2p.py

Revision 3657:e0dfd16abe9a
Added by Dan Smith 10 months ago

Fix tg_uv2p style issues

I didn't catch that this wasn't in the manifest during review,
and thus the style issues didn't get flagged. Adding it to the
manifest and fixing those here.

Related to #8591

Revision 3669:85c33506a154
Added by Ran Katz 8 months ago

[tg-uv2+] Add 2 stopbits serial port setting fixes #8591

A (Windows) user discovered that teh driver did not commmunicate properly with the radio,
The causewas wrong (default) stopbits setting ( was 1 stop bit).
As OEM SW uses 2 stopbits and fix was valicated on Windows and MAC, driver is updated accordingly.

History

Updated by Jim Unroe almost 2 years ago

  • Status changed from New to Feedback

Basically to get a radio supported, the radio in question, plus the factory programming software, has to get into the possession of an interested CHIRP developer. Apparently that has not happened in the over 8 years since this model was originally requested. Since this model has already been requested, I'm going to close this ticket and you can add your interest in having the TG-UV2 being supported to that ticket. Issue: #177

Jim KC9HI

Updated by Nas Ziak almost 2 years ago

TG UV 2 plus as i know is a newer model but do what have to do , as i see there is no interest at supporting this brand as baofeng . Sorry for the inconvenience

Updated by Bernhard Hailer almost 2 years ago

  • Target version set to chirp-daily

Leaving open, assuming that the "Plus" version is different to the TG-UV2.

Updated by Ran Katz 10 months ago

Added Image file for proposed driver

Updated by Hao Xu 9 months ago

I found TG-UV2+ has shown up in the supported device list but I can't seem to find that working.
I can connect to the device with the Quansheng software, but Chirp gives me "Invalid response for address 0x0000"
Please let me know how I can help, would love to make this work. I'm new to HAM but I'm a developer

Updated by Hao Xu 9 months ago

Ran Katz wrote:

Added Image file for proposed driver

Is this image for TG-UV2 or TG-UV2plus

Updated by Jim Unroe 9 months ago

Hao Xu wrote:

I found TG-UV2+ has shown up in the supported device list but I can't seem to find that working.
I can connect to the device with the Quansheng software, but Chirp gives me "Invalid response for address 0x0000"
Please let me know how I can help, would love to make this work. I'm new to HAM but I'm a developer

I don't know where you found it is a "supported device list". Neither the vendor "Quansheng" nor the model "TG-UV2" shows up in any CHIRP files. The only thing close in the CHIRP Supported Radio Models list on the home page is Wouxun KG-UV2D, which I would expect to be not compatible with a Quansheng radio. I would consider it safe to say that CHIRP does not support any Quansheng radio models.

Jim KC9HI

Updated by Hao Xu 9 months ago

Jim Unroe wrote:

Hao Xu wrote:

I found TG-UV2+ has shown up in the supported device list but I can't seem to find that working.
I can connect to the device with the Quansheng software, but Chirp gives me "Invalid response for address 0x0000"
Please let me know how I can help, would love to make this work. I'm new to HAM but I'm a developer

I don't know where you found it is a "supported device list". Neither the vendor "Quansheng" nor the model "TG-UV2" shows up in any CHIRP files. The only thing close in the CHIRP Supported Radio Models list on the home page is Wouxun KG-UV2D, which I would expect to be not compatible with a Quansheng radio. I would consider it safe to say that CHIRP does not support any Quansheng radio models.

Jim KC9HI

It showed up in the build on 02/10 and 02/14, not on 02/09. So, I assume someone added the driver recently, but I can't seem to find that in the drivers
https://trac.chirp.danplanet.com/chirp_daily/daily-20220210/Model_Support.html

Updated by Hao Xu 9 months ago

It also shows up in UI, but the latest driver update I see is 28 days ago. That's what confused me. unless there are other branches rather than the main Chirp daily is built from

Updated by Hao Xu 9 months ago

Hao Xu wrote:

It showed up in the build on 02/10 and 02/14, not on 02/09. So, I assume someone added the driver recently, but I can't seem to find that in the drivers
https://trac.chirp.danplanet.com/chirp_daily/daily-20220210/Model_Support.html

I need to correct that it is indeed in 02/09 build but it was not in 02/02. https://trac.chirp.danplanet.com/chirp_daily/daily-20220202/Model_Support.html

Updated by Jim Unroe 9 months ago

Hao Xu wrote:

Hao Xu wrote:

It showed up in the build on 02/10 and 02/14, not on 02/09. So, I assume someone added the driver recently, but I can't seem to find that in the drivers
https://trac.chirp.danplanet.com/chirp_daily/daily-20220210/Model_Support.html

I need to correct that it is indeed in 02/09 build but it was not in 02/02. https://trac.chirp.danplanet.com/chirp_daily/daily-20220202/Model_Support.html

I stand corrected. I was looking at the files from 18 January which did not yet include the tg_uv2p.py driver.

Jim KC9HI

Updated by Hao Xu 9 months ago

yup, I found the commit 8236e479d0fd by Ran Katz. Looks like it is working for him somehow. I have 3 units (2 Chinese domestic version and 1 US imported version) and I got none of them working. I guess I need to setup an environment and debug a bit when I got a chance

Updated by Ran Katz 9 months ago

  • Assignee set to Ran Katz

@Hao Xu
Can you attach the debug.log file chirp generates?

Thanks,
Ran

Updated by Hao Xu 9 months ago

Ran Katz wrote:

@Hao Xu
Can you attach the debug.log file chirp generates?

Thanks,
Ran

Here you go. My apologies I was caught up with other things and forget about this. I saw your email a few days ago

Updated by Ran Katz 9 months ago

Hi Hao,
I managed to test the radio on a windows machine (so far everything I did was on a MAC...) and encountered communications issues - not exactly what you experience, but very basic ones (getting "garbage" back from the radio).
I managed to fix them by changing the com port to have 2 stop bits - apparently this was documented and set in the original C application I based my driver on, obviously I missed it , but the strange thing is that I didn't encounter any issues on the MAC while on windows (with the same CH340 cable) it fails.

Once fixed it works on my radio both on MAC and on windows, read and write.

So, I uploaded a fix candidate : tg_uv2p_fix_8591_v1.py
please download it and:
1. Open CHIRP
2. Enable the developer functions: Help->Enable Developer Functions
3. Load the new driver: File -> Load Module and select the attached driver
4. Try to download : Radio ->Download from radio , select the TG-UV2+FIX model
5. if download works please try uploading as well
6. Let me know how it went

Thanks!
Ran

Updated by Ran Katz 9 months ago

v2 fixes the memory/channel numbering (now starts at 0 like the radio)

Updated by Hao Xu 9 months ago

Ran Katz wrote:

Hi Hao,
I managed to test the radio on a windows machine (so far everything I did was on a MAC...) and encountered communications issues - not exactly what you experience, but very basic ones (getting "garbage" back from the radio).
I managed to fix them by changing the com port to have 2 stop bits - apparently this was documented and set in the original C application I based my driver on, obviously I missed it , but the strange thing is that I didn't encounter any issues on the MAC while on windows (with the same CH340 cable) it fails.

Once fixed it works on my radio both on MAC and on windows, read and write.

So, I uploaded a fix candidate : tg_uv2p_fix_8591_v1.py
please download it and:
1. Open CHIRP
2. Enable the developer functions: Help->Enable Developer Functions
3. Load the new driver: File -> Load Module and select the attached driver
4. Try to download : Radio ->Download from radio , select the TG-UV2+FIX model
5. if download works please try uploading as well
6. Let me know how it went

Thanks!
Ran

Hi Ran,

You rock! This works!
I was about to sniff the official software today based on our email communication and saw this update you have here.
I was using my Windows machine all the time since I wasn't sure if Macs have proper drivers for the cable. Good thing is that we caught the bug early on.

Cheers,
Hao

Updated by Ran Katz 7 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

Applied in changeset 85c33506a154.

Also available in: Atom PDF