Project

General

Profile

Actions

Bug #8647

closed

Chirp not working with Mac OS Big Sur

Added by Rob Kuijpers almost 2 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
01/03/2021
Due date:
% Done:

0%

Estimated time:
Chirp Version:
daily
Model affected:
Baofeng UV-B5
Platform:
MacOS

Description

Multiple problems:

  • Chirp cannot access desktop files (see screenshot #1)
  • Chirp does not download from radio (Baofeng UV-B6) Setup worked before upgrading to Mac OS Big Sur, so I suspect this to be the problem.

KR
Rob, PA9Z


Files

debug.log (28.1 KB) debug.log Rob Kuijpers, 01/03/2021 08:22 AM

Related issues

Related to Bug #9309: CHIRP vs. Big SurClosed08/25/2021

Actions
Has duplicate Bug #8769: MacBook Pro (13-inch, M1, 2020) macOS Big SurClosed01/31/2021

Actions
Has duplicate Bug #8749: App crashes on launch on Apple Silicon M1 Mac running macOS Big Sur 11.1Closed01/28/2021

Actions
Actions #1

Updated by Bernhard Hailer almost 2 years ago

Hi Rob, I'm not a Mac user, but the log suggests a number of things:

/Applications/CHIRP.app/Contents/Resources/chirp/chirp/ui/mainapp.py:1593: GtkWarning: Cannot open pixbuf loader module file '/usr/local/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache': No such file or directory

This likely means that your installation is broken.
Try running the command
  gdk-pixbuf-query-loaders > /usr/local/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.
  d.run()
/Applications/CHIRP.app/Contents/Resources/chirp/chirp/platform.py:152: GtkWarning: Could not find the icon 'inode-directory'. The 'hicolor' theme
was not found either, perhaps you need to install it.
You can get a copy from:
    http://icon-theme.freedesktop.org/releases

The download issue may be caused by a bad cable, cable driver, or connector - check these things.

Actions #2

Updated by Bernhard Hailer almost 2 years ago

  • Status changed from New to Feedback
  • Model affected changed from (All models) to Baofeng UV-B5
  • Platform changed from Windows to MacOS
Actions #3

Updated by Rob Kuijpers almost 2 years ago

Thanks for the swift replay!

After entering in terminal: /opt/kk7ds/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache
I get following response : zsh: permission denied: /opt/kk7ds/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache

Note: I had to change the path you suggested, as loaders.cache is located elsewhere.

KR
RK

Actions #4

Updated by john Kelly almost 2 years ago

Rob Kuijpers wrote:

Thanks for the swift replay!

After entering in terminal: /opt/kk7ds/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache
I get following response : zsh: permission denied: /opt/kk7ds/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache

Note: I had to change the path you suggested, as loaders.cache is located elsewhere.

KR
RK

any resolution? I have the same issue but with a BTech GMSR V1

Actions #5

Updated by David Alpern over 1 year ago

*** Verified cable works ***

Got a new MacBook Pro with Big Sur... Tried to load CHIRP and got no love...
Tried launching the app from the command menu while located in my App folder.

Ran the following command prompt in Terminal: /Applications/CHIRP.app/Contents/MacOS/chirp

Results are below:
2021-08-25 19:24:39.521 CHIRP[7255:1077255] *** WARNING: Method userSpaceScaleFactor in class NSView is deprecated on 10.7 and later. It should not be used in new applications. Use convertRectToBacking: instead.
Traceback (most recent call last):
File "/Applications/CHIRP.app/Contents/MacOS/../Resources/chirp/chirpw", line 131, in
from chirp.ui import mainapp
File "/Applications/CHIRP.app/Contents/Resources/chirp/chirp/ui/mainapp.py", line 32, in
from chirp.drivers import generic_xml, generic_csv, repeaterbook
ImportError: cannot import name generic_xml

Actions #6

Updated by Martin Cooper about 1 year ago

Rob:
Are you using the Mac Unified Application? If not, please try that. GTK failures tend to result from an incompatible mix of externally installed GTK libraries with Chirp's usage of GTK. The Unified Application incorporates the version of GTK that Chirp needs.

David:
This is a separate issue. It looks like you may have grabbed a build that was in the middle of some changes related to the removal of some XML support. Please try a later build of Chirp, and see if that resolves your issue.

Actions #7

Updated by Bernhard Hailer 9 months ago

  • Status changed from Feedback to Closed

No more traffic on this ticket.

Actions

Also available in: Atom PDF