Bug #8707

Failure to Write Memory IC-7100 Live-Mode Radio

Added by Danny Burdick over 1 year ago. Updated over 1 year ago.

Status:Closed Start date:01/20/2021
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Chirp Version:daily Platform:Windows
Model affected:Icom IC-7100

Description

debug.log shows

[2021-01-20 09:42:33,326] chirp.ui.editorset - DEBUG: <MemoryEditor object at 0x7f3912b1a960 (chirp+ui+common+Editor at 0x5601ded9e6e0)> changed

Change shows on screen

Actual memory location is not written to

Refresh, Restart, Edit from screen or properties drop down all the same

Does NOT WRITE changes to radio even though it say's it did

debug.log (411.8 kB) Danny Burdick, 01/20/2021 05:28 pm


Related issues

related to Bug #8771: Add further instructions for Icom IC-7100 New 01/31/2021

History

Updated by Bernhard Hailer over 1 year ago

  • Status changed from New to Feedback
  • Model affected changed from (All models) to Icom IC-7100

Could you please provide the debug log as described in the Wiki: "How To Report Issues"? Thanks!

Updated by Danny Burdick over 1 year ago

Debug.log attchd

Bank 1 Channel 20
Had rtone originally at 107.2 the same as ctone
I changed rtone to 254.1 and it shows I changed it to that
It also showed I changed it to that live
But when you exit and reread the radio it is back to 107.2 unchanged
It's like memory in the radio is write protected or since it's linux debian stable
permissions are messed up somewhere not allowing "write" but not saying anything about it.

Updated by Danny Burdick over 1 year ago

It does this with both the RTS cable and a standard usb non-proprietary cable
I had heard rumors that there may be a problem using chirp with the RTS cable
So I tried both still same responses

Updated by Danny Burdick over 1 year ago

Downloaded live boot cd runs an old version from 2016 my radio isn't in there yet so I ran updater and it updated the old one with a new one that had a typo in the script file at

/usr/local/bin/chirpw

line 20 says import from chirpui (it supposed to be spelled chirp.ui)
and because of that anyone using the updater can no longer run chirp
it won't start...

Updated by Rudolph Gutzerhagen over 1 year ago

Info: Not a typo.
The directory structure was changed in Revision r2429 (5ea1d3ec423c) see Issue #2351 .
Support for Icom IC-7100 was added in Revision r2757 (3e366aeabfb5) in late August 2016 with a build released shortly thereafter on 2016-09-03 .

In Issue #5023 there is a link to a reddit post, wherein there is a possible vague clue:
  • I was able to get Chirp to work with my Icom-7100. It didn't access the Icom memory through the USB port, but through the accessory port (I had to buy a separate cable.)

Updated by Danny Burdick over 1 year ago

OK after talking to dozens of people who can use Chirp IC-7100
One guy had two of them (IC-7100's)
I've come to the conclusion that it may be the cable
None of my RTS work with Chirp to "WRITE" anything (To be expected)
The cable that comes with the radio is a straight USB to mini-USB
I understand that in order to work correctly I need a USB to 1/8" male phone plug to plug into the remote jack on the back
Ordered one just now from the ebay guy who tries all his cables with Chirp (28K in radios)
Will try that when it gets here...

Updated by Danny Burdick over 1 year ago

Bought and recvd cable from bluemax49ers supposed to be "THE RIGHT CABLE" does the same thing reads but does not write back to radio
Chirp shows you changed the value of any field on the screen but upon exit you find that it did not do the change in the radio, only on the screen of the computer.

Updated by Rudolph Gutzerhagen over 1 year ago

please excuse the is-it-plugged-in question...
You have set the radio to receive, in clone mode, on the radio panel, just before getting Chirp to do it's upload?
Is there any status activity on the radio panel during the upload? (I'm curious; I don't have this radio)

Updated by Danny Burdick over 1 year ago

There is no "clone anything on this model radio"
There is no "upload" on this radio
This radio requires "Download" 1st then you find Chirp notifying you that this radio is a "live-mode radio"
You edit any field of data you want to change and it immediately upon hitting enter/return it is supposed to "WRITE"
that change to the radio.....no upload possible...just enter/return and it automatically uploads.

That is the issue here with this "bug/feedback" entry
No "Write" to radio ever for any reason
It say's it wrote it but it does not as verified by closing the app and restarting everything
You find the data field has not changed but is still the same value that it told you on the screen that it changed
and complied with your wishes.....

Updated by Rudolph Gutzerhagen over 1 year ago

That is very strange. In the basic manual, section 6, last page, it indicates setting clone mode to receive data. Icom IC7100 ? Right?

Updated by Danny Burdick over 1 year ago

That section is referring to the use of Icom's CS-7100 programming software for the IC-7100
which only works under Windows not anything else and it is quite like fly paper in that it
only installs if you have already installed the old original version wherever you get that.
The radio's hardware was programmed to have a section which only works with that.
That software is closed source, commercial, and will cost you $48.90 unless you steal it from some
pirate site. Not even going there
Open source, Linux, and free no matter how long it takes eventually.

Updated by Rudolph Gutzerhagen over 1 year ago

This is even more strangerer. I did expect that actually doing that test would have yielded good results for you. Thank you for answering my query.

Updated by Danny Burdick over 1 year ago

OK
We can close this sucker out !!!!!!!!
Found it

I don't know how but if you do a "RESET ALL"
Which ever operating system is the first to talk to the IC-7100 must setup the radio uart/port somehow to only work with itself

If you do a "RESET ALL" in the radio and then program the radio with RTS (Widows you got no choice there) it will work with either the RTS custom cable or the factory original cable but not the

FTDI USB CAT Programming Cable ICOM CAT CI-V IC-7100 IC-7200 IC-7300 CT-17

And you will "NOT" be able to go back to Linux Chirp and have "WRITE" privileges

Here is where it gets interesting...

If you do a "RESET ALL" and then program the radio using the Linux Chirp and the CT-17 FTDI CAT cable everything works perfectly and you magically have all the "WRITE" privileges forever but RTS and Windows Chirp crap all over themselves trying to talk to your radio now even if you put back in their cables....

It would appear the radio has the equivalent of an NVRAM and whoever gets there first after a "RESET ALL" in the radio wins the fight....RTS or Windows Chirp using their respective cables

or

Linux Chirp using the CT-17 CAT cable with full "LIVE-RADIO MODE" "WRITE" privileges.....

Let's close this one out the books and sticky it so those who have Icom IC-7100's can know what is going on

Danny W. Burdick
KE4OZD

Updated by Bernhard Hailer over 1 year ago

  • Status changed from Feedback to Closed

Closed as suggested by submitter.
The ticket will stay available and can be found in searches.

Also available in: Atom PDF