New Model #893

Yaesu VX-150

Added by Brent Jensen about 9 years ago. Updated 9 months ago.

Status:Feedback Start date:11/24/2012
Priority:Normal Due date:
Assignee:Bernhard Hailer % Done:

0%

Category:-
Target version:-
Chirp Version:daily Equipment Loan Offered:Yes

Description

Have radio and USB but no software to loan.

debug.log (28.1 kB) Thomas P, 04/30/2021 01:09 pm


Related issues

duplicates New Model #355: Yaesu VX-150 Rejected 11/24/2012

History

Updated by Tom Hayward about 9 years ago

  • Status changed from New to Rejected

Closing because another issue has an equipment loan offer.

Updated by Tom Hayward about 9 years ago

Oops, meant to close the other one...whatever.

Updated by Tom Hayward about 9 years ago

Oh, now I understand. Redmine automatically closed both of them at the same time because they're linked. Dan, please help.

Updated by Dan Smith about 9 years ago

  • Status changed from Rejected to New

Updated by Bill Phillips over 8 years ago

I have a vx-150, serial cable, and ADMS-1F software I can loan out.

Updated by CJ Luck almost 3 years ago

I have a VX-150 I can loan out for testing.

I tried downloading from the radio using the VX-170 driver, and it gets to about 90%, and then throws this error message: " ord() expected a character, but string of length 0 found."

Not sure if that is helpful, but it seems to me that the vx-150 and the vx-170 are similar enough that it wouldn't take much to make it work for the vx-150.

Updated by Bernhard Hailer over 2 years ago

  • Status changed from New to Feedback
  • Assignee set to Bernhard Hailer

Could you please provide a debug log as described in the Wiki: "How To Report Issues"? Thanks!
Use a recent version of Chirp. With that log, it might be easy to get things going.

Updated by Thomas P over 1 year ago

I tried my vx-150 with the existing vx-170 profile and experienced the same results as CJ Luck.

TypeError: ord() expected a character, but string of length 0 found

Attaching the debug log. I hope this helps because I love this radio. Let me know if I can help with more info or tests.

Updated by Hardy Pottinger 10 months ago

I acquired 2 VX-150s and have access to 2 RTS cables and ADMS software that works with the radios. I've started looking into using Chirp and experienced the same result as Thomas P. I also tried running a port monitor while using Chirp and have a trace up to the point of getting the TypeError msg. Chirp is happily reading data in 32 byte chunks but I can't make heads or tails of the data. I tried added a memory tag to one of the channels, expecting to find the clear text somewhere, but didn't. The trace starts out with 4 chunks of more or less random looking bytes, then 4 blocks of a funky looking count sequence: FF 01 02 ... 0D 0E, repeated. Then comes a large number of chunks with all FFs (empty memory?), then many repetitions of " 06 00 01 00 44 00 00 60 00 0c 00 00 00 aa 00 02". I can try attaching the trace file if that would be useful. In the meantime I'll continue trying to bring up a decent debugging environment.
And, yes, I like these 2 radios. Only 2 meters but they are built like battleships.

Updated by Hardy Pottinger 9 months ago

A quick update - after almost a month I'm starting to make a bit of progress with a new vx150.py driver. Using win10 and python2 for the development environment. mmap is slowly starting to come into focus and the chirp editor window is gradually getting populated with data. Yay!

Also available in: Atom PDF