Bug #9051

Settings tab empty for QYT KT-8R

Added by Bartlomiej Zielinski over 1 year ago. Updated about 1 year ago.

Status:Closed Start date:05/08/2021
Priority:Normal Due date:
Assignee:Jim Unroe % Done:

100%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:All
Model affected:QYT KT-8R

Description

The settings tab remains empty after downloading data from QYT KT-8R radio. When I open the previous file from a disk, the settings are properly displayed.

CHIRP daily 20210429, the same for the previous version.

QYT_KT-8R_20210425.img - Options properly displayed (16.2 kB) Bartlomiej Zielinski, 05/08/2021 02:16 am

QYT_KT-8R_20210508.img - Options not displayed (16.1 kB) Bartlomiej Zielinski, 05/08/2021 02:16 am

debug.log - Chirp log file (55.1 kB) Bartlomiej Zielinski, 05/08/2021 02:16 am


Related issues

duplicated by Bug #9519: REF: Bug #9051 Settings tab empty for QYT KT-8R Closed 11/05/2021

Associated revisions

Revision 3619:11b922422d1d
Added by Jim Unroe about 1 year ago

[KT-8R] Settings tab empty for QYT KT-8R

The Settings tabs in CHIRP are empty when the KT-8R has TMR set to M+ABCD.
This driver was derived from the QYT mobile radios which only have 15 TMR
selections. This radio has a 16 TMR selections similar to the BTech mobile
radios so so setting it to the 16th choice puts it out-of-range based on the
current programming.

This patch adds 16 TMR choices support for the QyT KT-8R.

Fixes #9051

History

Updated by Jim Unroe over 1 year ago

  • Status changed from New to In Progress
  • Assignee set to Jim Unroe
  • Target version set to chirp-daily
  • Platform changed from Windows to All

I see what the issue is. I'll try to see if I can work developing a patch into my schedule.

In the mean time, only download from your radio into CHIRP when TMR (Transceiver Multi Reception) is not set to M+ABCD which will allow the Settings tabs to show.

Jim KC9HI

Updated by Bartlomiej Zielinski over 1 year ago

Thank you, it works by now.

Updated by Jim Unroe about 1 year ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Patch submitted. The fix will be in the next CHIRP daily build following acceptance.

In the mean time you can select...

M+ABC with display line D selected (ABCM)
M+ABD with display line C selected (ABMD)
M+ACD with display line B selected (AMCD)
M+BCD with display line A selected (MBCD)

Note: M = the currently selected display line

Jim KC9HI

Updated by Anonymous about 1 year ago

  • Status changed from Resolved to Closed

Applied in changeset 11b922422d1d.

Also available in: Atom PDF