Bug #9111

Abbree AR-F8, some settings missing

Added by Arquimedes Chacon 3 months ago. Updated 3 months ago.

Status:Feedback Start date:06/06/2021
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:All
Model affected:Abbree AR-F8

Description

When connecting an Abbree AR-F8 device considering the model KG-UV8D chirp can read information from the device but when clicking on the "Settings" tab there is no information of any kind.
In some other requests, from other users, the error is described but the solution is not clear or definitive, it seems that the log file has not been sent yet.
Thanks for any help you can give!

debug.log (436.3 kB) Arquimedes Chacon, 06/06/2021 12:17 pm


Related issues

duplicated by Bug #9109: Blank Setting Closed 06/06/2021

History

Updated by Jim Unroe 3 months ago

  • Status changed from New to Feedback
  • Assignee deleted (Jim Unroe)

A blank Settings tab is usually a result of an out-of-range setting. Having the CHIRP Radio Images (*.img) file attached to this issue would be helpful.

Reviewing the included debug.log file shows there is something that is set to 350.000000 (perhaps a VFO) which is outside of the 134.000000-174.997500 range it is supposed to be within.

Jim KC9HI

Updated by Arquimedes Chacon 3 months ago

Hi Jim !
Thanks for your prompt response!

Thanks to your comment and in order to see the "Settings" information, I followed the following steps:
1.- In the "Browser" tab > Option vhf_limits and uhf_limits, then replaced the "dec" values by limits for vhf between 136 and 174 and for UHF between 400 and 520.
2.
In the vfoa and vfob option (in the same Browser tab) values within the ranges established in the previous point were placed.
3.- The information was uploaded to the equipment.
4.- The chirp application was closed and restarted.
5.- The information was downloaded from the equipment.
6.- The Settings tab is now working.

However (not everything is always wonderful) not all the functions are available, it is evident that it is not the ideal structure for the AR-F8 model. Some configurations do not correspond to the model and others are not there (for example GPS).

I think it is important to suggest that the chirp team keep trying to set a model specific option. I know it is not always possible but many of us would appreciate it very much!!!.

Best wishes!

Updated by Arquimedes Chacon 3 months ago

(The "strikethrough" style is a mistake, the information is valuable).

Updated by Jim Unroe 3 months ago

Arquimedes Chacon wrote:

However (not everything is always wonderful) not all the functions are available, it is evident that it is not the ideal structure for the AR-F8 model. Some configurations do not correspond to the model and others are not there (for example GPS).

This is most likely due to an interested volunteer CHIRP developer not having access to an Abbree AR-F8 and the OEM programming software. Until this happens, you will have to use the OEM software to configure functions and settings that aren't supported by the KG-UV8D driver module. You might consider donating one or loaning one to a developer for the cause.

Jim KC9HI

Updated by Bernhard Hailer 3 months ago

  • Subject changed from Blank Setting to Abbree AR-F8, some settings missing
  • Priority changed from Immediate to Normal
  • Target version set to chirp-daily
  • Model affected changed from AR-F8 to Abbree AR-F8
  • Platform changed from Windows to All

(Changed title to reflect the problem more precisely.)

Also available in: Atom PDF