Bug #9187

Unable to download from Baofeng UV-5X radio

Added by Kevin Jeffers 2 months ago. Updated about 1 month ago.

Status:Closed Start date:07/06/2021
Priority:Normal Due date:07/07/2021
Assignee:Jim Unroe % Done:

100%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:All
Model affected:Radioddity UV-5G

Description

I have been attempting to program my UV-5X radio however i cannot download from either of my 2 UV-5X radios. I receive error message "An error has occurred: radio did not respond"
I am using the baofengtech FTDI programing cable and CHIRP daily version 20210706.
I receive the same error if i chose UV-5X or UV-5R
My radios have the newest firmware V1.9 and I am running a fully updated windows 10 Pro system.
The radio can be read on the same laptop and comm port, with the same cable using the pofung programing software but that interface is not very user friendly.
Please advise.

debug.log (29.9 kB) Kevin Jeffers, 07/07/2021 01:29 pm

uv5r_uv5x.py (65 kB) Jim Unroe, 07/09/2021 06:38 pm

debug.log (41.6 kB) Kevin Jeffers, 07/17/2021 10:32 am

Associated revisions

Revision 3532:5f059dbcf609
Added by Jim Unroe about 1 month ago

[UV-5G] Add support for Radioddity UV-5G/UV-5X

This patch adds support for the Radioddity UV-5G/UV-5X GMRS radio (not to be
confused with the Baofeng UV-5X released back in 2014 as a variant of the
UV-5R)

addresses issue #9187 (also #9093)

History

Updated by Rudolph Gutzerhagen 2 months ago

debug.log

Updated by Kevin Jeffers 2 months ago

Debug Log updated

Updated by Jim Unroe 2 months ago

  • Status changed from New to Feedback

Unfortunately Baofeng has no problem with coming out with new and different radio and reusing model name of an older one. The UV-5X that CHIRP supports is the older original UV-5X, not the new UV-5X that is a GMRS model.

Jim KC9HI

Updated by Kevin Jeffers 2 months ago

Agreed. In this case, I read on a different post that I should use the UV-5R setting for the new UV-5X (GMRS) radio. Even that however did not work. So hopefully there is a solution. :)

Updated by Jim Unroe 2 months ago

Kevin Jeffers wrote:

Agreed. In this case, I read on a different post that I should use the UV-5R setting for the new UV-5X (GMRS) radio. Even that however did not work. So hopefully there is a solution. :)

The UV-5X model selection is an alias of the UV-5R model selection. If one works, the other must work. If one does not work, the other must not work.

CHIRP does not support any Baofeng models that have firmware that the user can update, which would include the UV-5X (GMRS version).

Jim KC9HI

Updated by Kevin Jeffers 2 months ago

Not updating firmware. Just attempting to read stored memory to edit repeaters. Actual UV-5R and GT-5R work on my PC with my programing cable.(See original details)

Updated by Jim Unroe 2 months ago

Jim Unroe wrote:

CHIRP does not support any Baofeng models that have firmware that the user can update, which would include the UV-5X (GMRS version).

I may have misspoke on this one. CHIRP supports the Radioddity/Baofeng GT-5R model which I think might allow user firmware updates.

Jim KC9HI

Updated by Jim Unroe 2 months ago

Kevin Jeffers wrote:

Not updating firmware. Just attempting to read stored memory to edit repeaters. Actual UV-5R and GT-5R work on my PC with my programing cable.(See original details)

Nobody said you were updating firmware. What I am telling you is that the UV-5X (GMRS version) is not a CHIRP supported radio model. To get it supported would require that a UV5X along with the working OEM software gets into the hands of an interested CHIRP developer willing to do the work.

Jim KC9HI

Updated by Jim Unroe 2 months ago

I captured the "magic" string used to initiate cloning from the OEM software. It is unique to this model.

I hacked the attached driver with this string as a curiosity just to see if it can "read" your radio if the correct "magic" is used.

Download the attached test driver module to some place convenient (don't right-click to download. left-click and click "download" in the next page that appears). Save test driver module to some place convenient. Enable the developer functions in CHIRP (Help -> [X] Enable Developer Functions). Then load this test driver into CHIRP (File -> Load Module). The background should turn red to indicate that CHIRP is running with a custom driver module. Try downloading from your UV-5X using the Model: UV-5R selection (that is the selecting I temporarily modified). If you get a successful download, attach it to this issue and do nothing else.

Jim KC9HI

Updated by Kevin Jeffers 2 months ago

Followed the steps exactly and worked with CHIRP daily 20210706 installed. Got full download from my radio.

Thx Jim KC9HI !

Updated by Jim Unroe 2 months ago

  • Status changed from Feedback to In Progress
  • Assignee set to Jim Unroe
  • Model affected changed from UV-5X to Radioddity UV-5X
  • Platform changed from Windows to All

Progress has started to develop a formal patch to add support for the Radioddity UV-5X GMRS model (not to be confused with the Baofeng UV-5X introduced back in 2014 as a UV-5R variant -- and why the Vendor: Baofeng / Model: UV-5X selections do not work for this model).

Note: This ticket is basically a dupe of #9091, but since I was not aware of this when I started, #9091 has been closed and all activity will be done against this ticket.

Jim KC9HI

Updated by Jim Unroe 2 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Patch submitted. Once accepted, support will be available in the next CHIRP daily build following approval.

Jim KC9HI

Updated by Jim Unroe about 1 month ago

  • Model affected changed from Radioddity UV-5X to Radioddity UV-5G

The patch was accepted. Since the manufacturer had the FCC documents changed from UV-5X to UV-5G, the patch was updated to reflect the same. So to program a Radioddity UV-5X or Radioddity UV-5G, make the following selections.

Vendor: Radioddity
Model: UV-5G

Jim KC9HI

Updated by Jim Unroe about 1 month ago

  • Status changed from Resolved to Closed

Support for the Radioddity UV-5G/UV-5X is in today's CHIRP daily build.

Jim KC9HI

Also available in: Atom PDF