Bug #9419

ICOM IC-7300

Added by Steve Toquinto about 1 year ago. Updated 4 months ago.

Status:Closed Start date:10/03/2021
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:All
Model affected:Icom IC-7300

Description

1. What is the behavior you are seeing?
(When having Chirp download from the radio it will display those freqs stored in memory
BUT then the Radio will go into TX and stays locked up until it is either powered down or
until the program is terminated).

3. Can you reproduce the problem all the time? (YES)
I have also installed previous versions going back to
version "chirp-daily-20210406" with the same issue.

4. What are the steps required to reproduce the problem?
(Same as listed in #1)

5. Is this specific to a certain radio model (driver) or something that you can reproduce with another radio?

KB6HOH_2022-05-12_debug.log (119.8 kB) Steve Toquinto, 05/13/2022 05:24 am

IMG_0579.JPG (1.8 MB) Steve Toquinto, 05/13/2022 05:24 am

IMG_0580.JPG (1.4 MB) Steve Toquinto, 05/13/2022 05:24 am

IMG_0581.JPG (926.1 kB) Steve Toquinto, 05/13/2022 05:24 am

History

Updated by Bernhard Hailer about 1 year ago

  • Model affected changed from (All models) to Icom IC-7300
  • Platform changed from Windows to All

Updated by Bernhard Hailer 5 months ago

  • Status changed from New to Feedback

Could you please provide a debug log as described in the Wiki: "How To Report Issues"? Thanks!

Updated by Steve Toquinto 5 months ago

1. What is the behavior you are seeing?
(When having Chirp download from the radio it will display those freqs stored in memory
BUT then the Radio will go into TX and stays locked up until it is either powered down or
until the program is terminated).
_UPDATE: 2022-05-12 Same problem as before but now does NOT even read the data in the memories.
_
3. Can you reproduce the problem all the time? (YES)
I have also installed previous versions going back to
version "chirp-daily-20210406" with the same issue.

4. What are the steps required to reproduce the problem?
(Same as listed in #1)

Updated by Jim Unroe 5 months ago

Issues like this are almost always cause by the device driver installed in Windows not being compatible with the USB-to-Serial chip used in the programming cable (or sometimes the radio itself). It has noting to do with the CHIRP application itself.

I would suggest that you use the Windows Device Manager application to determine which chip is being used, then download and install the latest device driver from that chip vendor's website. The exception would be if it is a Prolific type chip. In that case, you must download, install and select the older Prolific v3.2.0.0 device driver.

See the Miklor website's Drivers and USB Cables page for links to the various chip vendors drivers and related instructions.

Jim KC9HI

Updated by Steve Toquinto 5 months ago

Jim,

You do understand that ICOM supply's the USB Serial Drivers for this Radio.
I have the latest USB Drivers and Firmware from Icom installed.
The drivers are from Silicon Labs. I don't know if they are written specifically for Icom.
I have POSTED this info on the IC-7300 Groups.io Website.
73 de Steve KB6HOH

Updated by Jim Unroe 5 months ago

Hi Steve,

Do you understand that the ICOM IC-7300 has a CI-V port and a USB port. You didn't mention which method you were using. Access to the CI-V port would be through a cable with a USB-to-Serial adapter. Mine has a CH340 chip which uses a Windows driver from WCH.

I would speculate from your reply that you are connecting via the radio's USB port. That being the case, I went ahead and disconnected my Raspberry Pi to get it out of the way and then hooked up my Windows laptop to my IC-7300. I then upgraded CHIRP to the latest CHIRP daily build. My laptop has never been hooked up to my IC-7300 before, but it has programmed many radios using a programming cables that were manufactured with the Silicon Labs CP210x chip. That being the case I let Windows use the Silicon Labs driver that has been previously installed and didn't bother with installing the one that ICOM hosts on their website. I used Device Manager to determine that the IC-7300 was assigned COM5.

My first attempted download from the IC-7300 resulted in the same errors that you experienced. Since I was using the same USB cable that I use for FT8 I knew the USB cable was OK and I assumed that the SilLabs driver was OK, I speculated that the problem most likely was do to an incorrect setting in the IC-7300. I went through the IC-7300 settings one-by-one and decided it might be...

MENU -> (2) -> SET -> Connectors -> CI-V -> CI-V USB Port and changed its selection to *Link To [REMOTE] *

After making that change, CHIRP read the memories from the IC-7300. I had never enter any memories before so all 99 were empty. I was able to key frequencies into CHIRP and they would show up in the IC-7300. Unfortunately if I keyed frequencies into the IC-7300 they didn't automatically show up in CHIRP. I had to close the IC-7300 tab and read from the radio again. So it appears that CHIRP's ICOM IC-7300 driver only offers very minimal support, it does work.

If you had to change CI-V USB Port to get this to work like I had to, don't forget to change it back when you are done. My digital modes won't work until I do.

Jim KC9HI

Updated by Steve Toquinto 5 months ago

Jim,

Tnx for the info. I got the same results as you did BUT it does work.
Since I don't have a whole lot of freqs to load I guess I can suffer thru going from Link to Unlink.
I'm guessing NOT a whole lot of support for the IC-7300.
73 de Steve KB6HOH

Updated by Bernhard Hailer 4 months ago

  • Status changed from Feedback to Closed

It looks like this is resolved.
Chirp can only affect what the radio supports. If the radio makes things difficult, then it's not anything Chirp can fix.

Also available in: Atom PDF