Project

General

Profile

Actions

Bug #9463

closed

QYT KT8900

Added by MICHEL ANTOINE DRIVET AMADOR over 1 year ago. Updated 11 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
Start date:
10/20/2021
Due date:
% Done:

0%

Estimated time:
Chirp Version:
daily
Model affected:
QYT KT8900, KT8900D
Platform:
Windows

Description

RADIO DOES NOT ENTER CLONE MODE
OLDER CHIRP VERSIONS READ CORRECTLY THE RADIO AN CAN PROGRAM IT WITHOUT AN ISSUE


Files

debug.log (50.2 KB) debug.log MICHEL ANTOINE DRIVET AMADOR, 10/21/2021 02:41 PM
debug.log (32.6 KB) debug.log THIS WORKS CORRECTLY MICHEL ANTOINE DRIVET AMADOR, 10/21/2021 05:03 PM
debug.log (32.6 KB) debug.log MICHEL ANTOINE DRIVET AMADOR, 10/21/2021 05:16 PM
QYT_KT8900_20211021.img (16.2 KB) QYT_KT8900_20211021.img MICHEL ANTOINE DRIVET AMADOR, 10/21/2021 05:16 PM
debug.log (32.6 KB) debug.log MICHEL ANTOINE DRIVET AMADOR, 10/21/2021 05:16 PM
QYT_KT8900_20211021.img (16.2 KB) QYT_KT8900_20211021.img MICHEL ANTOINE DRIVET AMADOR, 10/21/2021 05:16 PM
kt8900_test_#1.py (153 KB) kt8900_test_#1.py Jim Unroe, 10/21/2021 06:29 PM
Actions #1

Updated by Jim Unroe over 1 year ago

  • Status changed from New to Feedback

Which is it, KT8900 or KT8900D?

If it is a KT8900, then this is most likely the same as issue #9459. Please check there to see if it is. If it is, then a patch has already been submitted. Use the temporary test driver module until a CHIRP daily build is released that includes the patch.

If this is a KT8900D, then include the MCU version from the OEM software or attach a CHIRP debug.log file.

Jim KC9HI

Actions #2

Updated by MICHEL ANTOINE DRIVET AMADOR over 1 year ago

THANKS FOR THE ANSWER I ALREADY LOADED DE MCU, BUT SENDS THE SAME ERROR

Radio did not enter clone mode. You may want to try it as a WACCOM MINI-8900, there is a known variant of this radios that is a clone of it.

Actions #3

Updated by Jim Unroe over 1 year ago

What is the newest version of CHIRP that will work with this radio?

Jim KC9HI

Actions #4

Updated by MICHEL ANTOINE DRIVET AMADOR over 1 year ago

THE LAST ONE THAT I USED WITH THIS RADIO WAS CHIRP DAILY 20200827 I STIL HAVE THE INSTALLER EXE

Actions #5

Updated by Jim Unroe over 1 year ago

Please install it, open CHIRP, download from your radio, close CHIRP. Then attach the debug.log file and the downloaded CHIRP Radio Images (*.img) file.

Jim KC9HI

Actions #6

Updated by MICHEL ANTOINE DRIVET AMADOR over 1 year ago

IT WAS EVEN AN OLDER VERSION THAT WORKS CORRECTLY DAILY 20200227

Actions #9

Updated by Jim Unroe over 1 year ago

There is no change in the code in the area where the cloning process fails. This must be a timing issue. It may take some trial-and-error to come up with a solution.

The current driver makes 3 attempts to initialize the cloning process. I have attached a test driver module that increases the number of attempts to 5 and also adds a 0.5 second pause between attempts. Try it and let me know what the result is.

Thanks you,
Jim KC9HI

Actions #10

Updated by Bernhard Hailer 9 months ago

  • Priority changed from High to Normal
  • Model affected changed from QYT8900 8900D to QYT KT8900, KT8900D

Did the test driver work? We will close this ticket soon.

Actions #11

Updated by Bernhard Hailer 11 days ago

  • Subject changed from QYT8900 to QYT KT8900
  • Status changed from Feedback to Closed

No more feedback.

Actions

Also available in: Atom PDF