New Model #959

ICOM IC-2300H support

Added by Jim MacKenzie almost 8 years ago. Updated about 1 year ago.

Status:Closed Start date:07/09/2013
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Chirp Version:daily Equipment Loan Offered:No

Description

I'd like to add the ICOM IC-2300H to the list of radios we support. We already support the -2100H and -2200H and I'm hoping that relatively minor changes to that support might work with the 2300 (we shall see).

Icom_IC-2300H.img - Factory default image for Icom IC-2300H (6.2 kB) Windsor Schmidt, 06/25/2017 03:40 pm

Associated revisions

Revision 2908:0b2aaa54f308
Added by Windsor Schmidt almost 4 years ago

[New Model] Add Support for Icom IC-2300H Radio

Patch for review; based on existing code for the IC-2200H.

#959

History

Updated by mike 240 over 7 years ago

Jim MacKenzie wrote:

I'd like to add the ICOM IC-2300H to the list of radios we support. We already support the -2100H and -2200H and I'm hoping that relatively minor changes to that support might work with the 2300 (we shall see).

Is there any update on this radio? Is there any way I can help? I get mine in the mail tomorrow.

Updated by mike 240 over 7 years ago

i got my radio, please let me know how i can help.

Updated by mike 240 over 7 years ago

anyone?

Updated by Ken Settlemyer about 7 years ago

I'd like to add my name to interested parties for the 2300h also...

Updated by Ken Settlemyer about 7 years ago

Ken Settlemyer wrote:

I'd like to add my name to interested parties for the 2300h also...

I can also loan the radio if that helps... getting a 2820 in a few days, so can be without it for a period of time...

Updated by Dan Starkenburg almost 7 years ago

Jim MacKenzie wrote:

I'd like to add the ICOM IC-2300H to the list of radios we support. We already support the -2100H and -2200H and I'm hoping that relatively minor changes to that support might work with the 2300 (we shall see).

Ditto that for me!

Tnx & 73,
Dan / ab0re

Updated by Darin Langhorn over 6 years ago

Just bought an IC-2300h. Should have checked to see if the CHIRP SW was out yet. Any updates? I would like to be added to the list of interested parties. Thanks

Updated by Geoff Scott about 6 years ago

Is this model ever going to get into the roadmap?

Updated by William Hoblitzell Jr about 6 years ago

Geoff Scott wrote:

Is this model ever going to get into the roadmap?

I've been wanting to know the same thing? I have a 2300H that I would be willing to let be used if it would help with the process.

73
William/ KF5WNY

Updated by Francis Santos almost 6 years ago

I have 3 units and it will be more easier and easy to deploy if we can have CHIRP work with it.

thanks a lot & more power.

Updated by Alfredo Betancourt almost 6 years ago

Hello, I have been using CHIRP with a Baofeng and is great, now I have an Icom IC2300H and would really like to program it with CHIRP. When will you have it ready for the 2300H?
Thank you.

Updated by Andrew Konosky over 4 years ago

I recently purchased a IC-2300H and have a USB cable. Chirp does not work with it when setting the model to the 2200H. Any ETA on support for this? Any data I can gather from my Linux system via the USB cable to send you?

Updated by William Pilgrim about 4 years ago

Count me in as wanting to add the IC-2300 to the Chirp list.
Thanks!

KA0RSN

Updated by Tom Leung about 4 years ago

I will add my request as well for the ICOM 2300H. Thank you.

VE7TLW

William Pilgrim wrote:

Count me in as wanting to add the IC-2300 to the Chirp list.
Thanks!

KA0RSN

Updated by Windsor Schmidt almost 4 years ago

Hi developers,

I've written a new module to support the IC-2300H, based on the existing IC-2200H module. Works for me; passes the automated tests, and most everything but the bank link feature is accessible from the GUI. A factory default image for the radio is attached, with a patch for review to follow. Thanks,

Windsor / W7FZ

Updated by Windsor Schmidt almost 4 years ago

  • Status changed from New to Feedback

Hi, all.

Revision 2908:0b2aaa54f308 adds a patch to support the IC-2300H, now in the automated builds. Please test and post any feedback here. Thanks!

http://trac.chirp.danplanet.com/chirp_daily/daily-20170627

Updated by Josh Beach over 3 years ago

I've tested connecting to my 2300h on daily 20170714. I've used both Windows and Arch Linux, with both a Prolific and FTDI adapter cable.

I receive the error "Failed to Communicate with Radio: Unexpected response from Radio" on both OSes when the 2300h is in Cloning mode, but idle and I try to connect.

When I press the "Clone Out" button on the radio and try, I receive the error "Out of Sync with radio."

Please let me know what I can do to help get it working.

Updated by Dan Smith over 3 years ago

Don't put the radio into clone mode first. Unlike Yaesu radios, Icom radios are smart and can be controlled fully by the computer. Just turn it on and tell chirp to start the download.

Updated by Windsor Schmidt over 3 years ago

For what it's worth, I'm also using Arch Linux and an FTDI-based cable. As Dan says, don't enter clone mode manually, however you will have to manually power-cycle the radio after cloning.

Updated by Josh Beach over 3 years ago

And there it is. I feel a little sheepish. Thanks everyone.

I can confirm it works both in detect and 2300h mode with absolutely no issues.

Updated by Bernhard Hailer about 1 year ago

  • Status changed from Feedback to Closed

Support added two years ago.

Also available in: Atom PDF