Bug #9617

Unable to See Settings

Added by Dustin Barrons 11 months ago. Updated 11 months ago.

Status:Closed Start date:12/17/2021
Priority:Normal Due date:
Assignee:Jim Unroe % Done:

100%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:All
Model affected:BTECH UV-5X3

Description

I purchased a new BTECH UV-5X3 last week and downloaded CHIRP. On first install and download, I was able to see all settings for the radio. I saved an unedited version of this radio as an image (attached - BTECH_UV-5X3_001). I made changes to settings and channels, and saved images (attached - BTECH_UV-5X3_001_20211215). After a week, I re-downloaded from the radio and the settings tab in CHIRP was completely blank (attached - BTECH_UV-5X3_001_20211215). Assuming there was an issue with the image file, I closed CHIRP, reopened, and attempted to open the original, unaltered image. Settings were mow showing as blank - though they existed and were editable previously. I reset this radio and attempted again. Settings were still blank.

Assuming the radio firmware was corrupt, I returned/purchased a new BTECH UV-5X3. I immediately downloaded and saved an image file (attached - BTECH_UV-5X3_002), only to find that this, also, had a blank settings screen. The attached debug.log is related to this attempt, on the new radio.

As I've attempted this with 2 different radios, one that was brand new and completely unaltered from factory, I can only assume that something is going on with CHIRP.

Any help would be greatly appreciated. Thank you.

BTECH_UV-5X3_001.img - Original Radio - Factory Settings (8.2 kB) Dustin Barrons, 12/17/2021 04:44 pm

BTECH_UV-5X3_001_20211215.img - Original Radio - Edited Settings (8.2 kB) Dustin Barrons, 12/17/2021 04:44 pm

BTECH_UV-5X3_002.img - New Radio - Factory Settings (8.2 kB) Dustin Barrons, 12/17/2021 04:44 pm

Radio Download.jpg - New Radio - Download Settings (26.3 kB) Dustin Barrons, 12/17/2021 04:44 pm

Radio Clone Progress.jpg - New Radio - Clone Progress (was completed successful) (14.9 kB) Dustin Barrons, 12/17/2021 04:44 pm

Radio Memories.jpg - New Radio - Memories (429.7 kB) Dustin Barrons, 12/17/2021 04:44 pm

Radio Settings (blank).jpg - New Radio - Blank Settings (130.5 kB) Dustin Barrons, 12/17/2021 04:44 pm

debug.log - Debug (125.9 kB) Dustin Barrons, 12/17/2021 04:44 pm

BTECH_UV-5X3_002_20211218.img (8.2 kB) Dustin Barrons, 12/18/2021 09:09 am

Settings Successful.jpg (339 kB) Dustin Barrons, 12/18/2021 09:09 am

ERROR.png (34.5 kB) Jon Tish, 12/21/2021 06:54 am

Associated revisions

Revision 3636:c086af63968a
Added by Jim Unroe 11 months ago

[UV-5X3] Fix for Unable to See Settings on BTECH UV-5X3

The BTECH UV-5X3 as shipped from the factory does not always have all 6 of the
sub-VFOs populated with frequencies. This was generating and error conditions
that was preventing the Settings tabs from being displayed.

This patch detects an unpopulated sub-VFO setting and populates the setting
with the appropriate low band limit frequency.

fixes #9617

History

Updated by Jim Unroe 11 months ago

  • Status changed from New to In Progress
  • Assignee set to Jim Unroe
  • Target version set to chirp-daily
  • Platform changed from Windows to All

Apparently something got messed up with the submission of a new feature. While it is being sorted out, use the CHIRP daily-20211118 build (which was the build prior to the new feature being added).

Jim KC9HI

Updated by Jim Unroe 11 months ago

It would appear that these radios don't come from the factory with the values for the new feature fully populated. Try the following...

1. Tap the [VFO/MR] key as needed to switch to VFO mode
2. Key in a VHF frequency
3. Key in a 220 frequency
4. Key in a UHF frequency
5. Tap the [A/B] key to switch to the other VFO
6. Repeat steps 2 through 4

Now download from your UV-5X3 and look to see if the Settings tabs appears. Report back the results.

Thanks,
Jim KC9HI

Updated by Dustin Barrons 11 months ago

Reply #2 worked!!! Using CHIRP daily -20211216, I cycled VHF/220/UHF channels on A and B, redownloaded, and voila! Settings now appear.

Thank you TREMENDOUSLY for the quick and accurate response. Much appreciated!!!

Updated by Jim Unroe 11 months ago

Dustin Barrons wrote:

Reply #2 worked!!! Using CHIRP daily -20211216, I cycled VHF/220/UHF channels on A and B, redownloaded, and voila! Settings now appear.

Thank you TREMENDOUSLY for the quick and accurate response. Much appreciated!!!

After further review, it would have only required cycling through the B VFO. The A VFO is fully populated and only the B VFO is missing a value causing an out-of-range value that broke the display of the Settings tabs.

Jim KC9HI

Updated by Jim Unroe 11 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

A patch has been submitted. A sub-VFO that isn't populated with a frequency will be gracefully handled in the next CHIRP daily build following acceptance of the patch.

Jim KC9HI

Updated by Anonymous 11 months ago

  • Status changed from Resolved to Closed

Applied in changeset c086af63968a.

Updated by David Billcheck 11 months ago

Hi Jim,

Just checked my 5X3 files
Loaded a saved file and my settings do not show.
Will get my 5X3 radios and do a fresh download to see if the settings show.
Probably have access to them in a frw days. maybe Dec22.

Updated by Jim Unroe 11 months ago

David Billcheck wrote:

Hi Jim,

Just checked my 5X3 files
Loaded a saved file and my settings do not show.
Will get my 5X3 radios and do a fresh download to see if the settings show.
Probably have access to them in a frw days. maybe Dec22.

Right. Any previously saved file will have an unpopulated UHF sub-VFO frequency slot that causes the settings to not display. You will either have to upload each file into your radio, do the procedure on the B VFO like you did before and then download to CHIRP to fix it. Or, better yet, just wait until tomorrow when the CHIRP daily build with the fix will be available.

Jim KC9HI

Updated by David Billcheck 11 months ago

Just loaded uv5x3_6VFOs.py and now I get my settings back
Did not need to load a module when originally got radios and
downloaded a factory image and modded my settings.

Used BTECH UV5X3 straight off of the drop down menu for BTECH

Something is wierd here. Didn't need to load a module before for the 5X3

Dave

Updated by David Billcheck 11 months ago

Was on 20211208 daily and have always shown 6 VFO's on the settings page "other settings".
This new build 20211216 will not show settings unless I load module uv5x3_6VFOs.py.
Other modules show blank settings page.

Dave

Updated by Jim Unroe 11 months ago

Sorry, Dave. I got you mixed up with Dustin.

There was a new feature added to the BTECH UV-5X3 in early December. It works fine with a radio that has been in service and frequencies keyed into the VFO. It was discovered later that the "factory" state had a frequency missing in one of the sub-VFO memory slots which the code wasn't expecting (or prepared to handle) a missing frequency.

You can install and use a CHIRP daily build from November if you need to run tonight. Or you can just wait until tomorrow (shortly after midnight PDT) and install the new CHIRP daily build with the fix.

Jim KC9HI

Updated by David Billcheck 11 months ago

Thanks Jim.

Tomorrows fix will be welcomed.

Dave

Updated by Jon Tish 11 months ago

David Billcheck wrote:

Was on 20211208 daily and have always shown 6 VFO's on the settings page "other settings".
This new build 20211216 will not show settings unless I load module uv5x3_6VFOs.py.
Other modules show blank settings page.

Dave

I just tried the new daily build for myself, and I can confirm that I am still getting a blank settings page with both of my new UV5R's. I've tried switching VFO's downloading older builds, everything. Still can't see the settings page at all.

Updated by Jim Unroe 11 months ago

This issue was related to the BTECH UV-5X3. Since you added to this issue, I assumed that your radios were the BTECH UV-5X3. This issue does not affect the UV-5R model in any way.

A missing settings tab is usually caused by one or more setting in the radio is set to an invalid and/or out-of-range value. Open up an issue for your radios and I will be able to help you with it.

Jim KC9HI

Also available in: Atom PDF