Bug #9703

CRT Micron Alias RETEVIS-95

Added by Dae k 6 months ago. Updated 5 months ago.

Status:Closed Start date:01/14/2022
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:Linux
Model affected:Retevis RT-95

Description

OS: Lubuntu 18.04.6 (with lxde)
Kernel: Linux version 4.15.0-163-generic (buildd@lcy01-amd64-021) (gcc version 7.5.0 (Ubuntu 7.5.0-3ubuntu1~18.04)) #171-Ubuntu SMP Fri Nov 5 11:55:11 UTC 2021
Chirp: CHIRP daily-20220103 on Linux - Ubuntu 18.04.6 LTS (Python 2.7.17)

======= Install via Flatpak =======
Fail

From the official website i have download the flatpak file.
when i try doubleclic on it, i take a error about dl.flathub
and if i try with terminal ...

  • 773 flatpak install ./chirp-daily-20220103.flatpak
  • 774 /usr/bin/flatpak run --branch=master --arch=x86_64 --command=chirpw --file-forwarding com.danplanet.chirp @ %F @
  • 775 man flatpak
  • 776 flatpak -list
  • 777 flatpak-list
  • 778 flatpak list
  • 779 flatpak run com.danplanet.chirp
  • 780 flatpak update
  • 781 sudo add-apt-repository ppa:alexlarsson/flatpak
  • 782 sudo apt update ; sudo apt install flatpak
  • 783 flatpak install ./chirp-daily-20220103.flatpak
  • 784 sudo flatpak install ./chirp-daily-20220103.flatpak
  • 785 sudo apt install flatpak gnome-software-plugin-flatpak gnome-software
  • 786 flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
  • 787 flatpak install flathub
  • 788 flatpak install --user flathub
  • 789 flatpak install flathub --user
  • 790 flatpak list
  • 791 flatpak start flathub
  • 792 flatpak run flathub
  • 793 0
  • 794 flatpak run chirp
  • 795 flatpak install flathub
  • 796 sudo ostree --repo=/var/lib/flatpak/repo/ config set core.min-free-space-percent 1
  • 797 strace -o log -f -yy flatpak --user update org.gnome.Platform/x86_64/3.24
  • 798 sudo flatpak install flathub
  • 799 sudo flatpak install ./chirp-daily-20220103.flatpak
  • 800 flatpak install org.freedesktop.Platform/x86_64/19.08
  • 801 flatpak uninstall --unused
  • 802 flatpak update
  • 803 flatpak install ./chirp-daily-20220103.flatpak
  • 804 sudo flatpak repair --user
  • 805 flatpak install ./chirp-daily-20220103.flatpak
  • 806 flatpak repair --user
  • 807 sudo rm -rfv /home/bambi/.local/share/flatpak/repo/.lock
  • 808 flatpak repair --user
  • 809 flatpak install ./chirp-daily-20220103.flatpak
~/Téléchargements$ flatpak install ./chirp-daily-20220103.flatpak
Required runtime for com.danplanet.chirp/x86_64/master (runtime/org.freedesktop.Platform/x86_64/19.08) found in remote flathub
Do you want to install it? [Y/n]: y
Info: org.freedesktop.Platform//19.08 is end-of-life, with reason:
   The Freedesktop SDK 19.08 runtime is no longer supported as of September 1, 2021. Please ask your application developer to migrate to a supported version
Applications using this runtime:
   com.danplanet.chirp
Info: org.freedesktop.Platform.VAAPI.Intel//19.08 is end-of-life, with reason:
   The Freedesktop SDK 19.08 runtime is no longer supported as of September 1, 2021. Please ask your application developer to migrate to a supported version
Info: org.freedesktop.Platform.GL.default//19.08 is end-of-life, with reason:
   The Freedesktop SDK 19.08 runtime is no longer supported as of September 1, 2021. Please ask your application developer to migrate to a supported version

com.danplanet.chirp permissions:
    ipc    network   wayland   x11   devices   file access [1]

    [1] home

        ID                                 Branch           Op           Remote                Download
 1. [✗] org.freedesktop.Platform           19.08            i            flathub               1,0 kB / 238,5 MB
 2. [ ] com.danplanet.chirp                master           i            chirp-origin          0 bytes

Error: Error deploying: Failed to read commit a85bd015f1731e68cd057a07f76ab109fa70225dc89fe35d588013d7c2df334d: No such metadata object 8ed38508cbc96bd33e5da2a4dfa6ac6dc907ef0f3004c4cf4adc4bf8ae5fa4a2.dirtree
error: Failed to install org.freedesktop.Platform: Error deploying: Failed to read commit a85bd015f1731e68cd057a07f76ab109fa70225dc89fe35d588013d7c2df334d: No such metadata object 8ed38508cbc96bd33e5da2a4dfa6ac6dc907ef0f3004c4cf4adc4bf8ae5fa4a2.dirtree

======= Run with sources ========
i think i don't understand how use a

======= Install via ppa ========
Sucess
sudo add-apt-repository ppa:dansmith/chirp-snapshots ; sudo apt update ; sudo apt install chirp-daily ; sudo chirpw
(i run chirpw on root because without it can't acces to radio)

======= find the radio =======
Double fails (why i'm here)

with the lasted daily version
and with the script from
https://chirp.danplanet.com/attachments/download/5613/20200522_anytone778uv.py

the windows become red but not RT95 on list


Related issues

duplicates Bug #9547: Retevis RT95 Feedback 11/16/2021

History

Updated by Bernhard Hailer 6 months ago

  • Status changed from New to Closed
  • Priority changed from Urgent to Normal
  • Model affected changed from RT-95 to Retevis RT-95

#Duplicates ticket #9547, which also lists a likely solution for your problem.

Updated by Dae k 5 months ago

excuse me, but how does this solve my flatpak problem?
or with the sources ?

Updated by Jim Unroe 5 months ago

You most likely don't have the flatpak fully installed. In addition to that, the RT95 and its variants require the addition of the Python future package. Without "future", the models that are dependent on it will not be listed in CHIRP.

Jim KC9HI

Updated by Dae k 5 months ago

the specific problem with RT-95 has been solved in another post
what I would like to know is what I did not understand or did not execute correctly to use flatpak or use chirp from the zip

Updated by Jim Unroe 5 months ago

Dae k wrote:

the specific problem with RT-95 has been solved in another post
what I would like to know is what I did not understand or did not execute correctly to use flatpak or use chirp from the zip

For linux distributions derived from Ubuntu prior to 20.04 (which would include you Lubuntu 18.04.6) you do not need to use the flatpak. You can add the PPA as described on the Running Under Linux wiki page.

Linux distributions derived from Ubuntu 20.04 and later have dropped Python 2.7 and other CHIRP dependencies. So to run CHIRP you would either have to add Python 2.7 and track down the remaining dependencies. The flatpak was created to eliminate the need to do this. A properly installed flatpak brings along everything needed except the future package.

The "win32.zip" build is for Windows. The "tar.gz" build is for linux and has the same requirements as mentioned above.

Jim KC9HI

Updated by Dae k 5 months ago

i have python2.7 and 3.8 on my distrib,
but i recive the message "Error: Error deploying: Failed to read commit "
or "no free space" but i have 20gio free :/ very strange

and i don't realy understand how use tar.gz after unzip it.

Also available in: Atom PDF