New Model #9991

CRT Electro UV aka Retevis RA25(?) aka AnyTone AT779UV(?) aka Radioddity DB20G(?)

Added by Andreas Schroeder about 1 month ago. Updated about 1 month ago.

Status:Feedback Start date:08/16/2022
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Equipment Loan Offered:No

Description

The CRT Electro UV is a nice and cheap VHF/UHF-FM Tranceiver, but the software is crap. You don't believe how bad this little peace of software is. I tried also the special software from AnyTone, Retevis and Radioddity - same crap. I tried with CHIRP several other models, but no good result.

CRT Electro UV: https://www.crtfrance.com/en/mobiles-transceivers/975-crt-electro-uv.html
Retevis RA25: https://www.retevis.com/ra25-dual-band-mobile-ham-radio
AnyTone AT779UV: http://anytone.net/pro_info100.html
Radioddity DB20G: https://www.radioddity.com/products/radioddity-db20g

History

Updated by Jim Unroe about 1 month ago

  • Status changed from New to Closed

Dupe of #9902 (RA25)
Dupe of #8953 (AT-779UV)
Dupe of #9241 (DB20G)

Please particpate, contribute and watch these existing issues.

From the How To Report Issues page.

Please DO NOT attach the manufacturer's software to the issue. Even if you think the software is freely available via download elsewhere, that does not mean you can legally distribute it yourself. Posting it here also opens up the CHIRP website and community to potential action by owners of that software. If it is downloadable somewhere, feel free to post a link but DO NOT attach it to the issue.

Jim KC9HI

Updated by Jim Unroe about 1 month ago

  • File deleted (crt_elektro_prg_soft.exe)

Updated by Jim Unroe about 1 month ago

  • Status changed from Closed to Feedback

Also available in: Atom PDF