Bug #334

TYT TH-UV3R :: chirp program seems to access radio but writes empty .img file

Added by Steve Jackson almost 9 years ago. Updated 5 months ago.

Status:Closed Start date:10/25/2012
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:Windows
Model affected:TYT TH-UV3R

Description

The 10/19 daily build was used to try and download radio programming.

Radio was programmed by factory supplied software, about 40 memory channels.

Using same cable as used successfully to program radio with factory software, chirp can access rig, but when reading, light on rig flashes red (indicating write cycles), not green (read cycles), that seems wrong.

Radio memories not overridden, if that matters.

Resulting .img file on PC is empty.

debug.log (14.5 kB) Steve Jackson, 03/19/2013 09:23 pm

chirp.config (435 Bytes) Steve Jackson, 03/19/2013 09:23 pm

t7h.img (944 Bytes) Steve Jackson, 03/19/2013 09:23 pm


Related issues

related to Bug #7969: TYT TH-UV3R - Channels not available after Upload to Radio Feedback 06/09/2020

History

Updated by Steve Jackson almost 8 years ago

This problem either has something to do with the manual setting of the COM port for the USB adapter or the radio communications protocol (possibly related to the newer command set for this model radio that have the 2.5 kHz step ability). The application seems to be able to 'talk' to the Prolific serial port emulator, and the radio side of the link communicates with the rig. However, no information is extracted.

Others privately report that this application and cable work on different computer/OS combinations, but only when the COM port setting is chosen from the GUI (not manually entered) and is on a port number between 1 and 9.

Updated by Dan Smith almost 8 years ago

  • Status changed from New to Blocked

Not sure how that possibly makes any sense, given that choosing something from the drop-down just fills in a text string. However, without a debug.log I can't/won't investigate any further. Instructions on how to fill out useful bug reports are in the documentation.

Updated by Steve Jackson over 7 years ago

Problem: TYT TH-UV3R , cannot read or write memory contents
Reproducible: always

Icom T7H tested first to see if new version of program and USB cable working OK.
Use COM11.
Verified read all memories, save .img file, write all memories to that radio, all OK.

Changed cable to TYT TH-UV3R interface.

Attempt to read existing 44 TYT TH-UV3R radio memory channels.
Program accesses radio, blinks LED red, but resulting file is empty.

Attempt to use Icom image file contents to write to TYT radio.
Program accesses radio, LED blinks green.
Does not program correct contents.

First six TYT memories, previously written, now corrupted.

Updated by Bernhard Hailer 6 months ago

  • Status changed from Blocked to Feedback
  • Target version set to chirp-daily
  • Model affected changed from (All models) to TYT TH-UV3R

I realize this was a long time ago. Have you been able to resolve this on your own since you submitted this?
This looks like a cable issue (are you sure you were using the correct COM port?). Please refer to these Wiki articles:
CableGuide
CableGuide FTDI OEM Cables
RTSystemsCablesAndMavericks (if you're running MacOS)

Updated by Bernhard Hailer 5 months ago

  • Status changed from Feedback to Closed

No more feedback by submitter.

Also available in: Atom PDF

prevent spam