Bug #5545

Icon Ic2200h no longer will upload or download

Added by John Wilkerson over 2 years ago. Updated 6 months ago.

Status:Closed Start date:02/02/2018
Priority:Normal Due date:
Assignee:Rhett Robinson % Done:

0%

Category:-
Target version:-
Chirp Version:daily Platform:Windows
Model affected:Icom IC-2200H

Description

Recent versions have broken the transfer protocol for older Icom radios. As such, chirp no longer supports these radios.

Associated revisions

Revision 2952:e3b90fa8c316
Added by Rhett Robinson over 2 years ago

Fix older Icom radio models by properly sending commands with raw encoding.

Fixes #5545.

History

Updated by Dan Smith over 2 years ago

  • Assignee set to Rhett Robinson

Hi Rhett,

It looks like your icf patch did break other Icom radios. Can you take a look please?

Thanks!

Updated by Rhett Robinson over 2 years ago

Yes, I'll take a look. My natural suspicion is when I added the raw support: https://chirp.danplanet.com/projects/chirp/repository/revisions/ebcb6aeda1b8 since that is the only of my changes that could affect other drivers.

I don't have an IC2200h, but it would be helpful if possible if the reporter could compare chirp versions and determine at which version support actually broke. That would help narrow down and confirm if my change caused the regression.

John, do you know when this first happened?

Updated by Rhett Robinson over 2 years ago

Also if you could describe the way it fails: does it fail to read from the radio? Write to the radio? Recognize the radio? Something else?

Updated by Rhett Robinson over 2 years ago

Okay, I believe I realize what happened. When I refactored my original patch into the two-phase patch and introduced an IcomRawCloneModeRadio I inadvertently BCD-encoded all day for the original radio type. Previously, it would BCD-encode only the memory contents, and other commands, such as getting the model or putting the radio into clone mode, were sent raw. This will be an easy fix.

Updated by Bernhard Hailer 6 months ago

  • Status changed from New to Closed
  • Priority changed from Urgent to Normal
  • Chirp Version changed from 0.4.0 to daily
  • Model affected changed from Icom older models to Icom IC-2200H

Patch applied. No more traffic on this ticket.

Also available in: Atom PDF

prevent spam