Bug #5853

Chirp crashes in set_dock_icon_pixbuf on launch on OS X

Added by Jeff Lane about 2 years ago. Updated 2 months ago.

Status:Closed Start date:06/03/2018
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Chirp Version:daily Platform:MacOS
Model affected:(All models)

Description

OSX High Sierra version 10.13.4 (17E202)
Macbook Air

The install seems to have been successful. I had to re-install homebrew first, but then it worked fine:
$ brew install tdsmith/ham/chirp
> Tapping tdsmith/ham
Cloning into '/usr/local/Homebrew/Library/Taps/tdsmith/homebrew-ham'...
remote: Counting objects: 7, done.
remote: Compressing objects: 100% (7/7), done.
remote: Total 7 (delta 0), reused 4 (delta 0), pack-reused 0
Unpacking objects: 100% (7/7), done.
Tapped 3 formulae (34 files, 26.7KB)
> Installing chirp from tdsmith/ham
> Installing dependencies for tdsmith/ham/chirp: gettext, libffi, pcre, glib, jpeg, libtiff, libpng, gdk-pixbuf, atk, freetype, fontconfig, pixman, cairo, fribidi, graphite2, icu4c, harfbuzz, pango, hicolor-icon-theme, gtk+, libepoxy, gsettings-desktop-schemas, gtk+3, gdbm, openssl, readline, sqlite, python@2, pygobject, py2cairo, pygtk, gtk-mac-integration, libxml2
> Installing tdsmith/ham/chirp dependency: gettext
> Downloading https://homebrew.bintray.com/bottles/gettext-0.19.8.1.high_sierra.bottle.tar.gz
  1. 100.0%
    > Pouring gettext-0.19.8.1.high_sierra.bottle.tar.gz

Caveats

This formula is keg-only, which means it was not symlinked into /usr/local,
because macOS provides the BSD gettext library & some software gets confused if both are in the library path.

If you need to have this software first in your PATH run:
echo 'export PATH="/usr/local/opt/gettext/bin:$PATH"' >> ~/.bash_profile

For compilers to find this software you may need to set:
LDFLAGS: -L/usr/local/opt/gettext/lib
CPPFLAGS: -I/usr/local/opt/gettext/include

> Summary

History

Updated by Jeff Lane about 2 years ago

It seems to have truncated my initial bug..

here's what happens when I try running Chirp on OSX:

$ chirp
2018-06-03 11:50:29.105 python2.7[29521:552549] *** Terminating app due to uncaught exception 'NSImageCacheException', reason: 'Cannot lock focus on image <NSImage 0x7fdafcdc3240 Size={0, 0} Reps=(
)>, because it is size zero.'
*** First throw call stack:
(
    0   CoreFoundation                      0x00007fff4a18e32b __exceptionPreprocess + 171
    1   libobjc.A.dylib                     0x00007fff71808c76 objc_exception_throw + 48
    2   CoreFoundation                      0x00007fff4a21fdcd +[NSException raise:format:] + 205
    3   AppKit                              0x00007fff47800ca1 -[NSImage _lockFocusOnRepresentation:rect:context:hints:flipped:] + 316
    4   AppKit                              0x00007fff47800b5e __51-[NSImage lockFocusWithRect:context:hints:flipped:]_block_invoke + 82
    5   AppKit                              0x00007fff477c44d8 -[NSImage _usingBestRepresentationForRect:context:hints:body:] + 164
    6   AppKit                              0x00007fff47800b03 -[NSImage lockFocusWithRect:context:hints:flipped:] + 162
    7   AppKit                              0x00007fff47864eda -[NSImage lockFocusFlipped:] + 123
    8   libgtkmacintegration-gtk2.2.dylib   0x000000011164b7e4 nsimage_from_pixbuf + 201
    9   libgtkmacintegration-gtk2.2.dylib   0x000000011164aec6 gtkosx_application_set_dock_icon_pixbuf + 29
    10  _gtkosx_application.so              0x000000011163d2bb _wrap_gtkosx_application_set_dock_icon_pixbuf + 119
    11  Python                              0x000000010c09b367 PyEval_EvalFrameEx + 19822
    12  Python                              0x000000010c09f489 fast_function + 196
    13  Python                              0x000000010c09b26a PyEval_EvalFrameEx + 19569
    14  Python                              0x000000010c0963e2 PyEval_EvalCodeEx + 1562
    15  Python                              0x000000010c03cce4 function_call + 327
    16  Python                              0x000000010c01f160 PyObject_Call + 97
    17  Python                              0x000000010c029a0d instancemethod_call + 163
    18  Python                              0x000000010c01f160 PyObject_Call + 97
    19  Python                              0x000000010c06562e slot_tp_init + 64
    20  Python                              0x000000010c06278c type_call + 182
    21  Python                              0x000000010c01f160 PyObject_Call + 97
    22  Python                              0x000000010c09b354 PyEval_EvalFrameEx + 19803
    23  Python                              0x000000010c0963e2 PyEval_EvalCodeEx + 1562
    24  Python                              0x000000010c095dc2 PyEval_EvalCode + 32
    25  Python                              0x000000010c0b77ab run_mod + 49
    26  Python                              0x000000010c0b7852 PyRun_FileExFlags + 130
    27  Python                              0x000000010c0b73d4 PyRun_SimpleFileExFlags + 706
    28  Python                              0x000000010c0c8f54 Py_Main + 3136
    29  libdyld.dylib                       0x00007fff72422015 start + 1
)
libc++abi.dylib: terminating with uncaught exception of type NSException
Abort trap: 6

Updated by Jeff Lane about 2 years ago

quick and dirty check of python2 shows that the interpreter doesn't crash on its own:
$ python2 -c 'print "Hello world"'
Hello world

Updated by Jeff Lane about 2 years ago

And finally, I also downloaded the zip file of the Chirp Daily (daily is dated July 2017) and tried running that. I got the same crash as above.

Updated by Jim Unroe about 2 years ago

  • Status changed from New to Feedback
  • Platform changed from Windows to MacOS

Did you download and install the required KK7DS Python runtime for MacOS X?

Jim KC9HI

Updated by Armando Flores about 2 years ago

Same problem here but it seems to be that the problem is during the startup of the UI

It worked fine a couple of weeks ago. I wonder if a recent update has something to to with it.

Is there anything I can do to help? Thx for CHIRP

2018-06-14 23:02:30.578 python2.7[5025:148561] *** Terminating app due to uncaught exception 'NSImageCacheException', reason: 'Cannot lock focus on image <NSImage 0x7fb7ef8a1860 Size={0, 0} Reps=(
)>, because it is size zero.'
*** First throw call stack:
(
    0   CoreFoundation                      0x00007fff291c832b __exceptionPreprocess + 171
    1   libobjc.A.dylib                     0x00007fff50336c76 objc_exception_throw + 48
    2   CoreFoundation                      0x00007fff29259dcd +[NSException raise:format:] + 205
    3   AppKit                              0x00007fff26837ca1 -[NSImage _lockFocusOnRepresentation:rect:context:hints:flipped:] + 316
    4   AppKit                              0x00007fff26837b5e __51-[NSImage lockFocusWithRect:context:hints:flipped:]_block_invoke + 82
    5   AppKit                              0x00007fff267fb4d8 -[NSImage _usingBestRepresentationForRect:context:hints:body:] + 164
    6   AppKit                              0x00007fff26837b03 -[NSImage lockFocusWithRect:context:hints:flipped:] + 162
    7   AppKit                              0x00007fff2689beda -[NSImage lockFocusFlipped:] + 123
    8   libgtkmacintegration-gtk2.2.dylib   0x000000010b4ba7e4 nsimage_from_pixbuf + 201
    9   libgtkmacintegration-gtk2.2.dylib   0x000000010b4b9ec6 gtkosx_application_set_dock_icon_pixbuf + 29
    10  _gtkosx_application.so              0x000000010b4ac2bb _wrap_gtkosx_application_set_dock_icon_pixbuf + 119
    11  Python                              0x0000000105cce367 PyEval_EvalFrameEx + 19822
    12  Python                              0x0000000105cd2489 fast_function + 196
    13  Python                              0x0000000105cce26a PyEval_EvalFrameEx + 19569
    14  Python                              0x0000000105cc93e2 PyEval_EvalCodeEx + 1562
    15  Python                              0x0000000105c6fce4 function_call + 327
    16  Python                              0x0000000105c52160 PyObject_Call + 97
    17  Python                              0x0000000105c5ca0d instancemethod_call + 163
    18  Python                              0x0000000105c52160 PyObject_Call + 97
    19  Python                              0x0000000105c9862e slot_tp_init + 64
    20  Python                              0x0000000105c9578c type_call + 182
    21  Python                              0x0000000105c52160 PyObject_Call + 97
    22  Python                              0x0000000105cce354 PyEval_EvalFrameEx + 19803
    23  Python                              0x0000000105cc93e2 PyEval_EvalCodeEx + 1562
    24  Python                              0x0000000105cc8dc2 PyEval_EvalCode + 32
    25  Python                              0x0000000105cea7ab run_mod + 49
    26  Python                              0x0000000105cea852 PyRun_FileExFlags + 130
    27  Python                              0x0000000105cea3d4 PyRun_SimpleFileExFlags + 706
    28  Python                              0x0000000105cfbf54 Py_Main + 3136
    29  libdyld.dylib                       0x00007fff50f50015 start + 1
)
libc++abi.dylib: terminating with uncaught exception of type NSException
fish: 'chirp' terminated by signal SIGABRT (Abort)

Updated by Tim Smith about 2 years ago

  • Chirp Version changed from 0.4.0 to daily

Hello! This was also reported to me as https://github.com/tdsmith/homebrew-ham/issues/10. It is associated with Homebrew upgrading their version of the gtk-mac-integration package.

I've worked around it by disabling the call to `macapp.set_dock_icon_pixbuf(icon_pixmap)`, which is ugly, but doesn't crash. I don't know why it's failing or who's doing what wrong. :) I don't see any matching reports on the GNOME tracker [1] but have not reported it myself.

For clarity, the KK7DS Python runtime is not required for the Homebrew installation method and won't help fix this crash.

[1] https://bugzilla.gnome.org/buglist.cgi?bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=NEEDINFO&bug_status=RESOLVED&bug_status=VERIFIED&f0=OP&f1=OP&f2=product&f3=CP&f4=CP&j1=OR&list_id=315072&o2=substring&order=changeddate%20DESC%2Cpriority%2Cbug_severity&query_based_on=&query_format=advanced&v2=gtk-mac-integration

Updated by Tim Smith about 2 years ago

  • Subject changed from crash with dump when trying to run Chirp on OSX to Chirp crashes in set_dock_icon_pixbuf on launch on OS X

Updated by Bernhard Hailer 2 months ago

  • Status changed from Feedback to Closed

Solution suggested; no more traffic on this ticket.

Also available in: Atom PDF