New Model #6525

Yaesu FTM-7250

Added by Walter O'Donnell over 1 year ago. Updated 3 months ago.

Status:Closed Start date:03/02/2019
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:-
Target version:chirp-daily
Chirp Version:daily Equipment Loan Offered:No

Description

Yaesu has a basic configuration for memory and settings plus dropped the price on this model making it more prominent in the market. It is a System Fusion model but the core is a basic dual band 50W rig. It ships with a Mini-USB cable for firmware updates but I am not sure if that can be used for memory and settings entry. Thank you for any assistance in adding this model to the program.

ftm7250d.py - FTM-7250D driver for Chirp (6.5 kB) Iain White, 06/29/2020 09:32 am

FTM7250D.patch - Mercurial patch file (7.2 kB) Iain White, 06/29/2020 12:38 pm

Yaesu_FTM-7250D.img - FTM-7250D image file (63.9 kB) Iain White, 07/11/2020 06:23 pm


Related issues

duplicated by New Model #6589: Yaesu FTM-7250DE Closed 03/10/2019
duplicated by New Model #7035: Yaesu FTM 7250 DE/DR Closed 09/04/2019

Associated revisions

Revision 3379:1ffec14eed99
Added by Iain White 3 months ago

Add new driver for the Yaesu FTM-7250D radio based on the FTM3200 driver Fixes #6525

Revision 3382:a226c8d23f91
Added by Dan Smith 3 months ago

Unregister ftm7250 because it conflicts with detection for the ftm3200

Related to #6525

Revision 3384:d3ad63e91000
Added by Iain White 3 months ago

Change FTM7250D driver class FTM7250Radio _model = "AH52N" to "AH75M" Fixes #6525

Revision 3386:02910ce19eef
Added by Iain White 3 months ago

Add FTM7250D image file for testing: Yaesu_FTM-7250D_R.img Issue #6525

History

Updated by Bernhard Hailer 8 months ago

  • Status changed from New to Feedback
  • Assignee deleted (Walter O'Donnell)
  • Priority changed from High to Normal

From duplicate request #7035:

Updated by Daniele Ciresa 5 months ago:
Molti usano il modello FTM-3200D per leggere/scrivere le informazioni sullFTM 7250 DE/DR con esito positivo, il problema è configurare le UHF poiché il 3200D è solo VHF, il cavo di programmazione è lo Yaesu CT-29F che usa la connessione microfono.

Italian post translated to English:
Many use the FTM-3200D model to read/write the information on the FTM 7250 DE/DR successfully. The problem is to configure UHF entries since the 3200D is only VHF. The programming cable is the Yaesu CT-29F which uses the microphone connection .

Updated by Hop VR2UHK 8 months ago

It seems that I cannot download from my FTM-7250DR when using FTM-3200D in Chirp.

In the debug log I did saw the radio spit out its model no.:
000: 41 48 37 35 4d 02 00 01 AH75M...
008: 01 00 00 00 00 00 00 00 ........

However, I got timeout error when downloading from my radio.
Any ideas?

Updated by Hop VR2UHK 8 months ago

I got it working now, turns out I am missing a 10K pull-up resistor from the DATA/PTT pin to +5V. I may try to modify the existing driver and push a patch to upstream.

Updated by Bernhard Hailer 7 months ago

  • Subject changed from FTM-7250 to Yaesu FTM-7250

Please keep us posted :-)

Updated by Iain White 3 months ago

I came up with a new driver for the FTM-7250D which is just a copy of the FTM3200 driver with a few modifications.
Driver filename is ftm7250d.py

The mods are:
1. change the radio name to FTM7250D
2. change the power level options to 5, 25, 50 Watts
3. change the prompt window text to reflect the 7250 cable connections and buttons to push for cloning (e.g. [GM AMS] key )
4. change the allowed bands to permit the 440 MHz band as the 7250 is 2M and 70cm

Still trying to work out how to test and then upload the code to Mercurial.
Hopefully more updates in a few days.

Updated by Iain White 3 months ago

Here is a first draft of the driver

Updated by Iain White 3 months ago

Mercurial patch file

Updated by Bernhard Hailer 3 months ago

Hi Iain, you might want to join the developer's mailing list and post your patch there. That will catch Dan's attention.
More details here: Developers.

Updated by Iain White 3 months ago

Bernhard,
I tried posting a patch to "" earlier today. I thought it worked, but I don't know if anyone has looked at it...

Iain

Updated by Iain White 3 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

Applied in changeset 1ffec14eed99.

Updated by Dan Smith 3 months ago

  • Status changed from Closed to In Progress

Re-opening this since the patch needs a fix to pass tests.

Iain, if you could also send a test image for tests/images for this radio with the fix, that'd be good.

Thanks!

Updated by Iain White 3 months ago

New patch created to change _model = "AH52N" to _model = "AH75M" to avoid conflict with FTM3200 driver

I will try to upload a test image file for the FTM7250D over the next couple of days.

Updated by Iain White 3 months ago

  • Status changed from In Progress to Closed

Applied in changeset d3ad63e91000.

Updated by John Owens N6JSO 3 months ago

Iain White wrote:

Applied in changeset d3ad63e91000.

Iain, can you clarify what cable you used with this? From notes above it looks like the Yaesu CT-29F might need some hardware modification to work? Or are you using this with the RT Systems USB-29F and is that cable actually different from the Yaesu one? Might be worth adding to the popup instructions on lines 85 and 92. 73!

Updated by Iain White 3 months ago

John,
I used a copy of the CT-29F that worked just fine without modification. It is sold on eBay by "Bluemax49ers" and uses an FTDI chip.
Best wishes, Iain

Updated by Iain White 3 months ago

Added an image file for the FTM-7250D for testing. Image was taken after a factory reset, plus it contains 2 memories with dummy data.

Also available in: Atom PDF

prevent spam