Bug #6601

FT-4 write to radio leads to error message

Added by Rob Hunter 6 months ago. Updated 6 months ago.

Status:Closed Start date:03/13/2019
Priority:High Due date:
Assignee:Daniel Clemmensen % Done:

100%

Category:-
Target version:chirp-daily Estimated time:4.00 hours
Chirp Version:daily Platform:All
Model affected:Yaesu FT-4XR

Description

I have a FT-4XR (USA model). I can read the data from the radio. I then wrote back to the radio and got 'error' when I keyed up. Reading the data back to Yaesu's own software showed that the TX frequencies for the repeaters I had programmed were all set to 0 MHz

Associated revisions

Revision 3211:d5bf16e01f12
Added by Daniel Clemmensen 6 months ago

[ft4] store tx freq correctly [#6601]

History

Updated by Daniel Clemmensen 6 months ago

  • Assignee changed from Rob Hunter to Daniel Clemmensen
  • Priority changed from Normal to High
  • Estimated time set to 4.00
  • Platform changed from Windows to All

I Just saw this and I have reproduced it on my FT-4. I hope to fix it by this evening.

Updated by Daniel Clemmensen 6 months ago

  • % Done changed from 0 to 90

Well that was interesting. The radio insists that you store the txfreq == rx freq, even if you are not "split" (i.e., if the "duplex" field is + or -). Weird, since you duplicate the RX value. Oh, well, I don't have to understand what the Yaesu programmer was thinking, only what he actually did.

Patch submitted. will close bug when it hits the daily build.

Updated by Dan Smith 6 months ago

Dan, I recently turned on keywords in redmine here, so if you reference your bug like this:

Fixes: #6601

Then redmine with automatically close it as complete with a reference to the commit once it gets applied to the tree.

Just FYI as it saves a step in cases where it makes sense.

Updated by Daniel Clemmensen 6 months ago

  • Status changed from New to Closed
  • % Done changed from 90 to 100

Thanks, Dan S. I will use that approach from now on. My thought was to wait until the daily build containing the fix was actually released, but automation and consistency are much better than developers making random decisions on bug closure.

Updated by Dan Smith 6 months ago

It's totally fine if you want to do it that way, but it usually means we forget and leave bugs open that were fixed long ago.

Anyway, just one tool for the belt. If you follow up like you have been, it's really up to you.

Also available in: Atom PDF