Feature #6619

Yaesu FT-65, 6.25 kHz stepping

Added by Rafal Renko over 3 years ago. Updated over 2 years ago.

Status:Closed Start date:03/17/2019
Priority:Normal Due date:
Assignee:Daniel Clemmensen % Done:

100%

Category:-
Target version:-
Chirp Version:daily Model affected:Yaesu FT-4, FT-65, FT-25

Description

New version of Chirp supports FT65 , but doesn't support step 6.25 kHz.
TRX supports step 6.25 kHz , and manually or in original sogtware there is possibility to use 6.25 kHz step.

Yaesu_FT-65R_20190320.img - FT-65E factory default settings (8.5 kB) Thom Barker, 03/20/2019 03:06 pm

Yaesu_FT-4XR_20190320.img - FT-4XE factory default settings (8.5 kB) Thom Barker, 03/20/2019 03:06 pm


Related issues

duplicated by Bug #7189: 6.25 step not available on Yaesu FT-4XE Closed 10/29/2019

Associated revisions

Revision 3298:d841aaba1977
Added by Bernhard Hailer over 2 years ago

[ft4] driver restructure (#7615)

While implementing two more radios of the Yaesu FT-4 family (the FT-25, see #7543, and the FT-4V, see #7387), I found that with some moderate reorganization, implementation of new radios will become easier. The proposed reorganization implements one more interstitial layer of inheritance to support the sub families of FT-4 (containing the FT-4X and FT-4V) and FT-65 (containing FT-65 and FT-25). Also, some variable assignments have been moved from the individual radio classes to the SCU-35 base class and to the interstitial classes named above.

This change also adds the infrastructure for adding European or Asian models, and as such prepare for addressing a number of currently open issues (6.25kHz tune step issues on EU models, frequency limitations; see #6619, #6651, #6677, #6761, #6869). It will also make it easier for a few additional fixes for issues which were found during my work on this driver (#7601, #7603, #7605). I will submit these fixes in additional patches.

Fixes: #7615

Revision 3308:9792a5917bf0
Added by Bernhard Hailer over 2 years ago

[ft4] Add Yaesu FT-65E. Fixes: #6619
This patch adds support for the Yaesu FT-65E to Chirp. It offers an additional tune step of 6.25 kHz.

Revision 3311:394e5664ab91
Added by Dan Smith over 2 years ago

Add test images for FT-25R, FT-4VR, FT-4XE, FT-65E

Related to #7189, #6619, #7387, #7543

History

Updated by Thom Barker over 3 years ago

Rafal Renko wrote:

New version of Chirp supports FT65 , but doesn't support step 6.25 kHz.
TRX supports step 6.25 kHz , and manually or in original sogtware there is possibility to use 6.25 kHz step.

That is because CHIRP does supports only the FT65R which is the USA version that does not allow the value of 6,25kHz for the channel step:
FT-65R (USA
FT-65E (Europe)

Same thing for the FT-4X, indeed CHIRP does support only the FT-4XR which is the USA version that does not allow the value 6,25kHz for the channel step:
FT-4XR (USA)
FT-4XE (Europe)

It would be nice if even the european versions were fully supported someday.
I guess it is not only matter to remove the 6,25kHz control on the channel step, though.
We will see.

Updated by Daniel Clemmensen over 3 years ago

  • Status changed from New to In Progress
  • Assignee set to Daniel Clemmensen
  • % Done changed from 0 to 50

Code is complete for this. The problem is testing, as I only have a FT-4XR. (Actually, there is extra code to suppress 6.25 kHz in the US version.)

I can make code available to anyone who wishes to test this. Might better to wait a bit and test the modified bandwidth constraints at the same time.

Updated by Thom Barker over 3 years ago

Daniel Clemmensen wrote:

Code is complete for this. The problem is testing, as I only have a FT-4XR. (Actually, there is extra code to suppress 6.25 kHz in the US version.)

I can make code available to anyone who wishes to test this. Might better to wait a bit and test the modified bandwidth constraints at the same time.

Glad to read that someone is working on this, thanks!
I own both Yaesu FT-65E and FT-4XE hence I could do tests if I get the code.
The only limitation is that I am working on Windows so I need the executable because I have not python and its libraries (https://chirp.danplanet.com/projects/chirp/wiki/DevelopersWin32Environment) and I would like not to have to install anything on the machine, as I am devote to use portable programs and I usually use standalone applications, which is also one of the reasons why I like CHIRP so much: it does not require installation.
I understand that what I can offer is not really help in the true sense of the word, but really I cannot do otherwise, sorry.
Now talking of the issues I do not know if the matter is tied to the fact I am using the european versions, but by working with the FT-4XE and FT-65E then many memories are missing while backing up on fresh factory default radios.
In my opinion would be also interesting compare things between USA and european versions.

Updated by Bernhard Hailer over 2 years ago

  • Subject changed from FT65 to Yaesu FT-65, 6.25 kHz stepping
  • Model affected changed from (All models) to Yaesu FT-4, FT-65, FT-25

Updated by Anonymous over 2 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 50 to 100

Applied in changeset 9792a5917bf0.

Also available in: Atom PDF