Bug #6681

Baofeng UV-5R refused to send second block 0x1f00

Added by Andrew Southern over 1 year ago. Updated about 1 month ago.

Status:Closed Start date:04/09/2019
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:Windows
Model affected:Baofeng UV-5R

Description

Having an issue communication with my radio. Radio refused to send second block 0x1f00 comes up.

I have tried downloading and loading the uv5r.py file but to no avail, I am still having the same issue.

the firmware displayed when On + 3 = BFB 298

Please help

I have 4 radios uv5r all with same issue. also im new to this and dont know how to acquire a debug file to show you my issues.

debug.log (23.4 kB) Loren Gibson, 04/29/2019 08:13 pm

debug.log (27.2 kB) Loren Gibson, 02/27/2020 04:51 pm


Related issues

duplicated by Bug #7115: Baofeng UV-5R "Radio refused to send block 0x0000" Closed 09/23/2019
duplicated by Bug #3345: Radio refused to send second block 0x1fc0 Closed 02/17/2016
duplicated by Bug #6857: Baofeng uv-5r Radio refused to send second block 0x1f00 Closed 06/13/2019

History

Updated by Loren Gibson about 1 year ago

I too am experiencing this issue with CHIRP daily-20190424 (just updated today), as well as the previous version which was installed on my Ubuntu computer. The error message "Radio refused to send second block 0x1f00" occurs when attempting to download from radio. My UV-5R version is also BFB298.

Updated by Jim Unroe about 1 year ago

  • Status changed from New to Feedback

Unfortunately the "On + 3" message has not been valid for over 5 years. All UV-5R radios report BFB297 (or BFB298) no matter what the "real" firmware version is. And BFB298 has traditionally indicated that the radio was a VHF/220 model (instead of the typical VHF/UHF model).

It appears that these radios are no longer returning the "ext memory" (the area of memory where the power-on message, band limits and squelch threshold settings are) to CHIRP.

Would you try the factory VIP software to see if you can change the power-on message?

Also the How To Report Issues page shows how to find the debug log in the 3 supported operating systems.

Jim KC9HI

Updated by Loren Gibson about 1 year ago

Thank you, Jim. Attached is my debug log from my Linux installation.

It appears that the factory VIP software is for Windows, and I don't have access to a Windows box. The URLs I found with software for the UV-5R are http://www.miklor.com/uv5r/UV5R-Software.php and http://www.baofengradio.com/endownload.asp?BigClassName=Programming%20Software&SmallClassName=&page=1. If there is no Linux version of the factory software, I won't be able to run it and attempt to change the power-on message.

You didn't ask for the firmware version (given that powering on with 3 held down is invalid), but I read http://www.miklor.com/uv5r/UV5R-FWRelease.php about how to find the firmware release using Chirp. I'm unable to figure out how to get a settings tab that appears about halfway down the page. If I do a File/New, the two tabs available are Memories and D-STAR.

My model is a UHF/VHF radio.

Loren

Updated by John McVeigh about 1 year ago

Gents,

What is the fix? I have 10 new uv-5r5's that report this error in Chirp. Yes, i have the latest build. Even reached out to baefong tech for support. Unfortunately the seller on Amazon is NOT on baefong tech authorized reseller & tech support is NOT supported. All older firware radios programmed perfectly. Just the new ones with (BFB298, power +3), won't program.

"An error has occurred. Radio refused to send second block 0x1f00."

Please assist!
thanks,
McFly255

Updated by John McVeigh about 1 year ago

FYI...
I have programmed 4 brand new Camo uv-5r5's with fireware HN5RV01. Inside sticker is different then the Black\Red uv-5r5's that i just got from amazon.
These ones r the issue.

thanks,
john

Updated by Loren Gibson about 1 year ago

I just acquired a second UV-5R, the second one being a 8W "Mirkit Edition" 2019 purchased on Amazon. CHIRP is working fine with this one. The Power-on+3 reports the same BFB298 (which I gather is no longer significant), and in CHIRP, Settings tab -> Other Settings -> Firmware Message 1 is HN5RV01. Firmware Message 2 is 1.

Is HN5RV01 the firmware version? It is the same as that reported above in message #5, but John experiences the problem.

I'm now running CHIRP daily-20190511, and I'm still getting the "refused to send second block" message on my first UV-5R, reported above in message #1.

Would I risk bricking my first UV-5R (the one I can't download from) if I attempted to upload one of the images from my Mirkit edition UV-5R? I suspect this is a poor idea, and I will not attempt this if there aren't assurances that it is safe to do so.

Many thanks,
Loren

Updated by John McVeigh about 1 year ago

I can NOT even download image from radio via Chirp. I immediately get error message once i click OK for initial download. Very frustrating.
john

Updated by John McVeigh about 1 year ago

Folks,

i'm at a loss on this error. just can NOT find the solution to this error. unless someone has something, i guess i will return to amazon.

john

Updated by John McVeigh about 1 year ago

8 out of 17 purchased uv-5r5's have error condition. sending back to amazon.
the other 7 programmed just fine. those 7 had firmware (HN5RV01 & 1FB297).

john

Updated by Jim Unroe about 1 year ago

According to the debug.log file, the radio is refusing to report its firmware version to CHIRP.

Jim KC9HI

Updated by David Baines about 1 year ago

It seems that most new UV-5R radios have this firmware. Not even the UV5R_W64_VIP software will read it, and fails with "Reading 3 Datablock" then Communication error.

If I hold down 6 and turn on radio it gives code 180531m if this helps?

Updated by Joao Carlos 10 months ago

David Baines wrote:

It seems that most new UV-5R radios have this firmware. Not even the UV5R_W64_VIP software will read it, and fails with "Reading 3 Datablock" then Communication error.

If I hold down 6 and turn on radio it gives code 180531m if this helps?

I have the same exact code when I hold down 6.

And have the same exact problem. Has anyone been able to solve this?

Updated by Bernhard Hailer 6 months ago

  • Tracker changed from New Model to Bug
  • Priority changed from Immediate to Normal
  • Target version set to chirp-daily
  • Model affected set to Baofeng UV-5R
  • Platform set to Windows

(Re-targeted this as "Bug", it's not a new model request.)

Updated by Bernhard Hailer 5 months ago

  • Subject changed from Radio refused to send second block 0x1f00 to Baofeng UV-5R refused to send second block 0x1f00

Updated by Loren Gibson 5 months ago

Update: Problem persists in CHIRP daily-20200227 for me.

Updated by Dennis Gonzales 4 months ago

A few days ago I had the same issue, then I tried pressing the connector firmly and it worked.
Firmware Message1: HN5RV01
6+PowerON: 180531
3+PowerON: BFB298

Error occurs if I don't press the connector firmly.
Press the connector firmly on the radio and it will download or upload to the radio.

Updated by Bernhard Hailer about 1 month ago

  • Status changed from Feedback to Rejected

Unfortunately, there isn't much Chirp can do when the radio doesn't report the firmware version.
The issue is that if Chirp uploads data to such a radio, it could potentially destroy it with data going into incorrect memory locations in the radio.
To prevent this, Chirp refuses to write data if it can't determine whether it's ok to do so - it needs the firmware version first.

Therefore, this request must be rejected. Sorry :-(

Updated by res eng about 1 month ago

It seems to me that 2 different problems have been lumped together here. One is a connector problem and the other is a protocol problem.
I had previously submitted a USB transcript showing that the radio was communicating correctly for the first half of the protocol. The subsequent second block did not work. No amount of connector pressing causes my radio to fail on the first part of the communication protocol. Only the second part of the protocol fails.
The connector has no "knowledge" of which part of the protocol is being sent, and therefore the connector cannot be smart enough to only fail on the second part of the protocol EVERY time. My suspicion is that my 2 radios have a different software version that is not compatible with Chirp. If you have no plans of ever fixing the issue, then please direct me to the most trouble-free cheap radio that is always compatible with Chirp and I'll buy it and support Chirp. Right now I don't trust either Chirp or the UV-5R . Cheers. RQ

Updated by Bernhard Hailer about 1 month ago

  • Status changed from Rejected to Feedback

I believe you are right.

Jim Unroe informed me that the issue where lack of firmware version data prevented an upload to the radio has been resolved. This should no longer be a problem with current daily releases.

Getting good electrical contact is definitely a huge problem with these cheap radios. They don't allow contact at all, or it's just good enough to cause trouble. It appears that many jacks don't go in far enough to ensure good contact. Some users reported that pressing the jack in firmly or holding it at an angle while uploading helps. That's the thing with cheap radios - you get what you pay for...

And then there are driver issues. If the cable is a Prolific, then there's a great chance that it contains a counterfeit chip, and then the (Windows) driver intentionally creates an unreliable connect. Here a driver downgrade might help: [[http://www.miklor.com/COM/UV_Drivers.php]]. MacOS is another story...

Updated by res eng about 1 month ago

After trying every version of Chirp known to man with my UV-5R, I decided to start shopping for a new handheld that is compatible with Chirp.
I stumbled upon the Revision list for the UV-5R on the baofengtech.com site. Apparently they removed cloning from the firmware. So now I have several good radios that are nearly impossible to program by hand? I guess the old UV-5R is the one to have. From my understanding, if you hold the "zero" key and the battery voltage momentarily pops up, then you likely have the UV-5R version that cannot be cloned. I will be experimenting with the UV-5R from this point on without trying to clone. If I brick-it, then I'm no worse off.
I cut and pasted the baofengtech website stuff below. Cheers.

Features - Updated Late 2013 ProducT Launch (2ND Gen.....
N5R Firmware (August 2014)
Hold '0' - Display Voltage
Removes Cloning Capabilities (Due to Several Firmware Edits)

VERSATILE RADIO FOR AMATEUR USE
The BaoFeng UV-5R is legal for use on amateur frequencies.

Updated by Bernhard Hailer about 1 month ago

  • Status changed from Feedback to Closed

Thanks for this feedback, and sorry that you hit a wall :-(
Yes, I remember having read elsewhere that there are some Baofeng radios around which refuse to clone.
And thanks for finding proof of it in the release notes. I'll take a note for a future FAQ.

If you still can, return these radios to the vendor. Cloning is a key feature; by killing it they make these radios harder to use.

Also available in: Atom PDF