Bug #7099

Chirp wont run in Ubuntu

Added by Charles Bingham 3 months ago. Updated about 1 month ago.

Status:New Start date:09/19/2019
Priority:High Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:Linux
Model affected:(All models)

Description

I wasn't able to get CHIRP to open after installing from the PPA so I downloaded the tar. I’m running Ubuntu 19.04 and have installed: python-gtk2, python-serial, python-libxml2. When I try to run the chirpw file downloaded directly form the site I get an error and it doesn't open. I think this might affect both the PPA and tar download. I am able to download and install this build on Windows 10.

Steps to reproduce:

1st Download chirp-daily-20190905.tar.gz
2nd tar chirp-daily-20190905.tar.gz
3rd cd chirp-daily-20190905
4th ./chirpw
5th Get error:

$ ./chirpw
Traceback (most recent call last):
File "./chirpw", line 20, in <module>
from chirp import chirp_common
File "/home/cdbingham/Desktop/chirp-daily-20190905/chirp/chirp_common.py", line 979
except errors.InvalidDataError, e:
^

If you need any more information let me know. Thanks in advance.

debug.log (21.1 kB) Charles Bingham, 09/24/2019 02:13 pm

History

Updated by Dan Smith 3 months ago

You're probably running it with python3 unintentionally. Try:

$ python2 chirpw

or

$ python2.7 chirpw

You might also run "dpkg -L" on whatever your python2-having package is to see where the python 2.x interpreter is.

Updated by Charles Bingham 3 months ago

When I run python -V I get: Python 3.7.3. So your right it’s not running 2 or 2.7.

When I specifically try python2 or python2.7, CHIRP now runs. I did get the following in the terminal, so I installed python-future:
$ python2 chirpw
WARNING: python-future package is not available; chirp.drivers.tk8180 requires it

I am now able to run the tar package thanks.

However, I'm still not able to get the package from the PPA to fully load. Is this related to the python version? I don’t know how to change that. When I try to open it from the applications list it starts to run but never fully loads (CHIRP in bar with spinning icon). I have attached the log file.

Updated by Charles Bingham 3 months ago

For some reason it cut off the bottom of the log file.

[2019-09-24 15:05:11,924] chirp.ui.mainapp - INFO: Skipping existing stock config
[2019-09-24 15:05:11,925] chirp.ui.mainapp - INFO: Skipping existing stock config
[2019-09-24 15:05:11,926] chirp.ui.reporting - INFO: Not reporting due to recent failure
[2019-09-24 15:05:11,926] chirp.ui.reporting - DEBUG: Reporting is disabled

Updated by GA-2S User about 1 month ago

WARNING: python-future package is not available; chirp.drivers.tk8180 requires it

Try running sudo -H pip install future to get the future package.

However, I'm still not able to get the package from the PPA to fully load

What is the error that apt-get install gives you?

Also available in: Atom PDF