Feature #8021

Requesting from Radioreference.com.com for a location outside of USA, ie the dreaded invalid county Id

Added by Jean Pichette over 1 year ago. Updated 10 months ago.

Status:Closed Start date:06/27/2020
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:-
Target version:chirp-daily
Chirp Version:daily Model affected:RadioReference

Description

Greets.

So, been fighting with this, and it’s obvious that the problem is that Chirp sends requests to radioreference.com using a Zipcode API which fails miserably for any non Us locale.
Can’t a dropdown to use “Metro Area” instead of Zipcode (with correct request natch) be added ?
It seems to be used for most Large countries.

Website searches using “County” as a droplist work, so that should be feasible. (No Zipcode search in Canada, but USA does get them, obviously)


Related issues

related to Bug #8133: RadioReference - "Server raised fault:invalid county id" Closed 07/25/2020
duplicated by Bug #5307: Error : "Unknown County Code" Closed 11/02/2017
duplicated by Bug #8061: RadioReference and Canada Closed 07/12/2020
duplicates Bug #2625: Country In Progress 06/02/2015
duplicates Bug #4941: Can not get in to Radio Reference Closed 06/23/2017
duplicated by Bug #8219: invalid county Closed 08/29/2020

Associated revisions

Revision 3431:e201a439edcc
Added by Mark Leigh 11 months ago

Added methods and UI to query/import RadioRef.com for Canada. Fixes #8021
My first foray into Python, so forgive anything that's not optimal.

user: Mark Leigh <>
branch 'default'
changed chirp/directory.py
changed chirp/radioreference.py
changed chirp/ui/mainapp.py

History

Updated by Bernhard Hailer over 1 year ago

  • Description updated (diff)
  • Status changed from New to Feedback
  • Target version set to chirp-daily
  • Model affected changed from (All models) to RadioReference

#4941 suggests that this has been resolved recently.
Did you try a recent build?

Updated by Jean Pichette over 1 year ago

Greets.

June 22nd 2020.
I did test with Actual american zipcodes, and it works for me. Completely useless, but it works. (90210, and a reserve one that I took from the report number in case the actual county ID was used to label the pdr reports generated.)

And tested queries at radioreference. (And double checked a dozen countries while editing this)

The entirety of this problem is that radioreference allows searches by Zipcodes , County and a few other options Like Metropolitan areas etc. . 
The options change by country.
Contrary to many databases they don’t seem to equate all the types of postal identifiers, so only real Zipcodes can be found by a zipcode search.
(Note The . Radioreference Website does not allow searching by postal code in canada, so may not actually have the information.)

Chirp ONLY offers to search by Zipcode.

Adding a County search would fix Canada
Adding a Region search would fix many countries, but not canada :) (This seems to be the default for the small countries with a single grouping)

So I’d suggest adding a pull down between Zipcode search, county, and Region. I think that would fix most countries.

P.s. I’m willing to do the entire research and check every listing To see if those 3 options would cover every countries. Might need a fourth, but I’d be surprised.

Jp

Updated by Jean Pichette about 1 year ago

Tested the July 11th release.

No improvement.

Just keeping this active :)

Updated by Jean Pichette about 1 year ago

Tested the july 22nd

Also, 4941 was a different (tho similar sounding issue) where a specific Zip code in Washington was buggy..

My issue is that there are no Zip Codes outside of the Us, and as long as Chirp will not provide a query by something other than a Zip Code, we can’t use it.
(Well, not the local frequency imports)

Updated by Mark Leigh 11 months ago

Yes, absurd that no one has tackled this... so I'm on it. Thank goodness it's open source.

Updated by Mark Leigh 11 months ago

A B wrote:

Yes, absurd that no one has tackled this... so I'm on it. Thank goodness it's open source.

Coming along. Probably a few days away from a pull request.

Updated by Mark Leigh 11 months ago

This is completed - for Canada!

The radio menu now has a submenu for RadioReference.com under which you can select Canada or USA. Inside the "Canada" option, you select Province and "county" (which is actually a mishmash of "Census geographic units" and Municipalities).

Currently excludes provincewide systems - but some ambitious human could probably take care of that.

I haven't pulled out a radio to test with, but import works well.

Enjoy! Pull request has been sent!

Updated by Mark Leigh 11 months ago

Mark Leigh wrote:

This is completed - for Canada!

On my version, radio menu now has a submenu for RadioReference.com under which you can select Canada or USA. Inside the "Canada" option, you select Province and "county" (which is actually a mishmash of "Census geographic units" and Municipalities).

Currently excludes provincewide systems - but some ambitious human could probably take care of that.

I haven't pulled out a radio to test with, but import works well.

Enjoy! Pull request has been sent!

Updated by Mark Leigh 10 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

Applied in changeset e201a439edcc.

Also available in: Atom PDF