Bug #8653

CHIRP Launches and Immediately Crashes on Mac, OS 10.12.6

Added by Steven Frischling over 1 year ago. Updated over 1 year ago.

Status:New Start date:01/04/2021
Priority:High Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Chirp Version:daily Platform:MacOS
Model affected:(All models)

Description

I downloaded the latest update to CHIRP and now it won't launch on my Mac, running 10.12.6.

Ever since I downloaded the update CHIRP appears to launch, bounces in the taskbar, then nothing. Dead, done, gone, nothing.

I deleted it and reinstalled previous versions that I knew worked, same issue. CHIRP will no longer launch them on my Mac either.

I have been on 10.12.6 for some time, as I can't upgrade this machine due to some software I need to use for work that requires I stay at this O/S.

Suggestions?


Related issues

related to Bug #8693: Mac 10.12 Crashing and wont open. Closed 01/18/2021

History

Updated by Christian Häusler over 1 year ago

I do experience the same behavior but with a recent version of macOS.

OS: macOS big Sur 11.11
Chirp: Installed using Homebrew (loaded from https://trac.chirp.danplanet.com/chirp_daily/LATEST/chirp-unified-daily-20210110.app.zip).

Process log does not look helpful to me but I have added it below anyway.

default    17:58:50.387764+0100    CHIRP    Received configuration update from daemon (initial)
default    17:58:50.391995+0100    CHIRP    CHECKIN: pid=36014
default    17:58:50.396903+0100    CHIRP    CHECKEDIN: pid=36014 asn=0x0-0x14a14a foreground=1
default    17:58:50.420865+0100    CHIRP    FRONTLOGGING: version 1
default    17:58:50.420892+0100    CHIRP    Registered, pid=36014 ASN=0x0,0x14a14a
default    17:58:50.423435+0100    CHIRP    BringForward: pid=36014 asn=0x0-0x14a14a bringForward=1 foreground=1 uiElement=0 launchedByLS=1 modifiersCount=1 allDisabled=0
default    17:58:50.423666+0100    CHIRP    BringFrontModifier: pid=36014 asn=0x0-0x14a14a Modifier 0 hideAfter=0 hideOthers=0 dontMakeFrontmost=0 mouseDown=0/0 seed=0/0
default    17:58:50.423784+0100    CHIRP    BringForward: pid=36014 asn=0x0-0x14a14a
default    17:58:50.423871+0100    CHIRP    SetFrontProcess: asn=0x0-0x14a14a options=0
default    17:58:50.442296+0100    CHIRP    Current system appearance, (HLTB: 2), (SLS: 1)
default    17:58:50.447951+0100    CHIRP    Post-registration system appearance: (HLTB: 2)
default    17:58:50.485572+0100    CHIRP    *** WARNING: Method userSpaceScaleFactor in class NSView is deprecated on 10.7 and later. It should not be used in new applications. Use convertRectToBacking: instead.
default    17:58:50.536094+0100    CHIRP    Entering exit handler.
default    17:58:50.536155+0100    CHIRP    Exiting exit handler.

Running chirp from the console gives me the following:

➜  ~ /Applications/CHIRP.app/Contents/MacOS/chirp           
Traceback (most recent call last):
  File "/Applications/CHIRP.app/Contents/MacOS/../Resources/chirp/chirpw", line 64, in <module>
    lc, encoding = locale.getdefaultlocale()
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/locale.py", line 545, in getdefaultlocale
    return _parse_localename(localename)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/locale.py", line 477, in _parse_localename
    raise ValueError, 'unknown locale: %s' % localename
ValueError: unknown locale: UTF-8

Updated by Derek Murphy over 1 year ago

Having exact same problem. There are many recommendations to change security setting to allow apps to run from unidentified developers - this does not work

I don't know if this has anything to do with but even after downloading the daily mac zip file it, terminal says that python is can't be located

Chirp guys, please take a look at the current MaxOSX suite for download.
(Running 10.12 here)

Updated by Derek Murphy over 1 year ago

Derek Murphy wrote:

Having exact same problem. Chirp icon is there, when clicking to open the application it simply bounces a few times in the bottom bar, then nothing happens and icon disappears.

There are many recommendations to change security setting to allow apps to run from unidentified developers - this does not work

I don't know if this has anything to do with but even after downloading the daily mac zip file it, terminal says that python is can't be located

Chirp guys, please take a look at the current MaxOSX suite for download.
(Running 10.12 here)

Updated by Rudolph Gutzerhagen over 1 year ago

First guess is that this is not an issue with Chirp. Can you try this please: look for settings on the app (and maybe the terminal) to set locale variables and uncheck them and then run Chirp. Let us know the result.

Updated by Derek Murphy over 1 year ago

Rudolph Gutzerhagen wrote:

First guess is that this is not an issue with Chirp. Can you try this please: look for settings on the app (and maybe the terminal) to set locale variables and uncheck them and then run Chirp. Let us know the result.

How do I do this? I'm not a computer pro
- there is no settings on the app as I can't get it to run whatsoever. Do you mean right click on the icon? If so there is no Settings
- If you're recommending to set locale variables, where Do i do this?

Thanks for the help

Updated by Derek Murphy over 1 year ago

If anyone can translate what this means for me

First I download the package. Not much of an extraction to do. The Chirp icon just appears
Click the Icon, starts to open, but app icon just bounces a few times then goes away

If right click and "Show Package Contents", inside I see a few files and folders.
Inside "Contents" folder
I go Contents/MacOS/chirp <-- this last one opens Terminal, where it starts to do this something then i get this:

Last login: Thu Jan 21 17:57:44 on ttys000
Derek-Murphys-MacBook-Pro:~ derekmurphy49$ /Users/derekmurphy49/Desktop/CHIRP.app/Contents/MacOS/chirp ; exit;
WARNING: python-future package is not available; chirp.drivers.anytone778uv requires it
WARNING: python-future package is not available; chirp.drivers.ga510 requires it
WARNING: python-future package is not available; chirp.drivers.ic2730 requires it
WARNING: python-future package is not available; chirp.drivers.tk8180 requires it
WARNING: python-future package is not available; chirp.drivers.tmd710 requires it
Traceback (most recent call last):
  File "/Users/derekmurphy49/Desktop/CHIRP.app/Contents/MacOS/../Resources/chirp/chirpw", line 131, in <module>
    from chirp.ui import mainapp
  File "/Users/derekmurphy49/Desktop/CHIRP.app/Contents/Resources/chirp/chirp/ui/mainapp.py", line 26, in <module>
    import gtk
  File "/Users/derekmurphy49/Desktop/CHIRP.app/Contents/Resources/site-packages/gtk/__init__.py", line 40, in <module>
    from gtk import _gtk
ImportError: dlopen(/Users/derekmurphy49/Desktop/CHIRP.app/Contents/Resources/site-packages/gtk/_gtk.so, 2): Symbol not found: _inflateValidate
  Referenced from: /Users/derekmurphy49/Desktop/CHIRP.app/Contents/MacOS/../Resources/lib/libpng16.16.dylib (which was built for Mac OS X 10.13)
  Expected in: /usr/lib/libz.1.dylib
 in /Users/derekmurphy49/Desktop/CHIRP.app/Contents/MacOS/../Resources/lib/libpng16.16.dylib
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.
Deleting expired sessions...none found.

[Process completed]

Also available in: Atom PDF