Bug #8693

Mac 10.12 Crashing and wont open.

Added by Bradley robinson robinson about 1 month ago. Updated 18 days ago.

Status:Feedback Start date:01/18/2021
Priority:High Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:MacOS
Model affected:(All models)

Description

I can not open CHIRP on my computer at all. I have absolutely no computer literacy to be able to begin to try and fix this. An elmer tried to use Team Viewer on my computer but because I can't update beyond 10.12 I can't use TeamViewer. Im completely lost and have no idea what Im doing.

debug.log (24.3 kB) Bradley robinson robinson, 01/18/2021 11:51 am


Related issues

related to Bug #8653: CHIRP Launches and Immediately Crashes on Mac, OS 10.12.6 New 01/04/2021

History

Updated by Dany L 19 days ago

First you need to disable your antivirus to run CHIRP.

Updated by Jim Unroe 18 days ago

  • Status changed from New to Feedback
  • Platform changed from Windows to MacOS

I think that the way CHIRP is packaged into a macOS Unified Application now, you must be using High Sierra (10.13) or later. At least that is what the error in the debug.log file would indicate to me.

ImportError: dlopen(/Applications/CHIRP.app/Contents/Resources/site-packages/gtk/_gtk.so, 2): Symbol not found: _inflateValidate
  Referenced from: /Applications/CHIRP.app/Contents/MacOS/../Resources/lib/libpng16.16.dylib (which was built for Mac OS X 10.13)

I believe that to run CHIRP on El Capitan (10.12) you would need to install the macOS Legacy Application which is no long kept current. The last available macOS Legacy Application version was chirp-daily-20201128.app.zip. You would also need to install the KK7DS Python Runtime.

CHIRP daily-20201128 builds
KK7DS Python Runtime files

Jim KC9HI

Also available in: Atom PDF