Bug #8683

Settings tab blank on Canadian model UV88

Added by Da Vee 5 months ago. Updated 2 months ago.

Status:Closed Start date:01/15/2021
Priority:Normal Due date:
Assignee:Jim Unroe % Done:

100%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:All
Model affected:TYT UV-88

Description

This issue seems to be a TYT UV-88 issue but its affecting CHIRP.
I've debugged a bit and my findings are below.
Attached is the .img file after doing a "Reset All"
The debug.log is from reading this configuration.

Thanks for supporting this radio.

1. What is the behavior you are seeing?
Settings tab is empty.

2. What is the behavior you were expecting?
Settings populated

3. Can you reproduce the problem all the time?
Yes

4. What are the steps required to reproduce the problem?
Download from radio.
View the Settings tab - It is empty.

5. Is this specific to a certain radio model (driver) or something that you can reproduce with another radio?
  • I'm sure it worked once before the radio was configured.
  • Factory fw version was UV88_Eng_BQ1_30_20200629.hex
  • All newer versions is showing this issue.
  • Debug log shows an exception. Upon further investigation I found the region is 0xFF and not handled by the region enumeration.

I worked around this by
options = ['Unlocked', 'Unknown 1', 'Unknown 2', 'EU', 'US']

try:

rx = RadioSettingValueList(options, options[_settings2.region])
except Exception:

LOG.debug("Region setting of %i is invalid. Assuming Unlocked" % _settings2.region)
rx = RadioSettingValueList(options, options0)*

rx.set_mutable(False)

debug.log - debug log (262 kB) Da Vee, 01/15/2021 06:54 pm

TYT_TH-UV88_20210115_Issue.img - img file downloaded from this radio. (8.8 kB) Da Vee, 01/15/2021 06:54 pm

TYT_TH-UV88_20210217_issue.img (8.8 kB) Tony Mattoni, 02/16/2021 11:45 pm

th_uv88.py - updated driver to use while waiting for patch to be accepted. (30.7 kB) Jim Unroe, 02/17/2021 04:47 pm

Associated revisions

Revision 3479:593602d6bafc
Added by Jim Unroe 4 months ago

[TH-UV88] Fix missing settings tab due to out-of-range value. #8683

This patch addresses the out-of-range (or lack of) region code that seems
to be present in more recent firmware versions by...

- extending the region code list for unknown values from 5 to 15.
- logging region code values from 5 to 15 to debug.log file.

With contributions from Ruddolph Gutzerhagen.

History

Updated by DJ kourampies 5 months ago

Same problem on mine, bought on Aliexpress, don't know if its meant for a specific region.

Updated by Tony Mattoni 4 months ago

CHIRP version daily-20201221 is working fine with TYT UV-88

Updated by Da Vee 4 months ago

Tony Mattoni wrote:

CHIRP version daily-20201221 is working fine with TYT UV-88

You are correct. I just verified on daily-20201221 and its working

Updated by Da Vee 4 months ago

Da Vee wrote:

Tony Mattoni wrote:

CHIRP version daily-20201221 is working fine with TYT UV-88

You are correct. I just verified on daily-20201221 and its working but not on latest.

Updated by Rudolph Gutzerhagen 4 months ago

The assessment about the region code appears to be correct. The image indicates a hex FF is passed from the radio. Chirp-20201221 and Chirp-20210212 handle this differently based on region code.

Updated by Jim Unroe 4 months ago

  • Status changed from New to In Progress
  • Assignee set to Jim Unroe
  • Target version set to chirp-daily
  • Platform changed from Windows to All

DJ kourampies wrote:

Same problem on mine, bought on Aliexpress, don't know if its meant for a specific region.

Has your radio been "unlocked"?
Attach an image for testing.

Updated by Tony Mattoni 4 months ago

Da Vee wrote:

Da Vee wrote:

Tony Mattoni wrote:

CHIRP version daily-20201221 is working fine with TYT UV-88

You are correct. I just verified on daily-20201221 and its working but not on latest.

Any later version than daily-20201221 is not working for me on Linux.

Updated by Jim Unroe 4 months ago

Tony Mattoni wrote:

Da Vee wrote:

Da Vee wrote:

Tony Mattoni wrote:

CHIRP version daily-20201221 is working fine with TYT UV-88

You are correct. I just verified on daily-20201221 and its working but not on latest.

Any later version than daily-20201221 is not working for me on Linux.

Yes. That's when the setting was added that radios like your broke. I plan on trying to find some time to look at it today.

Jim KC9HI

Updated by Jim Unroe 4 months ago

Tony Mattoni wrote:

Da Vee wrote:

Da Vee wrote:

Tony Mattoni wrote:

CHIRP version daily-20201221 is working fine with TYT UV-88

You are correct. I just verified on daily-20201221 and its working but not on latest.

Any later version than daily-20201221 is not working for me on Linux.

Thanks for adding your "image", Tony.

Jim KC9HI

Updated by Jim Unroe 4 months ago

  • File th_uv88.py added
  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

I just submitted a patch for approval. You can temporarily load the attached driver module to use while waiting for the patch to be accepted (or continue to use the older daily build).

Jim KC9HI

Updated by DJ kourampies 4 months ago

Thanks for the patch, indeed it works fine now on mine (no idea about hardware version, latest 2021 firmware.

Updated by Bernhard Hailer 2 months ago

  • Status changed from Resolved to Closed

Looks like this made it into the main branch.

Also available in: Atom PDF