New Model #9077

Add Baofeng GT-5R

Added by Dan Smith 4 months ago. Updated 3 months ago.

Status:Closed Start date:05/19/2021
Priority:Normal Due date:
Assignee:Jim Unroe % Done:

100%

Category:-
Target version:chirp-daily
Chirp Version:daily Equipment Loan Offered:No

Associated revisions

Revision 3507:55057cd5d54e
Added by Dan Smith 4 months ago

Add Radioddity GT-5R

This is a special version of the UV-5R with a requirement around
enforcing tx-inhibit outside of the legal limits.

#9077

Revision 3508:1ee9a4840389
Added by Dan Smith 4 months ago

Default to new-style detection for the GT-5R

Related to #9077

Revision 3514:4eefae328cf2
Added by Jim Unroe 4 months ago

[GT-5R] Fix TX-Inhibit Outside of Legal Limits

The current enforcement only allows TX on the following frequencies.
144.000, 148.000, 420.000 and 450.000 MHz.

This patch corrects the logic to allow TX on frequencies within the
144.000-148.000 MHz and 420.000-450.000 MHz ranges. Frequencies outside of
these ranges are set to Duplex = "off" (TX disabled).

Related to #9077

History

Updated by Jim Unroe 4 months ago

Nice. I just got mine yesterday. Thanks.

Jim

Updated by Bernhard Hailer 4 months ago

  • Status changed from New to Feedback

I assume this is complete?

Updated by Jim Unroe 4 months ago

  • Assignee set to Jim Unroe

Dan,

This patch does not work as intended.

    vhftx = [144000000, 148000000]
    uhftx = [420000000, 450000000]

    def set_memory(self, mem):
        # If memory is outside the TX limits, the radio will refuse
        # transmit. Radioddity asked for us to enforce this behavior
        # in chirp for consistency.
        if mem.freq not in self.vhftx and mem.freq not in self.uhftx:
            LOG.info('Memory frequency outside TX limits of radio; '
                     'forcing duplex=off')

vhftx and uhftx are lists with only 2 elements each.

mem.freq not in self.vhftx is always True except when 144000000 or 148000000
mem.freq not in self.uhftx is always True except when 420000000 or 450000000

This needs to be a VHF frequency >= 144000000 and < 148000000
and a UHF frequency >= 420000000 and < 450000000

I will work up a patch and submit it.

Jim KC9HI

Updated by Jim Unroe 4 months ago

  • Status changed from Feedback to In Progress
  • Target version set to chirp-daily

Updated by Jim Unroe 4 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Patch submitted.

Jim KC9HI

Updated by Jim Unroe 3 months ago

  • Status changed from Resolved to Closed

Patch accepted. Support will be in the next CHIRP daily build.

Jim KC9HI

Also available in: Atom PDF