Bug #9893

Flatpak

Added by Joe popinski 4 months ago. Updated 4 months ago.

Status:New Start date:05/27/2022
Priority:High Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Chirp Version:daily Platform:Linux
Model affected:(All models)

Description

updating Flatpak give this error:

Looking for updates…
Info: org.kde.Platform//5.15 is end-of-life, with reason:
We strongly recommend moving to the latest stable version of the Plaform and SDK
Applications using this runtime:
net.sourceforge.projectM
Info: org.freedesktop.Platform//19.08 is end-of-life, with reason:
The Freedesktop SDK 19.08 runtime is no longer supported as of September 1, 2021. Please ask your application developer to migrate to a supported version
Applications using this runtime:
com.danplanet.chirp
Info: org.freedesktop.Platform.GL.default//19.08 is end-of-life, with reason:
The Freedesktop SDK 19.08 runtime is no longer supported as of September 1, 2021. Please ask your application developer to migrate to a supported version
Nothing to do.

History

Updated by Joseph David 4 months ago

Joe popinski wrote:

updating Flatpak give this error:

Looking for updates…
Info: org.kde.Platform//5.15 is end-of-life, with reason:
We strongly recommend moving to the latest stable version of the Plaform and SDK
Applications using this runtime:
net.sourceforge.projectM
Info: org.freedesktop.Platform//19.08 is end-of-life, with reason:
The Freedesktop SDK 19.08 runtime is no longer supported as of September 1, 2021. Please ask your application developer to migrate to a supported version
Applications using this runtime:
com.danplanet.chirp
Info: org.freedesktop.Platform.GL.default//19.08 is end-of-life, with reason:
The Freedesktop SDK 19.08 runtime is no longer supported as of September 1, 2021. Please ask your application developer to migrate to a supported version
Nothing to do.

It looks like your system is out of date. Whatever software you are using to update Flatpak is suggesting that you update other parts of your system. This does not appear to be either a Chirp issue or a Flatpak issue.

Updated by Tony Fuller 4 months ago

Hi Joe,

The Freedesktop SDK 19.08 runtime is no longer supported as of September 1, 2021. Please ask your application developer to migrate to a supported version
Applications using this runtime:

com.danplanet.chirp

I think you have an outdated version of CHIRP installed. The latest flatpak uses the 21.08 Freedesktop SDK/Runtime. Uninstall the old CHIRP flatpak and install the latest one from https://trac.chirp.danplanet.com/chirp_daily/LATEST/
CHIRP is not published on flathub so you won't be able to take advantage of flatpaks auto-update mechanism.

Thanks,
Tony

Updated by Joe popinski 4 months ago

OK, installed new version from the link.
fixed my issue but,

any time there is an update to chirp i have to re download a new file?
when i update my flatpaks i use the command:

flatpak update

and thats where the previous error came from.

Updated by Tony Fuller 4 months ago

Hi Joe,

That is correct. CHIRP is not published on flathub so you won't be able to take advantage of flatpaks auto-update mechanism.

Thanks,
Tony

Updated by Tony Fuller 4 months ago

I also should have mentioned, if you are in need of an auto update feature and are willing to try snaps out I maintain https://snapcraft.io/chirp-snap

Tony

Also available in: Atom PDF