Bug #210

POSSIBLE bug (build 20120608) and Baofeng UV-5R

Added by Jim Moss about 7 years ago. Updated about 7 years ago.

Status:Closed Start date:06/09/2012
Priority:High Due date:
Assignee:Dan Smith % Done:

0%

Category:-
Target version:0.3.0
Chirp Version:0.2.2 Platform:Windows
Model affected:(All models)

Description

I don't know if this is Chirp related or not, but advising programmers of apossible issue.

After getting successful upload of UV-5R radio (thanks for Bug #202 fix!) I have a POSSIBLE related issue. After uploading image of UV-5R, I then imported a stored image from a Wouxun KG-UVD1P into the program and downloaded it to the UV-5R.

After it was done, a number of strange things started happening to the UV-5R;
  • The squelch is continously open
  • The FM receiver is inop (due to the open SQ?)
  • There is no TX on any channel
  • RX does not open on a strong signal (just quiet hissing) on any stored channel or the VFO

Users on http://groups.yahoo.com/group/baofeng_uv5r/ have also recently reported this issue and Chirp was mentioned as a programming path.

Per the suggestions on that site, I have reset the ratio (using Menu #40) and reinstalled my "original" imnage from both Chirp and the OEM s/w, all without a successful resolution. The channels in the individual images DO get into the radio, but still have the issues mentioned above.

Again, I do not know if this a Chirp issue or related to the OEM firmware.

UV-5R_BRICKED_IMAGE_BEFORE_VIP_RESET_ATTEMPT.img (6.4 kB) Jim Moss, 06/09/2012 08:22 pm

Dan_UV5R_Unbricked_Blank.img (6.3 kB) Dan Smith, 06/09/2012 09:03 pm

Associated revisions

Revision 1665:f7996093b944
Added by Dan Smith about 7 years ago

[uv5r] Fix incorrect download offset

This caused an off-by-8 error in the image, which resulted in people blowing
garbage (effectively) back into the auxiliary special block of their memory
and causing lots of trouble.
Fixes #210

History

Updated by Louis Sica about 7 years ago

Same issue here with the UV5r with the 6/8 daily build

Updated by Rob Walker about 7 years ago

Same issue with the 6/8 daily build.

Updated by Jim Unroe about 7 years ago

Same issue here with the UV5r with the 6/8 daily build

Updated by David Bowman about 7 years ago

Same issue here.

Updated by Dan Smith about 7 years ago

  • Status changed from New to Feedback
  • Assignee set to Dan Smith

Okay, first things first, lets try to rectify the situation. Using the OEM software to just read and write (or reset) the radio isn't going to resolve anything. You need to use the VIP software and use the "extra settings" thing (where the power-on message lives).

Open that up and write directly to the radio (don't read it first). Hopefully that will resolve things.

Second, if someone could post an image of their radio (as captured by CHIRP, NOT the OEM software) before they attempt the fix, that would be great.

Third, if anyone fixes their radio and can try breaking it again with CHIRP, please attach before/after images, as well as details about the procedure. I've not been able to reproduce it locally, so I'll need some help.

Thanks!

Updated by Jim Moss about 7 years ago

Dan,
Here are my findings in the attempt to restore the UV-5R:
1)Open OEM (VIP) software, open "Other" (see "UV-5R" in PONMSG, WRITE to radio = NO JOY, did not restore unit. SEE NOTES BELOW
2)Chirp image (biuld 20120608) of BRICKED radio: see attached file (UV-5R_BRICKED_IMAGE_BEFORE_VIP ...)
3) Unable to test further

Observations:
I did step #2 first (get image of bricked unit), shut down all apps, rebooted computer.

I then attempted #1. Upload looked to be successful but OLD VFO info was retained as was my OLD PONMSG (both lines 6 characters).

I then created a new image in the OEM software with the 2m and 70cm calling channels and uploaded it to the radio. my OLD PONMSG still remained but the channels were correct.

Also of note: my Kenwood/Wouxun/Baofeng USB cable has the "other than OEM" Prolific 2303 chipset. I am using the "correct" drivers for it.

I will keep the radio in its current state and be rady to assist you as you direct.

Jim
N9YKG

Updated by Dan Smith about 7 years ago

Okay, thanks for the details. I was able to successfully brick my radio with your image (hmm, sounds kinda weird). The good news is, I was able to unbrick it as well.

Please try to blow the attached image into your radio and report back. It should power on with an amber background and power-on messages of "AAAAAAA" and "BBBBBBB". It will be blank after that, but TX and battery levels should work fine.

Updated by Dan Smith about 7 years ago

Note that you need to use the 0608 build of chirp to upload that image. You should note that it doesn't question you about the model when you open it.

Updated by Rob Walker about 7 years ago

I just uploaded with the image Dan_UV5R_Unbricked_Blank.img. You are right, the chirp software didn't ask me what radio it was for, unlike the other image that I downloaded off of the radio. It also booted up with "AAAAAAA" and "BBBBBBB" like you said it would. The little Chinese lady who lives inside of the radio seems to have taken the night off. Menu 40 reset brought her back to life.

Do you need anything else? It looks like the problems is that chirp 2012.06.08 makes brick images. Is that correct?

Thanks,
Rob

Updated by David Bowman about 7 years ago

She was wide awake with I unbricked it. Thanks for all you do for us Dan!

Updated by Dan Smith about 7 years ago

  • Status changed from Feedback to Resolved
  • Priority changed from Normal to High
  • Target version set to 0.3.0

Okay, glad to hear it thanks.

Those of you that have unbricked with this process are good to go, except that you shouldn't use 0608 to download from your radio. I'll push a change up to the repo and push out another build. I'll also send unbricking instructions to the group.

Thanks for your help!

Updated by Jim Moss about 7 years ago

Dan,

You ARE the Man! Unbrick file worked flawlessly! I was also able to import the data from my Wouxun radio and SUCCESSFULLY upload it to the UV-5R!

Now, I just wish you could do the same for commercial radios (As if you don't already spend enough time in front of the CRT's, hi, hi!) as I just completed a 100 radio upgrade from "Bat Wings" to KW's (yes, it does happen, sometimes!) ... 4 different models to 3 models ... and my phat phingerz were tired after programming those 12 channels, over and over and over!

Thx again for this WONDERFUL program ... keep it coming ... we ALL need this!

73's
Jim
N9YKG

Updated by Dan Smith about 7 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF