Bug #272

CHiRP won´t start on any of my systems: UTF-8 in path

Added by Göran Berglind almost 10 years ago. Updated about 2 years ago.

Status:Closed Start date:08/10/2012
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Chirp Version:daily Platform:Windows
Model affected:(All models)

Description

I´ve got 3 PC:s, one running Win7 and the two others running Win XP SP3.
I´ve tried three different versions of CHiRP, stabel version 0.2.2, daily version 2012-07-30 and daily version 2012-07-27, the same error on every PC.
Installation goes OK, chirpw.exe starts according to TaskManager. A pop-up telling me that Error Reporting is enabled shows, when I hit the OK button in the pop-up winow CHiRP dies. Every time, repeatable.
The file debug.log shows the same errors regardless of hardware or CHiRP version.
73 de SA6AVT Göran

debug.log (3 kB) Göran Berglind, 08/10/2012 10:58 am


Related issues

related to Bug #2953: Bug at starting program Closed 10/27/2015
duplicated by Bug #1915: Chirp do not start in WIN XP Rejected 09/18/2014
duplicated by Bug #483: CHIRP will not run Windows XP Rejected 02/01/2013
duplicated by Bug #1631: Unicode character in path Closed 05/12/2014
duplicated by Bug #1685: Problem run program with russian characters in windows ac... Closed 06/07/2014
duplicated by Bug #427: The program will not run if the Windows user name contain... Rejected 01/14/2013
duplicated by Bug #4079: loading and saving files Rejected 09/28/2016
duplicated by Bug #2821: Startup under Windows 8.1 Closed 08/22/2015
duplicated by Bug #5087: Error reporting is enabled Rejected 08/21/2017
duplicated by Bug #4917: Same as Bug #272 Closed 06/15/2017
duplicated by Bug #310: Chirp doesn't work with Vista Rejected 09/18/2012

Associated revisions

Revision 2969:bbbe50c6a1e5
Added by Dan Smith about 4 years ago

Attempt to work around unicode pathing error on Windows

This is an attmept to work around bug #272 on Windows, where startup
fails because unicode characters in our default directory path cause
us to fail to join() in the ntpath.py module. Since copying stock
configs is what triggers this and causes chirp to just silently fail
to start up, we can just log and punt the issue. This should let us
start up (sans configs) and do stuff. I expect that as long as you
save files somewhere outside of a unicode-having path, it will work,
although config save at exit probably will fail (which is also non-fatal).

History

Updated by Göran Berglind almost 10 years ago

The problem is my username in Windows. I can´t use my real name Göran as username because Python can´t handle pathnames with funny letters like åäö.
Please close this issue.
Thank you.

Updated by Tom Hayward over 9 years ago

  • Subject changed from CHiRP won´t start on any of my systems to CHiRP won´t start on any of my systems: UTF-8 in path

I'm glad you found a workaround, but this is something Chirp should be able to support. I'll leave it open until a dev can test.

Updated by Bernhard Hailer about 2 years ago

  • Status changed from New to Closed
  • Chirp Version changed from 0.2.2 to daily

This is a known problem which has been haunting us for a long time. It appears that it's actually a problem in Python. Hopefully it's gone once we upgraded to Python 3?

Also available in: Atom PDF