Bug #2783

Daily Build 20150702 doesn't recognize multiple comm ports in Win 7/64

Added by Cecil Rendon about 5 years ago. Updated 6 months ago.

Status:Closed Start date:08/10/2015
Priority:Normal Due date:
Assignee:Dan Smith % Done:

0%

Category:-
Target version:-
Chirp Version:daily Platform:Windows
Model affected:(All models)

Description

I was running daily build 20150312 on Win 7 64 bit with no issues. I have 3 genuine FTDI cables on comm 13, 17 and 17 each for a different radio and all with no issues in device mngr using FTDI driver 2.12.0.0. I upgraded using chirp-daily-20150702-installer.exe to get support for the Baofeng UV82HP. When I did it only recognized comm 18. I downgraded back to 20150312 which I kept a copy of and all functions returned to normal. I used comm 13 for a download from a radio. Then I unplugged all cables and upgraded to 20150702 again and it listed comm 13 (the last used port) even though there was no such port active. I plugged in all cables again and it still only recognized comm 13. The single recognized ports in the upgrade did work when a cable was plugged in each time (18 then 13).

It seems that 20150702 only recognizes the last comm port used and no others in my environment. I worked with Jim Unroe on this through the Yahoo Groups following his suggestions to no avail.

Associated revisions

Revision 2591:853c2aa66578
Added by Alexey K about 5 years ago

[patch modified] doesn't recognize multiple comm ports in Win 7 - issue #2783

Description of the problem in the MSDN:

https://msdn.microsoft.com/ru-ru/en-en/library/aa363858(v=vs.85).aspx

"To specify a COM port number greater than 9, use the following syntax: "\\.\COM10".

This syntax works for all port numbers and hardware that allows COM port
numbers to
be specified."

But there is not quite right :) They write "\\.\COM10" it's not going to work.

Correctly so: "\\\\.\\COM10"

I tested on Win7x32, COM > 9. Work correctly.

Added fixes to the drop-down list of ports.
In the name of the port removing unnecessary characters for the user's convenience.

History

Updated by Jim Unroe about 5 years ago

  • Assignee changed from Jim Unroe to Dan Smith

Cecil,

I have confirmed this. I had to fall back to CHIRP daily-20150616 before port detection started working for all 256 Windows COM ports. This probably coincides with the changes to the Windows build station that occurred recently. I have changed the Assignee to Dan because he is probably the only one that can fix this.

In the mean time, you have 3 choices.

1. Install an use the CHIRP daily-20150616 build. It has the UV-82HP support that you are looking for.

2. Use the latest CHIRP daily build and only assign ports from COM1 though COM9 to your programming cable. It is the ports from COM10 though COM256 that are not detected with the builds since 20150616.

3. Use the latest CHIRP daily build and type in the COM port manually (COM13, COM17, etc.). This will work for all ports (COM1 through COM256).

Jim KC9HI

Updated by Cecil Rendon about 5 years ago

Any estimate yet which version will carry the resolution to this?

Updated by Alexey K about 5 years ago

  • Status changed from New to Feedback

The code CHIRP updated initialization of COM ports whose number in the operating system was greater than 9.

Updated by Jim Unroe about 5 years ago

I moved my programming cable to COM100, installed the 20151013 daily build and when downloading, the correct COM port was detected and displayed. Thanks.

Jim KC9HI

Updated by Bernhard Hailer 6 months ago

  • Status changed from Feedback to Closed

This appears to be complete.

Also available in: Atom PDF

prevent spam